Release

7.1.0 Released (Main)

Team,

PG 7.1.0 has been released which was the part of the 7.016beta series.  For future references, we will use the following scheme.  Currently, a snapshot of 7.1 has been made.  When there is a future update to a 7.2, we will use the snapshot and test against 7.1 to ensure there are no compatibility issues.  If there is for any reason an issue, we can create a patch to ensure that future major updates run smoothly!

The following changes have been made in 7.1.0 from 7.015:

  • New app deployment process
  • New cron interface and deployment
  • New ending interface
  • New appguard interface (ombi and other past apps will have zero issues now when used)
  • New portguard interface
  • New process interface
  • Tossed tons of useless ansible scripting
  • New flow processes
  • Easier to read yml’s for users of pgfork
  • Apps are now detected from /containers (meaning custom apps can be used, script reads directory)
  • Tons of bug fixes
  • Plex deployment tweaks
  • New container selection (pg will remember your prior selection for automatic rebuilds)

These changes will allow the building of new things to come:

  • pgbox – levels you can select to mass deploy or slim deploy certain apps (rather than one at a time)
    • new scripts allow this process to flow
    • no pauses issues
  • appvoyer – now that the apps build in a streamlined manner, can rebuild script. this will allow for better error checking
  • traefik – new coding techinques will streamline traffick
  • pgblitz – new coding techinques will allow updates to this including pgblitz for encryption
  • pgdrives – same as pgblitz

Team, thank you for your feedback, your assistance, and just being part of the team.  All we care about us noobs helping noobs and that’s what we are about 😀

Thanks,

The PG Team

——————-

If you want to donate to help miss admin, please do so for the holidays. If you do, send me a note for that reason also.  Funds collected; will purchase a gift and put everyone’s names on the box and post a picture during christmas.  Basically spent tons of time so I owe a gift to her (she is adversary #1) – https://plexguide.com/account/upgrades

If you also visit http://newshosting.plexguide.com – signups will count towards the process above. Again, just send me a note when you do!

Admin9705 posses a Masters Degree in Project Management and a Bachelors Degree in Business IT Administration. He currently posses nearly 40 certifications including CISSP, CCNP, and PMP. Admin9705 built this website being frustrated with all the fragmentary solutions all over the web. He enjoys running, coding, playing soccer, is a life learner and loves Final Fantasy!
Status
Not open for further replies.

IMDMonkey

PG Veteran
Member
Jun 2, 2018
16
7
Reactions
7 0 0
#2
Is it just me, or when I try to deploy Emby it is trying to deploy alltube instead....
 

Attachments

scrffybear80

PG User
Freelance Sponsor
Nov 18, 2018
8
2
Reactions
2 0 0
#3
Hey Admin .. Is there a way to get copies of the installer you had on the site earlier today. it was the the one that had 3 options with the 7.1beta and edge grouped under beta. I can't remember which one I used in that installer, but it seemed to be the most stable. This new installer keeps stalling on the script when you drive to mount the gdrive. Can you make those past versions you had on the site available.
 

cocainbiceps

PG Overlord
Freelance Sponsor
Jan 21, 2018
30
13
Reactions
13 0 0
#4
Should I do a complete re-install?
I'm not sure pgupdate is doing what it should be doing :lol:
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,990
1,699
Reactions
1,699 0 0
#5
Should I do a complete re-install?
I'm not sure pgupdate is doing what it should be doing :lol:
Run the installer again. There is a new pg command. It affextd users before pg 7.012

---- Automatically Merged Double Post ----

Hey Admin .. Is there a way to get copies of the installer you had on the site earlier today. it was the the one that had 3 options with the 7.1beta and edge grouped under beta. I can't remember which one I used in that installer, but it seemed to be the most stable. This new installer keeps stalling on the script when you drive to mount the gdrive. Can you make those past versions you had on the site available.
I will. Just note that before 7.012 u need to run the installer again . Your data is not lost.

---- Automatically Merged Double Post ----

Hey Admin .. Is there a way to get copies of the installer you had on the site earlier today. it was the the one that had 3 options with the 7.1beta and edge grouped under beta. I can't remember which one I used in that installer, but it seemed to be the most stable. This new installer keeps stalling on the script when you drive to mount the gdrive. Can you make those past versions you had on the site available.
added you asked, just run pgupdate. i'll change it so you can run any version, but after 7.1.0; i'll have it patch new upgrades such as 7.1 > 7.2
 
Last edited:

scrffybear80

PG User
Freelance Sponsor
Nov 18, 2018
8
2
Reactions
2 0 0
#7
Thank you Admin -- Left you a little something in your paypal!!!! :) Happy Coding!
 

pYTTH

PG User
Member
Nov 1, 2018
7
1
Reactions
1 0 0
#8
fresh install, been testing the 7.0.16 versions yesterday, now just upgdated to 7.1.0
for now no issues at all, seems to work great.
will keep you updated if i run into issues.

admin & team: well done! great job
 

timekills

PG Elite
Tech Support
Sep 12, 2018
183
105
Reactions
105 0 0
#9
Issue deploying bliztui container:

Where is the blitzui.yml file located now?
It isn't in /opt/plexguide/programs/containers/ or /opt/plexguide/containes.

The PG Blitz script looks in /opt/plexguide/programs/containers/blitzui.yml but couldn't find it. I didn't see it in the folders on the github page either.

Bash:
TASK [Launch Container Primary Information] *****************************************************************************************************************************************************
Sunday 25 November 2018  12:32:17 +0100 (0:00:00.349)       0:00:05.954 *******
fatal: [127.0.0.1]: FAILED! => {"reason": "Unable to retrieve file contents\nCould not find or access '/opt/plexguide/programs/containers/blitzui.yml'"}
        to retry, use: --limit @/opt/plexguide/programs/core/main.retry
 

JaksLax

PG Veteran
PG Donor
Jul 6, 2018
17
5
Reactions
5 0 0
#10
Thank you for all your amazing work. Thew some cash in your paypal account. Its not much, but all I could afford right now.
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,990
1,699
Reactions
1,699 0 0
#11
Not sure if it's just me but tried installing Plex on a fresh machine and 7.1.0 PG. 1st issue is it asks to claim the server once, then when you press [ENTER] it goes back through the install and asks you to claim it again.
Secondly, it's not appearing in my account to actually claim.

Anyone else confirm?

UPDATE: pgupdate to version 7.011 and re-ran plex install and it worked without issues, so it appears an issue with 7.1.0
I'll check, easy fix
 

timekills

PG Elite
Tech Support
Sep 12, 2018
183
105
Reactions
105 0 0
#12
Traefik install is still looking in /opt/plexguide/programs/containers for the yml files, so it errors out when rebuilding the containers.
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,990
1,699
Reactions
1,699 0 0
#13
Traefik install is still looking in /opt/plexguide/programs/containers for the yml files, so it errors out when rebuilding the containers.
no problem, working this now.
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,990
1,699
Reactions
1,699 0 0
#15

Qlogic

PG Elite
Member
Feb 24, 2018
101
16
Reactions
16 0 0
#16


---- Automatically Merged Double Post ----

Dont know if this is related but I upgraded and rebooted now plex is complaining ports are I use. And cannot bind. Any ideas. Or should I destroy the container and rebuld
 
Last edited:

Qlogic

PG Elite
Member
Feb 24, 2018
101
16
Reactions
16 0 0
#18
Trying to reinstall plex and stuck on creating directories
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,990
1,699
Reactions
1,699 0 0
#19
Trying to reinstall plex and stuck on creating directories
i'm going to take that piece out and add it to folder generation. a rare few people have issues with that (never had it)

---- Automatically Merged Double Post ----



---- Automatically Merged Double Post ----

Dont know if this is related but I upgraded and rebooted now plex is complaining ports are I use. And cannot bind. Any ideas. Or should I destroy the container and rebuld
just run

docker stop plex
docker rm plex

and go again, about to release 7.1.1 (so that folder fix will be there)

---- Automatically Merged Double Post ----



---- Automatically Merged Double Post ----

Dont know if this is related but I upgraded and rebooted now plex is complaining ports are I use. And cannot bind. Any ideas. Or should I destroy the container and rebuld
just run

docker stop plex
docker rm plex

and redeploy


Traefik install is still looking in /opt/plexguide/programs/containers for the yml files, so it errors out when rebuilding the containers.
are you sure, i made the changes awhile ago. cannot find it in any code

Snip20181125_25.png

changes made were

Snip20181125_24.png
Snip20181125_23.png

---- Automatically Merged Double Post ----

Is it just me, or when I try to deploy Emby it is trying to deploy alltube instead....
fixed for 7.1.1
 
Last edited:
Status
Not open for further replies.