Release

7.6 Changelog

Team,

NOTE:  Please see the 7.5 changelog if using a prior install about nzbget, sabnzbd, raddar, and sonarr

HOT:  To install, use the new installer on the install page!


Fixes for 7.6.12

PGFork has been repaired.  Update, run plexguide, and wait 1 min.  Commands update in the background.


Fixes for 7.6.11

AppGuard has been removed from SABNZBD, Tautulli, and NZBGET as where by default on new installs, the username and password is plex / guide.  We’ll continue to improve the security posture of the apps and reduce appguard to only work on apps with no protection.

To enforce, update to 7.6.11 and redeploy sabnzbd, tautulli, and or nzbget to remove appguard from working.  If the app is missing in pgbox, it’s ok; just type it and you can redeploy!


Fixes for 7.6.10 


Fixes for 7.6.9:

  • If using the 2nd disk option, the 2nd diskspace info will appear.  The picture is just a demo, but it’s set to only be turned on if the user is utilizing the 2nd disk option.


Fixes for 7.6.8:

  • Patched NZBGET.  One portion of nzbget was not exposed outward, thus casuing permission issues.   You should just be able to redeploy NZBGET and it should be working after that!  No changes to the config had to be made.
    • If it fails to still work – Please uninstall and reinstall nzbget if required.  Any containers talking to nzbget, please do a docker restart containername or reboot the server.  Please post any feedback!

Ran a test and file uploaded with NZBGET


Fixes for 7.6.7:

  • Made minor fixes for MultiHD Edition
  • Minor UI Touchups for MultiHD Editions


Fixes for 7.6.6:

  • Fixed changing server id issue under pgblitz (was reported)
  • Cleaned up main interface

Fixes for 7.6.5:

  • Fix for users whose sabnzbds and nzbd’s didn’t work.  May have to redeploy containers for folder recognition.  Root cause was turning folders into a subinstall, but would never complete or start; resulting in dud folders for several apps.

Fixes for 7.6.4:

  • When apps are deployed and a domain is not set, application pgbox does not output domain info as.  This is to help new users from being confused.

  • When plex is deployed, the output displays /web specifically for plex.  New users constantly had problems with plex due to the lack of /web.

 


Fixes for 7.6.3:

  • Removed tons of useless code
  • Cleaned up UI in several areas
  • moved location of logging file (may require deployment of pgblitz for accurate logging)
    • logging will eventually transition to a data movement log only
  • Kernal-Mode (Removed) as it may have caused many unbalanced changes

Fixes for 7.6.2:

  • Process Interface under settings is updated to new interface, made some minor bug fixes.


Fixes for 7.6.1:

  • Made changes to the server id to work with pgvault (please report any issues)
  • Fixed where it would exit when going back to main menu, if you have this problem on 7.6.1, please reupdate to 7.6.1 and the problem will go away.  The error was caught 20 minutes after the first release of it.

 


Version 7.6 is released with the following fixes:

  • fixed my containers; you can add your own custom containers (see the wiki)
    • they show up in pgbox install and remove
    • they will be part of pgcron when the app is installed
    • they will backup and restore in pgvault
  • cleaned up watchtower interface
  • new update allows  users to select any prior version; 7.6 and up; no longer bound to the few that are displayed
  • new pre-installer system; new format and less complex
  • sped up installer to enable mass execution install
  • sped up installer to enable subinstallers to execute while main executes
  • update commands: pgupdate, plexguide (improved streamlined execution)
  • plexguide starts faster upon startup
  • revamped and sped up inital installer script
  • plexguide versions pull independent of main project; pulls from a centralized source
  • removed useless code
  • removed ansible-toolbox from installation process
  • new pgupdate retrival system
  • new system allows you to type in any versions of plexguide (do not go below 7.6)
  • removed coding that would stall pg in certain areas at times

Admin9705 posses a Masters Degree in Project Management and a Bachelors Degree in Business IT Administration. He currently posses nearly 40 certifications including CISSP, CCNP, and PMP. Admin9705 built this website being frustrated with all the fragmentary solutions all over the web. He enjoys running, coding, playing soccer, is a life learner and loves Final Fantasy!
Status
Not open for further replies.

timekills

PG 1st Lieutenant
Coder
PG Donor
Sep 12, 2018
255
168
43
Reactions
168 0 0
#2
Some really impressive updates recently. I've donated to projects that were good before, but the management and focus on this has been outstanding.

Really appreciate the custom container addition - this will pay dividends in users experimenting and potentially developing application solutions usable by many.

Also, a little late but the 7.5+ improvement to PG Blitz including the search for "lost" files is great. It even seems to speed up the initial time to transfer for all files.

oh - and Merry Christmas!
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#2
it's the motivation and support of the members that drives the focus. plus using that pmp focus.
 
Last edited:

Uy9KC7OP2R2yn6TZVSMP

PG Specialist
Tech Lead
Mar 2, 2018
22
29
18
Reactions
29 0 0
#3
I was about to try out the latest 7.5 release :p - Looks like my timing was bad as it doesn't seem backwards compatible
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#4
I was about to try out the latest 7.5 release :p - Looks like my timing was bad as it doesn't seem backwards compatible
you can install 7.5 and 7.6 will install on top of it fine.
 

Uy9KC7OP2R2yn6TZVSMP

PG Specialist
Tech Lead
Mar 2, 2018
22
29
18
Reactions
29 0 0
#5
you can install 7.5 and 7.6 will install on top of it fine.
Thanks then I'll go ahead! Just made a small donation for the first time ever for such a project, it's perhaps not much but I had to at least give a thanks during the holidays for something which has been awesome for quite a while now.

Happy holidays pal
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#6
Thanks then I'll go ahead! Just made a small donation for the first time ever for such a project, it's perhaps not much but I had to at least give a thanks during the holidays for something which has been awesome for quite a while now.

Happy holidays pal
i've seen your username in the past believe (due to how crazy long it is) haha :D happy holidays to you. being a member counts most :D
 

Uy9KC7OP2R2yn6TZVSMP

PG Specialist
Tech Lead
Mar 2, 2018
22
29
18
Reactions
29 0 0
#7
i've seen your username in the past believe (due to how crazy long it is) haha :D happy holidays to you. being a member counts most :D
Yep we chatted on reddit I believe at first, then on slack, then discord and now here. I'm not very active in here but not a day goes by where I'm not playing with my plexguide setup :)
 

timekills

PG 1st Lieutenant
Coder
PG Donor
Sep 12, 2018
255
168
43
Reactions
168 0 0
#8
Yep we chatted on reddit I believe at first, then on slack, then discord and now here. I'm not very active in here but not a day goes by where I'm not playing with my plexguide setup :)
If I spent 10% as much time actually watching anything I have on the Plex setup as I spend "upgrading" it I'd probably have every movie released in the past 50 years watched by now.

"Everything is working great, time to relax and enjoy a...ooh look, a Plexguide update!"


P.S. yeah, yeah, I'll quit muddying up the forum post and leave it to relevant comments now.
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#8
haha trying to get the code down to prevent rewrites, i say it's about 75 percent there now. gotta fix the gce, a few of the tools, and options after; with the containers and wiki lol :D
 

yuvrajgill10

PG Specialist
Dec 1, 2018
21
3
8
Reactions
3 0 0
#9
If I upgrade from 7.5.4 to 7.6.1, do I still need to redeploy Sonarr, Radarr and my SABnzbd client? Seems to be working fine after upgrading...

Just tried installing NZBGet, but it keeps asking for a username and password like if I had App Guard deployed...but I removed App Guard and it still is coming up
 
Last edited:

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#9
It's Plex and guide. I'm working on app guard next to protect only containers without oortection only. Yes you'll have to redo them.
 

macfreaker

PG 2nd Lieutenant
Dedicated Sponsor
Jul 16, 2018
176
77
28
Belgium
Reactions
77 0 0
#10
I have a problem with sonarrbeta. NZBGet is downloading fine but the series are not copied to my tdrive. With Lidarr and Radarr I have no problem.
 
Dec 23, 2018
1
0
1
Reactions
0 0 0
#11

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#11

Taback

PG Sergeant
Mar 18, 2018
39
13
8
Reactions
13 0 0
#12
Getting this error when I backup sonarr/radarr container on 7.6.1.

1545732579482.png
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#12
so using 7.6.1, i just sent a file to google drive. all the commands show lsd. i know about ls being an error, but cannot find it in the code either.

1545759844765.png

1545759955001.png
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#13

mcap100

PG First Class
Dec 11, 2018
5
1
8
Reactions
1 0 0
#15
hi Admin9705,

Merry Christmas!! Love your work.

I Installed 7.6 last night on clean Debian 9.6 VM.

I tried to install Plex both public and plex pass editions. When I navigate to IP:32400 I get this:

CuUCwqj.png


Also, trying to update to 7.6.1 and this happens:

Screenshot at 09-43-17.png


Emby installs fine. I've restarted and reinstalled plex several times with no success.
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#15
rerun the installer and let me know if it fixes it. i have an idea what to do for this if it occurs to anyone again.
 

mcap100

PG First Class
Dec 11, 2018
5
1
8
Reactions
1 0 0
#18
rerun the installer and let me know if it fixes it. i have an idea what to do for this if it occurs to anyone again.
this fixed it. thanks...
 

yuvrajgill10

PG Specialist
Dec 1, 2018
21
3
8
Reactions
3 0 0
#19
It's Plex and guide. I'm working on app guard next to protect only containers without oortection only. Yes you'll have to redo them.
I'm not sure how to redo them; I've uninstalled and reinstalled nzbget multiple times but it still asks for a username and password
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,620
1,966
113
Reactions
1,966 0 0
#20
I'm not sure how to redo them; I've uninstalled and reinstalled nzbget multiple times but it still asks for a username and password
ya the username and password is plex / guide osrry had the firs one caps, it's in the wiki :D; i'll improve pg by adding special messages to each prodcut
 
Status
Not open for further replies.