7.4 Changelog

  • Guest - 7.5 will focus on bug fixing for all the containers including wiki writeup. Thanks to those who tested 7.4 (which will continue to receive minor updates). 7.5 should not be anything radical or drastic (unlike PGBox and PGClone).
Status
Not open for further replies.

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,988
1,698
Reactions
1,698 0 0
#1
Please report deployment of pgblitz and pgmove work out!  Tested, saw results fine; did on both debian and ubuntu!
Fixes Made to 7.4.13

Changed menu item for network auditor to display exit with Z instead of [4].  A visual fix.

Fixes Made to 7.4.12

Fixed PG to now overwrite previous key values for client id & secret; before it would just stack which was incorrect.  Thanks for those posting about the issue.  I would recommend to go through the process again so it launches correctly, please move off .11 soon as possible.  I used 2 different systems as a demo.


Fixes Made  for 7.4.11

GCrypt & TCrypt will now work.  When rclone.conf was rewritten, they were not tracked; thus not added causing the services to fail.  Works now.
PGBlitz out of Beta
Recommended if...
Continue reading...
 
Last edited:

bubbadk

PG Elite
Member
Mar 18, 2018
150
30
Reactions
30 0 0
#2
For me it still doesn't mount on gdrive, tdrive or unionfs :)

it's a fresh install on google vm
 
Assists Greatly with Development Costs

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,988
1,698
Reactions
1,698 0 0
#5
Assists Greatly with Development Costs

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,988
1,698
Reactions
1,698 0 0
#8
i selected pgblitz and 7.4.0 :)
Ya trying to simplify the set up. I know it will need touchups and more testing. Ya didn't test for GCE yet but know why that is happening.
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,988
1,698
Reactions
1,698 0 0
#10

bubbadk

PG Elite
Member
Mar 18, 2018
150
30
Reactions
30 0 0
#11
Now gdrive and tdrive is showing my stuff. Unionfs doesn't :)

using 7.4edge
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,988
1,698
Reactions
1,698 0 0
#12
Now gdrive and tdrive is showing my stuff. Unionfs doesn't :)

using 7.4edge
ok good to know, i didn't change anything on that end :D did you restart or just redeploy
 
Assists Greatly with Development Costs

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,988
1,698
Reactions
1,698 0 0
#13
Now gdrive and tdrive is showing my stuff. Unionfs doesn't :)

using 7.4edge
try

sunionfs and ls -la /mnt/unionfs and what do you get
 
Assists Greatly with Development Costs

meteo

PG Overlord
Tech Support
Nov 6, 2018
47
17
OZ
Reactions
17 0 0
#16
Testing out 7.4.2 on a brand new hetzner debian install. Run into problems.
Had issues earlier with keys, thought I would try again. Like the new layout btw!
All setup, deleted previous service accounts, generate new service accounts, bam.
Code:
cat: /var/plexguide/project.final: No such file or directory
Created service account [gdsa414293685].
ERROR: (gcloud.iam.service-accounts.keys.create) INVALID_ARGUMENT: Invalid service account email (gdsa414293685@.iam.gserviceaccount.com).
Hopefully it's easy enough to fix. Thanks again for all the hardwork and improvements :)


EDIT: Strange, once process completes it then shows 20 keys active with the right email/name attached.
But if you select the email generator to list them all for copy/pasting new teamdrive members it's blank.
 
Last edited:

meteo

PG Overlord
Tech Support
Nov 6, 2018
47
17
OZ
Reactions
17 0 0
#17
Found another bug with performance modes, though I think you mentioned Debian isn't entirely updated.
After viewing the processor policies rather then rebooting the machine it exits showing this line of code.
Code:
Press [ANY] Key to Continue - will reboot the machinebash: /opt/plexguide/roles/processor/scripts/processor-menu-new.sh: No such file or directory
Not script-breaking but a few typos here and there, will try and note them all down in future.
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,988
1,698
Reactions
1,698 0 0
#18
Found another bug with performance modes, though I think you mentioned Debian isn't entirely updated.
After viewing the processor policies rather then rebooting the machine it exits showing this line of code.
Code:
Press [ANY] Key to Continue - will reboot the machinebash: /opt/plexguide/roles/processor/scripts/processor-menu-new.sh: No such file or directory
Not script-breaking but a few typos here and there, will try and note them all down in future.
hey that's great info, i figured that and the modules need to hide if debian is dedicated.

Testing out 7.4.2 on a brand new hetzner debian install. Run into problems.
Had issues earlier with keys, thought I would try again. Like the new layout btw!
All setup, deleted previous service accounts, generate new service accounts, bam.
Code:
cat: /var/plexguide/project.final: No such file or directory
Created service account [gdsa414293685].
ERROR: (gcloud.iam.service-accounts.keys.create) INVALID_ARGUMENT: Invalid service account email (gdsa414293685@.iam.gserviceaccount.com).
Hopefully it's easy enough to fix. Thanks again for all the hardwork and improvements :)


EDIT: Strange, once process completes it then shows 20 keys active with the right email/name attached.
But if you select the email generator to list them all for copy/pasting new teamdrive members it's blank.
i believe it, i've seen that which is a focus for the next beta push. do you like the consolidation of stuff?
 
Assists Greatly with Development Costs

meteo

PG Overlord
Tech Support
Nov 6, 2018
47
17
OZ
Reactions
17 0 0
#19
Just waiting on fix for the key generation, can't get server up without them. If you need any more info just let me know. Everything seems configured correctly for generation/deployment. Menu layout is much cleaner and easier to navigate, do like it. Suggest after configuring gdrive/tdrive mark with asterix, thought my settings hadn't stuck and double-checked.

Touching base on the Debian performance modes again, when enabling performance it mostly works.

TASK [performance : Disable Scaling Frequency UB18] **********************************************************************
Friday 07 December 2018 05:50:23 +1000 (0:00:00.018) 0:00:01.659 *******
fatal: [127.0.0.1]: FAILED! => {"changed": true, "cmd": "systemctl disable ondemand", "delta": "0:00:00.002933", "end": "2 018-12-07 05:50:23.603037", "msg": "non-zero return code", "rc": 1, "start": "2018-12-07 05:50:23.600104", "stderr": "Fail ed to disable unit: No such file or directory", "stderr_lines": ["Failed to disable unit: No such file or directory"], "st dout": "", "stdout_lines": []}
to retry, use: --limit @/opt/plexguide/roles/processor/processor.retry


Fails on this one task, checking perfomance policies after running script shows jump from 800mhz to 4.6ghz idle.
 
Last edited:

Admin9705

Administrator
Project Manager
Jan 17, 2018
3,988
1,698
Reactions
1,698 0 0
#20
Just waiting on fix for the key generation, can't get server up without them. If you need any more info just let me know. Everything seems configured correctly for generation/deployment. Menu layout is much cleaner and easier to navigate, do like it. Suggest after configuring gdrive/tdrive mark with asterix, thought my settings hadn't stuck and double-checked.

Touching base on the Debian performance modes again, when enabling performance it mostly works.

TASK [performance : Disable Scaling Frequency UB18] **********************************************************************
Friday 07 December 2018 05:50:23 +1000 (0:00:00.018) 0:00:01.659 *******
fatal: [127.0.0.1]: FAILED! => {"changed": true, "cmd": "systemctl disable ondemand", "delta": "0:00:00.002933", "end": "2 018-12-07 05:50:23.603037", "msg": "non-zero return code", "rc": 1, "start": "2018-12-07 05:50:23.600104", "stderr": "Fail ed to disable unit: No such file or directory", "stderr_lines": ["Failed to disable unit: No such file or directory"], "st dout": "", "stdout_lines": []}
to retry, use: --limit @/opt/plexguide/roles/processor/processor.retry


Fails on this one task, checking perfomance policies after running script shows jump from 800mhz to 4.6ghz idle.
Ya there will be an icon or color code
 
Status
Not open for further replies.

PG Developer Donations

 

Forum statistics

Threads
2,365
Messages
14,360
Members
4,825
Latest member
lankanrebel