7.7 Changelog

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,682
1,987
113
Reactions
1,987 0 0
#1
Intro 7.7 Update
This version introduces the use of PG Defense /w PG Shield and Port Guard.  AppGuard has been tossed out the door and now you can utilize Google Authentication.  Why is this great? Because once you sign in, you authenticate across all your apps.  Some extra features have been added from lessons learned with AppGuard. Scroll down to the bottom for fixes 7.7.0 for the initial pictures.

You can authorize any email account to authenticate (meaning, yours, another one, your friends… whatever)
You can exempt apps from PG Shield.  For example, you may not want Google Authentication working on Ombi
REMEMBER, this is very new! Do not use on your production server; it works for me 😀

Please visit the wiki @ http://pgshield.plexguide.com
Since 7.7.0 is a bit in BETA, you can use PG 7.6 by checking what versions to use @ http://versions.plexguide.com

Fixes for 7.7.6 –...


Continue reading...
 
Last edited:

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,682
1,987
113
Reactions
1,987 0 0
#3
it was hell to code. between working parts from another project; then the interface and baking into plexguide.
 

pYTTH

PG 2nd Lieutenant
Tech Lead
Nov 1, 2018
187
62
28
97
127.0.0.1
Reactions
62 0 0
#4

MrDoob

PG Captain
Mod | Tech Lead
Mega Sponsor
PG Donor
Aug 4, 2018
304
108
28
31
GERMANY
Reactions
108 0 0
#6
oh admin you are and stay a junky code.

I'm about 2 years ago, as synonymous tried for my forum back then. I know exactly how difficult GAuth is to implement.

and that's why we all like to support you.
 

pYTTH

PG 2nd Lieutenant
Tech Lead
Nov 1, 2018
187
62
28
97
127.0.0.1
Reactions
62 0 0
#7
Bug 1: if you add a user and you misstype, let's say blabla"domain.com and you want to delete that, let's say pressing delete and put in blabla@domain.com and you add that user there's an error. if you show your users it says

Code:
blabla?@domain.com
so just make sure in case you misstype, go delete user and create a new one.


Bug2: stuck at google auth - choose your accounti can't get past that screen. user is added and shown correctly.i've logged out, tried in ingognito mode, other browser etc, if i log in it keeps asking me to choose the account (apperently the one added to PG) but nothing happens once you click it.
will try to investigate more but as far i can see there's no logs on pg site because it's on googles site, right?
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,682
1,987
113
Reactions
1,987 0 0
#8
Good reports. Will check! Use the logs on the the oauth container in portainer; access via oauth
 
Last edited:

daveftw84

PG Captain
PG Donor
Jan 18, 2018
302
78
28
Reactions
78 0 0
#9
im getting
This page isn’t working
plex.mydomian.net is currently unable to handle this request.

HTTP ERROR 500
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,682
1,987
113
Reactions
1,987 0 0
#10
im getting
This page isn’t working
plex.mydomian.net is currently unable to handle this request.

HTTP ERROR 500
I'm tracking how to fix the Plex issue. 7.7 is focusing on treafik. What about your other subdomains?
 

daveftw84

PG Captain
PG Donor
Jan 18, 2018
302
78
28
Reactions
78 0 0
#11
sorry i already went back down
 

shakazaz

PG First Class
Dec 23, 2018
4
3
3
Reactions
3 0 0
#12
Hi Admin,

I got the same error as in "bug2" from pYTTH (above) :

Bug2: stuck at google auth - choose your accounti can't get past that screen. user is added and shown correctly.i've logged out, tried in ingognito mode, other browser etc, if i log in it keeps asking me to choose the account (apperently the one added to PG) but nothing happens once you click it.
will try to investigate more but as far i can see there's no logs on pg site because it's on googles site, right?
Running it on a GCE instance. Traefik + PG Port guard working fine, everything HTTPS. I set new OAuth as Web, authorized my domain (which is using duckdns.org), added users to PG Shield. But I am stucked at google auth like pYTTH : it keeps asking to choose an account after I type password.

I am using version 7.7.1, I have re-deploy PG Shield after each update / changes.

From OAUTH container logs I just got this :

2018/12/30 15:38:02 Set CSRF cookie and redirecting to google login
2018/12/30 15:39:11 Set CSRF cookie and redirecting to google login
2018/12/30 15:45:04 Set CSRF cookie and redirecting to google login
.... and so on.

Anyway, thanks Admin for your great work that I just discovered a week ago. I am already a fan :)
 

rcarteraz

PG 2nd Lieutenant
Nov 14, 2018
138
40
28
Reactions
40 0 0
#14
I'm sorry, this doesn't make sense. I went to update my system and the highest it showed was 7.5.13, it also said that I need to install with V2 installer in order to update further as there was no 7.6 options. However after running the V2 installer the only options are 7.7.1. This post says 7.7 is in Beta. Why isn't there an option to select a non-beta version?
 

MrDoob

PG Captain
Mod | Tech Lead
Mega Sponsor
PG Donor
Aug 4, 2018
304
108
28
31
GERMANY
Reactions
108 0 0
#15
only typ

7.6.11 and press enter
what*s the Problem ?

you see the link or release and you can look witch one you want to install
 

rcarteraz

PG 2nd Lieutenant
Nov 14, 2018
138
40
28
Reactions
40 0 0
#16
only typ

7.6.11 and press enter
what*s the Problem ?

you see the link or release and you can look witch one you want to install
Okay, I see. It used to show the current versions and the versions in beta. I feel it only invites issues to show the most recent version as a beta version you don't recommend people installing on their production servers. They should be split like previously was done.
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,682
1,987
113
Reactions
1,987 0 0
#16
that's actually next on my to do list; when doing pgupdate, it will show the latest beta. the thing is this will require a future 7.6 or 7.7 update to start seeing
 

MrDoob

PG Captain
Mod | Tech Lead
Mega Sponsor
PG Donor
Aug 4, 2018
304
108
28
31
GERMANY
Reactions
108 0 0
#17
okay that's of course an argument. maybe admin will change it.
 

thepj

PG Master Sergeant
Tech Lead
Nov 13, 2018
91
57
18
Arizona, USA
Reactions
57 0 0
#18
Super excited about this, thank you very much. I'll wait until your next release and try this out!
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,682
1,987
113
Reactions
1,987 0 0
#20
Bug 1: if you add a user and you misstype, let's say blabla"domain.com and you want to delete that, let's say pressing delete and put in blabla@domain.com and you add that user there's an error. if you show your users it says

Code:
blabla?@domain.com
so just make sure in case you misstype, go delete user and create a new one.


Bug2: stuck at google auth - choose your accounti can't get past that screen. user is added and shown correctly.i've logged out, tried in ingognito mode, other browser etc, if i log in it keeps asking me to choose the account (apperently the one added to PG) but nothing happens once you click it.
will try to investigate more but as far i can see there's no logs on pg site because it's on googles site, right?
try the new 7.7.2 update
 

PG Developer Donations

 

Forum statistics

Threads
2,959
Messages
18,622
Members
5,920
Latest member
farmgirl