Sonarr - Adding qbittorrent-vpn to Sonarr | PlexGuide.com

Sonarr Adding qbittorrent-vpn to Sonarr

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

giannakis

Active
Original poster
Donor
Apr 23, 2019
30
7
Hello all,

I'm trying to connect qbittorrent-vpn to Sonarr's download clients however I can't make it to connect.
I tried different combinations of ports, names, with password, without password but I can't make it work.
Can anyone please help me with the correct settings?

Thank you!
 
  • Like
Reactions: 1 users

T-minator

Citizen
Mar 19, 2019
3
1
Try using the local ip ( eg 172.17.0.10 ) which is displayed in Portainer. This works for me. However, after each reboot, new IP addresses are assigned.
 
  • Like
Reactions: 1 user

mwest35

Citizen
Nov 19, 2019
9
4
Having the same issue. Tried the ip method and that doesn't work for me. Might be because I have ports closed... Anyone else have hny other suggestions?

Thanks!
 

mwest35

Citizen
Nov 19, 2019
9
4
update. So seems I can connect if I use the local host ip displayed in portioner for the bridge network (172.17.0.14 in my case) for the qbittorrent-vpn docker. No other method works. I have tried qbittorrent, qbittorrent-vpn, my local machine ip etc. This isn't the right behavior for Plexguide/PGblitz, so I wonder how we fix this? Any ideas?

FYI I've also added the traefik.docker.network:bridged fix into portioner to make the web-ui she properly

Thanks!

@drpegasus who was your response referencing? Hard to determine without being quoted.
Post automatically merged:
 
Last edited:

Methanoid

Experienced+
Nov 9, 2018
115
21
Is anyone actually working on a proper fix for this (where we can type "qbittorrent-vpn" and have it connect) ??? Or is this as good as it gets for good?
 

DavidWebb

Citizen
Aug 4, 2018
11
2
I just got it working for me! In the qbittorrent-vpn container, remove the Bridge network. Not sure if this is needed, but I also changed the LAN_NETWORK to:

LAN_NETWORK172.18.0.1/16

Also in the Web UI Settings, I enabled "Bypass authentication for clients in whitelisted IP subnets" and added "172.18.0.0/16". Now I have it in Sonarr / Radarr by name and without needing the username or password!
 

Methanoid

Experienced+
Nov 9, 2018
115
21
I just got it working for me! In the qbittorrent-vpn container, remove the Bridge network. Not sure if this is needed, but I also changed the LAN_NETWORK to:

LAN_NETWORK172.18.0.1/16

Also in the Web UI Settings, I enabled "Bypass authentication for clients in whitelisted IP subnets" and added "172.18.0.0/16". Now I have it in Sonarr / Radarr by name and without needing the username or password!
And this survives MANY multiple reboots? The other fixes work fine until for some reason Linux decides dockers need different IP addresses
 

doob

Administrator
Project Manager
Jun 7, 2020
971
509
Check the network on qbittorrent-vpn

Its need 2 networks

Plexguide
And
Bridge

Portainer > local > container > qbittorrent-vpn > duplicate/edit > networks
 

Methanoid

Experienced+
Nov 9, 2018
115
21
Check the network on qbittorrent-vpn

Its need 2 networks

Plexguide
And
Bridge

Portainer > local > container > qbittorrent-vpn > duplicate/edit > networks
Thanks Portainer > local > container > qbittorrent-vpn > duplicate/edit > network NOT networks yes?

If I select Bridge I get

Hostname 5a8f66b7a0f1
Primary DNS Server 1.1.1.1
Secondary DNS Server 84.200.69.80
(rest blank)

If I select plexguide I get SAME....

I dont think I am explaining this well.... Not sure I can tell which networks are active :-( Sorry
 

doob

Administrator
Project Manager
Jun 7, 2020
971
509
So the docker is in the plexguide and bridge network.
Post automatically merged:

See the screening and check it

When bridge or plexguide is missing add it
 

Attachments

  • Like
Reactions: 1 user

Methanoid

Experienced+
Nov 9, 2018
115
21
So the docker is in the plexguide and bridge network.
Post automatically merged:

See the screening and check it

When bridge or plexguide is missing add it
thanks, sorted now AND putting qbittorrent-vpn in works again with both networks present (unlike the advice from @DavidWebb - weird!)
 
  • Like
Reactions: 1 user

DavidWebb

Citizen
Aug 4, 2018
11
2
I'm no expert, but I have done a good bit of tinkering to try to get it working for me. I read a while back that someone else fixed it for themselves by removing the Bridge network. That is the only way I have ever been able to connect to it by name. Whenever I have the Bridge and Plexguide networks together, I can only connect to it by the Bridge IP. Name or Plexguide IP don't work.

If there is something that I can change to have both networks and connect by name, then that is likely the proper way to go about it. I just have never once see that work.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending