Apps opening through external domain but not ports? | PlexGuide.com

Apps opening through external domain but not ports?

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
Hi all,

I done a clean install of Ubuntu and set everything up again but this time Traefik appears to be working great now and Sonnar and nzbhydra can connect to Jackett's Torznab URL using the reverse proxy domain name (https://Jackett.domain/api etc etc) but now the apps won't work through ports so everything such as Jackett:9117 returns "jackett’s server IP address could not be found" so I seems to have fixed one thing and create another.. PG Guard Ports are still open as well.
 
Last edited:

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,117
Sorry it was just a typo, all apps won't open through their port number but work fine through domain.
have port guard deployed? it's the only thing that will close the ports
 

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
have port guard deployed? it's the only thing that will close the ports
No, I haven't touched PG Guard due to all the issues I was having before with the domain name not working so I wanted to try and get things working before doing any PG Guard setup but off the bat the apps all won't connect through the port number?.
 
S

subse7en

Guest
Port guard has nothing to do with the internal traefik url.

Again you must use http, not https like you're doing
 

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
Again, a bit of a typo/lack of info as I actually tried quite a few things prior to submitting this question I tried different variations http/https restarting docker containers, checking DNS in ubuntu network, double checking godaddy IP not that I know if any of that is relevant but yeah I certainly tried without https.

I've gone back into PlexGuide > PG Move and re-deploying to see if that fixes anything.

re-deploying did nothing, while it makes no sense I'm actually going to close the ports and open again as I'm not really sure what would block ports
 
Last edited:
S

subse7en

Guest
Again, a bit of a typo/lack of info as I actually tried quite a few things prior to submitting this question I tried different variations http/https restarting docker containers, checking DNS in ubuntu network, double checking godaddy IP not that I know if any of that is relevant but yeah I certainly tried without https.

I've gone back into PlexGuide > PG Move and re-deploying to see if that fixes anything.
You're doing something wrong then.

In hydra you add each jackett tracker

Like this:

http://jackett:9117/api/v2.0/indexers/scenefz/results/torznab

This url works when jackett and hydra on the same service with traefik deployed.

http://jackett:9117

You may have added it incorrectly to Hydra. Use a custom torznab url, don't use the jackett option when adding indexer

Make sure your API keys are right.
 

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
Again, a bit of a typo/lack of info as I actually tried quite a few things prior to submitting this question I tried different variations http/https restarting docker containers, checking DNS in ubuntu network, double checking godaddy IP not that I know if any of that is relevant but yeah I certainly tried without https.
You're doing something wrong then.

In hydra you add each jackett tracker

Like this:

http://jackett:9117/api/v2.0/indexers/scenefz/results/torznab

This url works when jackett and hydra on the same service with traefik deployed.

http://jackett:9117

You may have added it incorrectly to Hydra. Use a custom torznab url, don't use the jackett option when adding indexer

Make sure your API keys are right.
I'm waiting for PG Guard ports to close at the moment, but I mean in general without evening using an app they point blank don't load, http://jackett:9117 returns "ERR_NAME_NOT_RESOLVED" same for other apps. Torznab URL's work absolutely fine with "https://jackett.domain/api etc" but change that url to jackett:9117 or http://jackett:9117/api etc it immediately fails.
 

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
They are internal to traefik.... You can't load them in the browser. That's not how works, but they do work when it's app-to-app.

I use these urls everywhere.

Copy the url from jackett and just replace the domain part...

The url you put in hydra should look similar to this
http://jackett:9117/api/v2.0/indexers/scenefz/results/torznab
Hi mate,

I just had a go now and both Sonarr and nzbhydra have no issues with the Torznab URL being the domain or being the port (using HTTP) so yes everything seems to be working well for now!

Now I just need to continue the wiki to understand how to integrate Rclone and then purchase Hetzer for a month just get some content in :ROFLMAO:

Thanks for all the help!
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending