Discussion - Cannot have both the docker-py and docker python modules installed | PlexGuide.com

Discussion Cannot have both the docker-py and docker python modules installed

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

plexguideisdead

Citizen+
Original poster
Jan 21, 2018
28
7
Upgraded, try to install various tools, Now Showing, Traefik etc...

Code:
fatal: [127.0.0.1]: FAILED! => {"changed": false, "msg": "Cannot have both the docker-py and docker python modules installed together as they use the same namespace and cause a corrupt installation. Please uninstall both packages, and re-install only the docker-py or docker python module"}
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,112
Ya cocainbiceps, told you earlier on discord incase :D. it's ansible issue that i really haven't been able to chase down. if you type that error on the net, there's really no end solution. @designgears managed to overcome it once; check with him. but hopefully you backed up your data incase. a rare few have this issue between upgrades.
 

Niller2005

Citizen
Staff
Apr 5, 2018
4
4
I had the same thing on one of my servers. I did this and it fixed it:
Code:
pip2 install docker
pip2 install docker-py
pip3 install docker-py
pip install 'docker-compose>=1.7.0'
pip install 'docker-py>=1.7.0'
pip uninstall docker
pip uninstall docker-py
pip uninstall docker-compose
pip install docker-compose==1.9.0
pip uninstall docker
pip2 uninstall docker
pip3 uninstall docker
pip install --ignore-installed docker-py
pip2 install --ignore-installed docker-py
could be cleaner but I just got off work, so maybe I'll clean it later
 
  • Like
Reactions: 1 user

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,112
hey if it works, let me know @cocainbiceps; then can add to the troubleshoot
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,112

designgears

Active
Staff
Jan 21, 2018
35
17
Ya cocainbiceps, told you earlier on discord incase :D. it's ansible issue that i really haven't been able to chase down. if you type that error on the net, there's really no end solution. @designgears managed to overcome it once; check with him. but hopefully you backed up your data incase. a rare few have this issue between upgrades.
You posted it in the wiki somewhere.
 
  • Like
Reactions: 1 user

Recommend NewsGroups

      Up To a 58% Discount!

Trending