Discussion - Can't open for write without O_TRUNC | PlexGuide.com

Discussion Can't open for write without O_TRUNC

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

houseofpaul

Citizen+
Original poster
Jan 12, 2019
27
4
2019/08/05 01:12:21 ERROR : [removed file name]: WriteFileHandle: Can't open for write without O_TRUNC on existing file without --vfs-cache-mode >= writes

Getting this error in
/var/plexguide/logs/rclone-tcrypt.log
/var/plexguide/logs/rclone-gdrive.log

Plex is working fine, it doesn't seem to have an issue reading any file. I did update sonarr recently to update the file dates to the aired date which I have confirmed it is doing for recently downloaded files, the files listed in the logs though were downloaded prior to the config change.
 

houseofpaul

Citizen+
Original poster
Jan 12, 2019
27
4
Rclone settings

Upload Settings Default Current
[1] BW Limit [1000M]
[2] Drive-Chunk-Size 64M [64M]
[3] Transfers 8 [8]
[4] Max-Transfer 750G [750G]

⏬ Download Settings Default Current
[5] Buffer-Size 16M [16M]
[6] VFS-Read-Chunk-Size 64M [64M]
[7] VFS-Read-Chunk-Size-Limit 1024M [2048M]

? VFS Cache Mode Settings Default Current
[8] VFS-Cache-Mode writes [off]
[9] VFS-Cache-Max-Age 1h [1h]
[10] VFS-Cache-Max-Size 100G [off]


? Misc Settings Default Current
[11] Dir-Cache-Time 5m [2m]
[12] Log-Level NOTICE [NOTICE]
 

houseofpaul

Citizen+
Original poster
Jan 12, 2019
27
4
I've changed all the rclone settings to the default settings, so hopefully that will fix this.
 
M

MrDoob

Guest
Pgupdate to 8.7.5
And deploy the mounts again

Set the rclone settings to

Screenshot_20190805-174530_JuiceSSH.jpg

1) is user specific

The rest is optimal for all
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending