CloudFlare CDN nok working with non-native Plex apps

Assists Greatly with Development Costs

kamos69

Senior Member
Original poster
Donor
Local time
11:55 AM
Apr 22, 2018
127
67
Hi

This is sort of a bizarre issue which I'm really struggling to resolve. I recently implemented the Cloudflare CDN using Teresa's Tutorial: https://plexguide.com/wikis/cdn-content-delivery-network/

I have a few friends that use my PMS and a couple of them have reported connectivity issues after the CDN implementation. The one person uses Apple TV and the other person uses Chrome Cast. They both say that sometimes the server just goes offline or stops during playback. It works fine for me when I use the browser (chrome, firefox, safari, etc) or the Windows Plex App. Has anyone else had a similar experience? If so, what did you do to resolve it?

Also, Teresa's CDN configuration is different to the PG guide tutorial here: https://plexguide.com/wikis/cloudflare-and-traefik/. Specifically, the customer URL config in Plex and the disabling of remote server. I don't have much experience with CDN's so I'm not sure which one to use.

Any help would be appreciated.

Cheers
 

Stupifier

Senior Member
Staff
Donor
Local time
4:55 AM
Mar 18, 2018
134
56
The last link you dropped is a guide which outlines just using Cloudflare to set up your domain and link it up to Traefik....it is not a guide for setting up CDN
 
  • Like
Reactions: Admin9705

kamos69

Senior Member
Original poster
Donor
Local time
11:55 AM
Apr 22, 2018
127
67
The last link you dropped is a guide which outlines just using Cloudflare to set up your domain and link it up to Traefik....it is not a guide for setting up CDN
My apologies, I thought the CloudFlare setup was the "CDN" setup.
 

kamos69

Senior Member
Original poster
Donor
Local time
11:55 AM
Apr 22, 2018
127
67
No problem! Just wanted to clarify that point for ya. Should clear things up for you
Thanks. I would still like to know if anyone else has experienced the problem I mentioned in the Original Post.
 

armsby

Full Member
Staff
Local time
10:55 AM
Apr 28, 2018
32
19
I have on some apps, I can't get the PS4 app to work and the new iphone app has issues when it comes to music, or at least that is what im seeing
 
  • Like
Reactions: Admin9705

Admin9705

Administrator
Project Manager
Local time
4:55 AM
Jan 17, 2018
4,760
1,814
Anybody found a solution for this?
I wish I could, but don't run it with cloudflare. I'm going to test this later on, since I've been using CF for other things.
 

kamos69

Senior Member
Original poster
Donor
Local time
11:55 AM
Apr 22, 2018
127
67
I have on some apps, I can't get the PS4 app to work and the new iphone app has issues when it comes to music, or at least that is what im seeing
I can confirm that this issue has been resolved. They were specific to the platform and the Plex apps on those platforms. Both iOS and Android were fixed. The PS4 issue was related to the "Strict SSL" setting in Cloudflare Rules. That's also been resolved with one of the recent PS4 client patches.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Maintenance Donations

Recommend NewsGroups

      Up To a 58% Discount!

Trending