Discussion - cloudflare traefik setup | PlexGuide.com

Discussion cloudflare traefik setup

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

samodftw

Citizen+
Original poster
Feb 24, 2019
19
9
I'm trying to figure out what to put on the Traefik api key section for cloudflare domain. Where Can I find these api keys . On cloud flare website I have
Global API Key and Origin CA Key which one goes where?

Can I do it this way?

[6]** NOT SET - CF_API_EMAIL --------- Global API Key
[7] ** NOT SET - CF_API_KEY ---------- Origin CA Key
 
Last edited:
  • Like
Reactions: 1 user

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,112
  • Like
Reactions: 1 user

samodftw

Citizen+
Original poster
Feb 24, 2019
19
9
I read the article on the wiki . my cloudflare is setup according to the wiki. The only part I'm missing is the api keys which one goes where?
 
  • Skull
Reactions: 1 user
M

MrDoob

Guest
[6]** NOT SET - CF_API_EMAIL --------- your email.address of the cloudfare account
[7] ** NOT SET - CF_API_KEY ---------- the global api key


3054
 
  • Like
Reactions: 1 users

samodftw

Citizen+
Original poster
Feb 24, 2019
19
9
Thanks a lot for the help :) . Gonna try this out and report if it works.

Edit:
Its working now. Thank you alot!!!
 
Last edited:
  • Like
  • Love
Reactions: 2 users

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,112
I'm glad this new treafik deployment has been working out well
 
  • Like
  • Love
Reactions: 1 users

samodftw

Citizen+
Original poster
Feb 24, 2019
19
9
Now I'm having a problem with loading ,I'm runnin Ex42nvme from Hetzner here are the specs
i7 7700
64Gb ram
2x512 Nvme drives in raid0

When I start a movie its take 20 sec before it plays. and that"s the same if it's direct play or transcpding. If I try to download the file through browser I get around 5-6 MB/s.



Edit

After some tinkering I was able to load files in less than 3 sec and also directplay for the first time . Right now its all automated and running flawlessly :D
 
Last edited:
  • Like
Reactions: 1 user

fyrstrm

Experienced
Donor
May 1, 2020
88
31
Is there a way to find out why my Traefik config keeps failing when setting up? I've triple checked everything, have test the ports and ping outside and everything looks good. I did notice that there are two different APIs. there's the global account ones in CF and there's also inquiry APIs listed under the domain. should i be using that one instead of the global API?
Post automatically merged:

Is there a way to find out why my Traefik config keeps failing when setting up? I've triple checked everything, have test the ports and ping outside and everything looks good. I did notice that there are two different APIs. there's the global account ones in CF and there's also inquiry APIs listed under the domain. should i be using that one instead of the global API?
How would I know if i hit my LE limit? i was fiddling around under windows this past week and i suppose that's possible.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending