Database Locked Errors

timmeh

Respected Member
Original poster
Local time
5:43 AM
Feb 14, 2019
82
18
I am getting database locked errors within Sonarr which is (seemingly) preventing Sonarr and NZBget sharing download information as no download information is getting through to NZBget. Getting quite frustrating and no amount of research online is helping. I'm at the point now where I'd actually pay someone to get Sonarr working for me as I've been tinkering with PGBlitz for over a week now and Sonarr has never worked. I've setup 4 different fresh installs and none have succeeded. Current error messages are:

[v2.0.0.5322] System.Data.SQLite.SQLiteException (0x80004005): database is locked

database is locked

at System.Data.SQLite.SQLite3.Step (System.Data.SQLite.SQLiteStatement stmt) [0x00088] in <61a20cde294d4a3eb43b9d9f6284613b>:0

at System.Data.SQLite.SQLiteDataReader.NextResult () [0x0016b] in <61a20cde294d4a3eb43b9d9f6284613b>:0

at System.Data.SQLite.SQLiteDataReader..ctor (System.Data.SQLite.SQLiteCommand cmd, System.Data.CommandBehavior behave) [0x00090] in <61a20cde294d4a3eb43b9d9f6284613b>:0

at (wrapper remoting-invoke-with-check) System.Data.SQLite.SQLiteDataReader..ctor(System.Data.SQLite.SQLiteCommand,System.Data.CommandBehavior)

at System.Data.SQLite.SQLiteCommand.ExecuteReader (System.Data.CommandBehavior behavior) [0x0000c] in <61a20cde294d4a3eb43b9d9f6284613b>:0

at System.Data.SQLite.SQLiteCommand.ExecuteScalar (System.Data.CommandBehavior behavior) [0x00006] in <61a20cde294d4a3eb43b9d9f6284613b>:0

at System.Data.SQLite.SQLiteCommand.ExecuteScalar () [0x00006] in <61a20cde294d4a3eb43b9d9f6284613b>:0

at Marr.Data.QGen.InsertQueryBuilder`1[T].Execute () [0x00046] in C:\BuildAgent\work\5d7581516c0ee5b3\src\Marr.Data\QGen\InsertQueryBuilder.cs:140

at Marr.Data.DataMapper.Insert[T] (T entity) [0x0005d] in C:\BuildAgent\work\5d7581516c0ee5b3\src\Marr.Data\DataMapper.cs:728

at NzbDrone.Core.Datastore.BasicRepository`1[TModel].Insert (TModel model) [0x0002d] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Datastore\BasicRepository.cs:111

at NzbDrone.Core.Messaging.Commands.CommandQueueManager.Push[TCommand] (TCommand command, NzbDrone.Core.Messaging.Commands.CommandPriority priority, NzbDrone.Core.Messaging.Commands.CommandTrigger trigger) [0x0013d] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Messaging\Commands\CommandQueueManager.cs:82

at System.Dynamic.UpdateDelegates.UpdateAndExecute4[T0,T1,T2,T3,TRet] (System.Runtime.CompilerServices.CallSite site, T0 arg0, T1 arg1, T2 arg2, T3 arg3) [0x00035] in <7aa7d6192efc4d31a9896d7a49ef2104>:0

at (wrapper delegate-invoke) System.Func`6[System.Runtime.CompilerServices.CallSite,NzbDrone.Core.Messaging.Commands.CommandQueueManager,System.Object,NzbDrone.Core.Messaging.Commands.CommandPriority,NzbDrone.Core.Messaging.Commands.CommandTrigger,System.Object].invoke_TResult_T1_T2_T3_T4_T5(System.Runtime.CompilerServices.CallSite,NzbDrone.Core.Messaging.Commands.CommandQueueManager,object,NzbDrone.Core.Messaging.Commands.CommandPriority,NzbDrone.Core.Messaging.Commands.CommandTrigger)

at (wrapper dynamic-method) System.Object.CallSite.Target(System.Runtime.CompilerServices.Closure,System.Runtime.CompilerServices.CallSite,NzbDrone.Core.Messaging.Commands.CommandQueueManager,object,NzbDrone.Core.Messaging.Commands.CommandPriority,NzbDrone.Core.Messaging.Commands.CommandTrigger)

at NzbDrone.Core.Messaging.Commands.CommandQueueManager.Push (System.String commandName, System.Nullable`1[T] lastExecutionTime, NzbDrone.Core.Messaging.Commands.CommandPriority priority, NzbDrone.Core.Messaging.Commands.CommandTrigger trigger) [0x000b7] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Messaging\Commands\CommandQueueManager.cs:95

at NzbDrone.Core.Jobs.Scheduler.ExecuteCommands () [0x00043] in C:\BuildAgent\work\5d7581516c0ee5b3\src\NzbDrone.Core\Jobs\Scheduler.cs:42

at System.Threading.Tasks.Task.InnerInvoke () [0x0000f] in <2943701620b54f86b436d3ffad010412>:0

at System.Threading.Tasks.Task.Execute () [0x00000] in <2943701620b54f86b436d3ffad010412>:0
Incidentally, Radarr works fine and all movies are picked up in Plex perfectly. Have not tried Lidarr yet...

Latests research points to permissions errors, but I cannot for the life of me see where in this process I had selected the incorrect permissions. Any advice, support, or offers of help welcome at this stage! :)

TIMMEH!!!
 

Admin9705

Administrator
Project Manager
Local time
12:43 AM
Jan 17, 2018
4,760
1,810
You'll have to check with the Sonarr crew because when it says the database is locked, it's an error on their end. I have seen this happen on my end before way back; but not for a while. Using v3 of Sonarr, this has not come up.
 

PlexFan

Respected Member
Staff
Local time
12:43 AM
Aug 8, 2019
53
8
Came across this myself in the version 2 of sonarr. no issues with v3.
 

timmeh

Respected Member
Original poster
Local time
5:43 AM
Feb 14, 2019
82
18
Interesting. I've updated and the error I get with V.3 is:
[Fatal] ConsoleApp: Address already in use. This can happen if another instance of Sonarr is already running another application is using the same port (default: 8989) or the user has insufficient permissions

Press enter to exit...
It's looking very much like a permissions issue. Do you know how I give Sonarr permission to access to write to nzbdrone.db?
 
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Members online

Maintenance Donations

Recommend NewsGroups

      Up To a 58% Discount!

Trending