Discussion - Docker fails at boot 'Unable to break cycle' | PlexGuide.com

Discussion Docker fails at boot 'Unable to break cycle'

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

nj543

Citizen
Original poster
Oct 25, 2019
13
2
I keep finding docker crashing after boot. This started happening on 2 machines after I ran a standard apt-get upgrade. Upon boot I get the error below in my logs each time and I need to manually restart the docker service. I'm a linux novice so any suggestion on where to look is appreciated. I also am getting an error after the system is running 24-36 hours where the mount drops detailed here: 'Transport endpoint not connected'


Appreciate any suggestions for either problem.

Code:
systemctl status docker

 docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
  Drop-In: /etc/systemd/system/docker.service.d
           └─override.conf
   Active: inactive (dead)
     Docs: https://docs.docker.com

Apr 03 17:44:17 ParmarServer systemd[1]: docker.service: Found ordering cycle on pgunion.service/start
Apr 03 17:44:17 ParmarServer systemd[1]: docker.service: Found dependency on multi-user.target/start
Apr 03 17:44:17 ParmarServer systemd[1]: docker.service: Found dependency on docker.service/start
Apr 03 17:44:17 ParmarServer systemd[1]: docker.service: Unable to break cycle starting with docker.service/start
Code:
17:43:43 pulseaudio: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
17:43:32 systemd: docker.service: Unable to break cycle starting with docker.service/start
17:43:23 pulsewayd: Error while registering computer:SOAP 1.1 fault SOAP-ENV:Server[no subcode]
"Host not found"
Detail: get host by name failed in tcp_connect()
17:43:20 spice-vdagent: Cannot access vdagent virtio channel /dev/virtio-ports/com.redhat.spice.0
17:43:17 pulsewayd: Error while registering computer:SOAP 1.1 fault SOAP-ENV:Server[no subcode]
"Host not found"
Detail: get host by name failed in tcp_connect()
17:43:14 systemd: Failed to start Raise network interfaces.
17:43:14 dhclient: exiting.
17:43:13 cron: Error: bad username; while reading /etc/crontab
 
Last edited:

Edrock200

MVP
Staff
Nov 17, 2019
542
195
It seems like your dhcp client is randomly having issues renewing your IP address, which is killing your network stack upon renewal/reboots, and dropping your mounts. Is this a hetzner box, vps, home server, something else? If it's a vps, dedi or home box and you've been provisioned a static IP or are using a NAT ip I would try setting your host to static IP address and see if the symptoms go away.
Post automatically merged:

If your 1.x network is internal only (i.e. doesn't have a path to the internet) then you don't need a gateway defined. You can try the linux route command to see if it will let you force all traffic through the 2.x route as well.
Post automatically merged:

If your 1.x network is internal only (i.e. doesn't have a path to the internet) then you don't need a gateway defined. You can try the linux route command to see if it will let you force all traffic through the 2.x route as well.
 
Last edited:
  • Like
  • Love
Reactions: 2 users

nj543

Citizen
Original poster
Oct 25, 2019
13
2
Thanks, that gave me something to look into. So I have 2 network connections, one just for local traffic on my network that connects to my NAS (192.168.1.x) and the other for direct internet connection on a separate IP (192.168.2.x) . I have struggled finding a way to make Ubuntu consistently use .2.x for internet. The only way that seems to work after reboot is to set the gateway for .1.x to blank/local to force it to always use .2.x. Changing the priority seems to only work temporarily. This solution seems to be the issue with docker.

Any suggestions on how to leave the network gateway there but force that connection to always be priority? ifmetric setting seems to be ignored
 
  • Like
Reactions: 1 user

Recommend NewsGroups

      Up To a 58% Discount!

Trending