Does GCE need NVME drives? | PlexGuide.com

Does GCE need NVME drives?

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

vFlagR

Experienced+
Original poster
Staff
Aug 27, 2018
111
84
Hey,

So I've been playing around with the GCE deployment options in PgBlitz the past couple of days as I'm spinning up and destroying servers to test them. While playing around I thought it would be nice to be able to stop/start the server so that I didn't spend too much money (I've used my credits and I'm too lazy to make another account). So I went ahead and added stop/start options to the menu only to realise that the GCE servers that PgBlitz builds can't be stopped because they use Local SSDs (I believe this is the NVME drives).

1567422110936.png

So my question is, do we _need_ to use NVME drives? If I forked PGBlitz GCE and created a version that used standard SSD's or HDD's would it work OK for PgBlitz? For testing purposes at least, I don't plan on using these servers for 24/7 downloading, mostly for testing beta releases.

Thanks!
vFlagR
 

vFlagR

Experienced+
Original poster
Staff
Aug 27, 2018
111
84
You can probably get a new account with credits, google lets you use the same card more than once.
Ah yeah, I almost definitely could. I honestly don't mind paying something per month for a server but it'd be nice to be able to turn if off/on so that I'm not burning money overnight or when I'm not actively using it. Unfortunately can't do that with NVME servers in GCP
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,116
It can use ssd but have to modify the code.
 

vFlagR

Experienced+
Original poster
Staff
Aug 27, 2018
111
84
It can use ssd but have to modify the code.
Cool, if there's no limitations other than the Pg code then I'll have a play about in a separate branch :)
 

itsgoingdown

Citizen
Apr 8, 2018
10
2
Hi, I would very much appreciate this being a part of say v9 specially the part where it wouldn't install PG when it detects a GCE instance.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending