Chat Error 521

BeardimusMaximus

Noob
Original poster
Local time
3:29 AM
Jan 7, 2020
1
0
I changed my server to one with more storage last night. I am trying to set everything back up but I am getting a 521 error. I switched out the IP's. My dns info is still correct but cloudfare is still giving me a 521 error. I have absolutely no idea how or where to even start fixing this. Any ideas on what could be wrong?
 

Admin9705

Administrator
Project Manager
Local time
4:29 AM
Jan 17, 2018
4,798
1,843
A 521 error happens when we are unable to make a TCP connection to your origin server. ... This is often caused by security or firewall software and happens if the origin server has directly refused Cloudflare's proxy request.

Assuming you saw that. I have never come across a 521, so I wouldn't figure out either.

Tons of stuff comes up with google on this: https://www.google.com/search?sxsrf=ACYBGNQ2rq49dUZwoSRR8hjBa5KprlklgQ:1578813164050&ei=7MYaXtTfAoW4ggf5zbywBQ&q=error+521+cloudflare+fix&oq=521+error+clou&gs_l=psy-ab.3.1.0j0i22i30l4j0i22i10i30j0i22i30l2.64710.67044..68040...2.2..0.106.565.5j2......0....1..gws-wiz.......0i71j0i67j33i160.USwA1AWwiZg
 
  • Like
Reactions: BeardimusMaximus

Edrock200

Respected Member
Local time
4:29 AM
Nov 17, 2019
93
27
Go into cloudflare and turn proxy dns off for one of your entries. The try to get to the site. If you can get to it without error, then 443 is open and your SSL cert is good, and you have an issue on your cloudflare settings. If you get an SSL cert error try redeploying traefik. If you can't get to it at all then port 443 is blocked somewhere. Easiest test is to use a second system in the same subnet as the server and try telnetting to port 443 on the server IP. If that doesn't work it's definitely the servers itself blocking the connection, or traefik not running/deployed properly.

When you say you switched out the ips you mean in DNS or you gave the new server the same ip as the old? Are these fully routable ips or NAT'd ips? If Nat, are your port forwarding rules setup by host name instead of IP by chance?
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Maintenance Donations

Recommend NewsGroups

      Up To a 58% Discount!