Discussion - Errors related to --vfs-cache-mode >= writes in /var/plexguide/logs/rclone-tcrypt.log | PlexGuide.com

Discussion Errors related to --vfs-cache-mode >= writes in /var/plexguide/logs/rclone-tcrypt.log

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

hooper

Governer
Original poster
Staff
Donor
Aug 1, 2018
310
119
I am seeing this error in /var/plexguide/logs/rclone-tcrypt-log for every file on my tdrive.

Code:
2019/04/12 06:49:17 ERROR : tv/The Walking Dead/Season 03/The Walking Dead - S03E07 - When the Dead Come Knocking.mkv: WriteFileHandle: Can't open for write without O_TRUNC on existing file without --vfs-cache-mode >= writes
I think this may be due to bazarr, but wondering if we should be setting --vfs-cache-mode to writes anyway.
 

hooper

Governer
Original poster
Staff
Donor
Aug 1, 2018
310
119
Here are my active rclone mount commands:

Code:
ps -ef | grep rclone

root      6664     1  0 Apr08 ?        00:26:11 

/usr/bin/rclone mount gdrive: /mnt/gdrive --config /opt/appdata/plexguide/rclone.conf --allow-non-empty --allow-other --size-only --uid=1000 --gid=1000 --umask 002 --log-file=/var/plexguide/logs/rclone-gdrive.log --log-level ERROR --timeout 1h --dir-cache-time 60m --vfs-cache-max-age 72h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 5G --drive-chunk-size 32M --buffer-size 256M

root      6668     1  8 Apr08 ?        07:50:57

/usr/bin/rclone mount tcrypt: /mnt/tcrypt --config /opt/appdata/plexguide/rclone.conf --allow-non-empty --allow-other --size-only --uid=1000 --gid=1000 --umask 002 --log-file=/var/plexguide/logs/rclone-tcrypt.log --log-level ERROR --timeout 1h --dir-cache-time 60m --vfs-cache-max-age 72h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 5G --drive-chunk-size 32M --buffer-size 256M

root      6693     1  0 Apr08 ?        00:28:41

/usr/bin/rclone mount tdrive: /mnt/tdrive --config /opt/appdata/plexguide/rclone.conf --allow-non-empty --allow-other --size-only --uid=1000 --gid=1000 --umask 002 --log-file=/var/plexguide/logs/rclone-tdrive.log --log-level ERROR --timeout 1h --dir-cache-time 60m --vfs-cache-max-age 72h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 5G --drive-chunk-size 32M --buffer-size 256M

root      6704     1  1 Apr08 ?        01:24:05

/usr/bin/rclone mount gcrypt: /mnt/gcrypt --config /opt/appdata/plexguide/rclone.conf --allow-non-empty --allow-other --size-only --uid=1000 --gid=1000 --umask 002 --log-file=/var/plexguide/logs/rclone-gcrypt.log --log-level ERROR --timeout 1h --dir-cache-time 60m --vfs-cache-max-age 72h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 5G --drive-chunk-size 32M --buffer-size 256M

plexgui+ 23770  6793  0 16:03 pst/0    00:00:00 grep --color=auto rclone
There is no --vfs-cache-mode setting. I have made some changes to the default values for some settings, but there is no option on --vfs-cache-mode.
 
Last edited by a moderator:

hooper

Governer
Original poster
Staff
Donor
Aug 1, 2018
310
119
ok, I fixed this. The code changed I referenced above was re-factored in a later PG release.

Basically, the file shown below needs to be edited and changed to crypt.service instead of drive.service. This will load the crypt-related rclone defaults instead of the drive-related defaults from the template.

3245

and here are my rclone commands that are running on the system now.

Code:
ps -ef | grep rclone

root       359     1  0 16:40 ?        00:00:00 

/usr/bin/rclone mount gdrive: /mnt/gdrive --config /opt/appdata/plexguide/rclone.conf --allow-non-empty --allow-other --size-only --uid=1000 --gid=1000 --umask 002 --log-file=/var/plexguide/logs/rclone-gdrive.log --log-level ERROR --timeout 1h --dir-cache-time 60m --vfs-cache-max-age 72h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 5G --drive-chunk-size 32M --buffer-size 256M

root       537     1  1 16:40 ?        00:00:01 

/usr/bin/rclone mount tdrive: /mnt/tdrive --config /opt/appdata/plexguide/rclone.conf --allow-non-empty --allow-other --size-only --uid=1000 --gid=1000 --umask 002 --log-file=/var/plexguide/logs/rclone-tdrive.log --log-level ERROR --timeout 1h --dir-cache-time 60m --vfs-cache-max-age 72h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 5G --drive-chunk-size 32M --buffer-size 256M

root       845     1  1 16:40 ?        00:00:00 

/usr/bin/rclone mount gcrypt: /mnt/gcrypt --config /opt/appdata/plexguide/rclone.conf --allow-non-empty --allow-other --size-only --uid=1000 --gid=1000 --umask 002 --log-file=/var/plexguide/logs/rclone-gcrypt.log --log-level ERROR --timeout 1h --vfs-cache-mode writes --dir-cache-time 60m --vfs-cache-max-age 72h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 5G --drive-chunk-size 32M --buffer-size 256M

root      1022     1  3 16:40 ?        00:00:02 

/usr/bin/rclone mount tcrypt: /mnt/tcrypt --config /opt/appdata/plexguide/rclone.conf --allow-non-empty --allow-other --size-only --uid=1000 --gid=1000 --umask 002 --log-file=/var/plexguide/logs/rclone-tcrypt.log --log-level ERROR --timeout 1h --vfs-cache-mode writes --dir-cache-time 60m --vfs-cache-max-age 72h --vfs-read-chunk-size 64M --vfs-read-chunk-size-limit 5G --drive-chunk-size 32M --buffer-size 256M
This change has NOT been pushed to the repo. So someone with access to do so should probably do that.
 
  • Like
Reactions: 1 user

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,112
Book marked for follow up!
 
  • Like
Reactions: 1 user
M

MrDoob

Guest
ok, I fixed this.
Test this one some days .. if all okay ..
Create an PullRequest.

For the changes .

But if you have a good server with great specs , you can use greater values as user with lower specs.
So be careful
 

mythbuster

Active
Sep 23, 2018
30
16
I am having the same issue - which file do I need to change? I am currently on 8.6.5 using blitz encrypted and have re-deployed mounts several times to no avail.
 

hooper

Governer
Original poster
Staff
Donor
Aug 1, 2018
310
119
I am having the same issue - which file do I need to change? I am currently on 8.6.5 using blitz encrypted and have re-deployed mounts several times to no avail.
do you use bazarr for grabbing subtitles? This is what was causing the issue for me.

to fix this, turn select option 4 to deploy PG Clone, then select option 1 to use PGBlitz PG Clone, then select [C] for options, then select [2] for Rclone mount VFS Settings. In this section select option [6] and change the mode to [3] for writes. After this change, go ahead and redeploy your PG Clone mounts and the error should go away.
 
  • Like
  • Love
Reactions: 2 users

mythbuster

Active
Sep 23, 2018
30
16
do you use bazarr for grabbing subtitles? This is what was causing the issue for me.

to fix this, turn select option 4 to deploy PG Clone, then select option 1 to use PGBlitz PG Clone, then select [C] for options, then select [2] for Rclone mount VFS Settings. In this section select option [6] and change the mode to [3] for writes. After this change, go ahead and redeploy your PG Clone mounts and the error should go away.
That's bizarre, I am not using bazarr. Not sure what caused the issue. But that did the trick, thank you!
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending