GCE Billing Not Turned On

djzidon

Respected Member
Original poster
Local time
8:54 AM
Jul 7, 2018
82
13
I'm having some trouble following the instructions to turn on GCE billing...feel like a total noob...

I will say that when you sign up, it has you enable billing from the get go. This might be new.

Here are the steps I've followed:
  • Open the console left side menu and select Billing.
  • Click the New billing account button. (Note that if this is not your first billing account, first you need to open the billing account list by clicking the name of your existing billing account near the top of the page, and then clicking Manage billing accounts.)
  • Enter the name of the billing account and enter your billing information. The options you see depend on the country of your billing address. Note that for United States accounts, you cannot change tax status after the account is created.
  • Click Submit and enable billing

I've tried this several times: creating a billing account, submitting and enabling billing, and trying to build a new project. Each time it says billing not turned on. I then either try creating a new billing account (and submitting and enabling billing again - blue button last step), try combinations of closing billing accounts, and even linking them to my projects.

Is the fact that I already have projects in there the issue? 1 was to establish the API, and the other 2 were from random things.

Any help would be appreciated!
 

djzidon

Respected Member
Original poster
Local time
8:54 AM
Jul 7, 2018
82
13
Ok, wow I finally figured this out. For some reason I got hosed by the fact that google keeps defaulting to my personal account rather than the one I use for plexguide.

In effecting, I was enabling billing on the wrong account! *facepalm

(please close discussion)

Cheers all
 

djzidon

Respected Member
Original poster
Local time
8:54 AM
Jul 7, 2018
82
13
Spoke a bit too soon. I got past the first 2 hurdles, but now I'm getting an error message during Step 5 - Set Processor Count:

ERROR: (gcloud.beta.billing.projects.link) unrecognized arguments: 01AACF-D7D036-630E20

To search the help text of gcloud commands, run:
gcloud beta help -- SEARCH_TERMS
--------------------------------------------------------
SYSTEM MESSAGE: Billing Failed - Turn It On Or Check
--------------------------------------------------------

NOTE: Common Billing Issue for GCE Credits
NOTE: Cannot Continue with GCE

1. Too Many Projects - Delete Unused Ones!
2. Ran Out of Credits & Must Turn On (Warning - Expensive)

Press [ANY KEY] to Continue
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads