Discussion - gcrypt.service not found | PlexGuide.com

Discussion gcrypt.service not found

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

weasel

Citizen
Original poster
Feb 24, 2019
14
2
Hey All. After syncing my library today, I received the following error when trying to play media -

Code:
Please check that the file exists and the necessary drive is mounted.
I then checked if my mount was showing. Which in this case is mnt/gcrypt (using an existing rclone setup). I notice that the folder is greyed out.

I then proceed to update PG to latest version and redeploy. I notice the following error however the redeploy goes through fine.

Code:
TASK [Creating Folder - /mnt/gcrypt] [B]***[/B] Sunday 26 May 2019  13:30:48 +0200 (0:00:00.126)     
0:00:00.126 [I]**[/I] failed: [127.0.0.1] (item=/mnt/gcrypt) => {"changed": false, "item": "/mnt/gcrypt", "msg": "There was an issue creating /mnt/gcrypt as requested: [Errno 17] 
File exists: '/mnt/gcrypt'", "path": "/mnt/gcrypt", "state": "absent"}   
to retry, use: --limit @/opt/pgclone/ymls/crypt.retry
Also when I restart gcrypt.service it says gcrypt.service not found.

Any help please?

PS: I have been using this for the past few weeks and the issue has happened just today.
PPS: AFAIK I dont have a api ban (I could download a big file as a test just fine). Also I use my credentials.


Thanks.
 

weasel

Citizen
Original poster
Feb 24, 2019
14
2
Thanks for your reply. I now get this:

Code:
crypt.service - GCrypt Daemon
   Loaded: loaded (/etc/systemd/system/gcrypt.service; disabled; vendor preset:
   Active: active (running) since Sun 2019-05-26 19:14:34 CEST; 7s ago
 Main PID: 10438 (rclone)
    Tasks: 9 (limit: 2279)
   CGroup: /system.slice/gcrypt.service
           └─10438 /usr/bin/rclone mount gcrypt: /mnt/gcrypt --config /opt/appda
Also I notice that I can see gcrypt under Plex however it doesnt show my existing data only default movie etc folders.
 
M

MrDoob

Guest
sudo docker stop plex && sudo docker start plex
 
  • Like
Reactions: 1 user

weasel

Citizen
Original poster
Feb 24, 2019
14
2
Oh my god. That worked. Out of curiosity what went wrong?

Thanks a ton...
 
  • Like
Reactions: 1 user
M

MrDoob

Guest
Plex see only file before the service is reloaded ..

If you start en service after Plex is running.. the plex cant see the files

So that's a simple fail of plex ...
 
  • Like
Reactions: 1 user

weasel

Citizen
Original poster
Feb 24, 2019
14
2
Plex see only file before the service is reloaded ..

If you start en service after Plex is running.. the plex cant see the files

So that's a simple fail of plex ...
Thanks. Still unsure what went wrong initially but happy that its back :)
 

weasel

Citizen
Original poster
Feb 24, 2019
14
2
This issue has come up again after I synced my library. I could see a red trash icon in my plex for most of the older stuff I had synced in the past few weeks.

This time though I followed the same steps and still could not get it to work.

Code:
HTTP request sent, awaiting response... 200 OK
Length: 1018 [text/plain]
Saving to: ‘gcrypt.service’

gcrypt.service      100%[===================>]    1018  --.-KB/s    in 0s

Last-modified header missing -- time-stamps turned off.
2019-05-27 07:26:12 (93.2 MB/s) - ‘gcrypt.service’ saved [1018/1018]
After chmod and sudo service gcrypt start
Code:
Failed to start gcrypt.service: Unit gcrypt.service not found.
A server reboot got the gcrypt.service back however my Plex library is still showing trash icon and unable to play them files.
 
Last edited:

weasel

Citizen
Original poster
Feb 24, 2019
14
2
@MrDoob everytime I sync the library I lose gcrypt.service. I need to them do what you mentioned in the first post and then reboot the server. Only then does it work.

Should I downgrade to 8.5 versions?
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending