Discussion - Having issue using traefik to forward to a non docker service. | PlexGuide.com

Discussion Having issue using traefik to forward to a non docker service.

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

designator09

Citizen+
Original poster
Feb 4, 2019
21
3
Traefik works perfect for any docker containers, can even get it to work with third party containers. I edited the main config file as follows. It will not try to forward anything. I built a dedicated plex box instead of virtualizing since the demand has increased. Running into ssl errors trying to connect even with using ip:32400 instead of domain:32400. I have ports opened for now and its working ok but getting a lot of indirect connection errors due to the ssl errors.
I need traefik to be a reverse proxy for another local pc. Reading up this is the config I came up with but it does not even show up on the debug log for traefik when I try to access it.

insecureskipverify = true

logLevel = "DEBUG"
defaultEntryPoints = ["http", "https"]

[entryPoints]
[entryPoints.http]
address = ":80"
[entryPoints.http.redirect]
entryPoint = "https"
[entryPoints.https]
address = ":443"
[entryPoints.https.tls]
MinVersion = "VersionTLS12"
CipherSuites = ["TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256","TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256","TLS_ECDHE_RSA_WIT$
[entryPoints.monitor]
address = ":8081"

[retry]

[acme]
acmeLogging = true
email = "[email protected]"
storage = "/etc/traefik/acme/acme.json"
entryPoint = "https"
[acme.dnsChallenge]
provider = "godaddy"
delayBeforeCheck = "90"

[[acme.domains]]
main = "mydomain.com"
[[acme.domains]]
main = "*.mydomain.com"

[backends]
[backends.plex]
[backends.plex.servers.plex]
url = "http://192.168.2.198:32400"
[backends.cockpit]
[backends.cockpit.servers.server]
url = "https://127.0.0.1:9090"

[frontends]
[frontends.plex]
backend = "plex"
[frontends.plex.routes.plex]
rule = "Host:plex.mydomain.com"
[frontends.cockpit]
backend = "cockpit"
passHostHeader = true
[frontends.cockpit.routes.cockpit]
rule = "Host:cockpit.mydomain.com"

[docker]
endpoint = "unix:///var/run/docker.sock"
domain = "mydomain.com"
watch = true
exposedbydefault = false
network = "plexguide"
 

prillygoat

Citizen
Dec 10, 2019
4
2
I have a configuration similar to yours however I created a separate file called rules.toml in the same directory as my traefik.toml file and that's where I configured my non-docker host proxy rules.

You'll need this entry in traefik.toml for rules.toml to be enabled.

#traefik.toml entry
[file]
watch = true
filename = "/etc/traefik/rules.toml"


#rules.toml
[backends]
[backends.backend-plex]
[backends.backend-plex.servers]
[backends.backend-plex.servers.server-plex-ext]
url = "http://192.168.1.2:32400"
weight = 0

[backends.backend-blueiris]
[backends.backend-blueiris.servers]
[backends.backend-blueiris.servers.server-blueiris-ext]
url = "http://192.168.1.2:8888"
weight = 0

[frontends]
[frontends.frontend-plex]
backend = "backend-plex"
passHostHeader = true
[frontends.frontend-plex.routes]
[frontends.frontend-plex.routes.route-plex-ext]
rule = "Host:plex.example.com"

[frontends.frontend-blueiris]
backend = "backend-blueiris"
passHostHeader = true
[frontends.frontend-blueiris.routes]
[frontends.frontend-blueiris.routes.route-blueiris-ext]
rule = "Host:blueiris.example.com"


I've attached a rules.txt in hopes to preserve the spacing in the toml file for you.
 

Attachments

  • Like
Reactions: 1 users

designator09

Citizen+
Original poster
Feb 4, 2019
21
3
Really appreciate the response, I seen where most put it in a separate file, I will try it later this weekend, Thanks!
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending