Discussion - Help getting Funkwhale running | PlexGuide.com

Discussion Help getting Funkwhale running

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

skymp

Citizen+
Original poster
Sep 8, 2018
23
4
Hello I've tried for a few days to get funkwhale running but no success. Im a bit of a linux noob so would be very greatful for some guiding.

Heres the Docker Wiki of funkwhale: https://docs.funkwhale.audio/installation/docker.html

This is the error in the container logs I'm getting and the website wont load:

337:M 17 Sep 08:57:36.653 * Running mode=standalone, port=6379.

337:M 17 Sep 08:57:36.653 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.

337:M 17 Sep 08:57:36.653 # Server initialized

337:M 17 Sep 08:57:36.653 # WARNING overcommit_memory is set to 0! Background save may fail under low memory condition. To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.

337:M 17 Sep 08:57:36.653 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.

337:M 17 Sep 08:57:36.653 * Ready to accept connections

[services.d] done.

[2019-09-17 08:57:36 +0000] [336] [INFO] Starting gunicorn 19.9.0

[2019-09-17 08:57:36 +0000] [336] [INFO] Listening at: http://127.0.0.1:8000 (336)

[2019-09-17 08:57:36 +0000] [336] [INFO] Using worker: uvicorn.workers.UvicornWorker

[2019-09-17 08:57:36 +0000] [383] [INFO] Booting worker with pid: 383

[2019-09-17 08:57:38 +0000] [383] [INFO] Started server process [383]

[2019-09-17 08:57:38 +0000] [383] [INFO] Waiting for application startup.

[2019-09-17 08:57:38 +0000] [383] [INFO] ASGI 'lifespan' protocol appears unsupported.

Many Thanks!
 

vFlagR

Veteran
Staff
Aug 27, 2018
111
84
Hey,

Could you share with us the Docker-Compose or Docker Run command that you are using to try and start Funkwhale?
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending