Discussion - How to force Traefik to use something besides ports 443 and 80 | PlexGuide.com

Discussion How to force Traefik to use something besides ports 443 and 80

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

Oohdang

Citizen+
Original poster
Feb 20, 2019
22
4
My port forwarding is working for all of my installed docker containers but when I forward ports 443 and 80 they are not opening per canyouseeme.org. I'm assuming this is because my ISP is blocking traffic on those ports, and this is causing traefik not to deploy correctly. I can connect remotely via direct ip without issue, but I've got a local server I'm sharing with family in another state and I would like to get this working for them to make it easier to connect. Is there a way to edit the traefik config to force it to listen on different ports that I could successfully forward without interference from my ISP? I turned up very little helpful information when googling.

Thanks!
 

Oohdang

Citizen+
Original poster
Feb 20, 2019
22
4
Anyone? I still haven't been able to figure out how to fix this problem
 

justinglock40

Experienced
May 27, 2018
67
13
Are you sure that you have you DNS pointing to the right IP address? Seems highly unlikely that the ISP would block 80/443.
 

Oohdang

Citizen+
Original poster
Feb 20, 2019
22
4
Are you sure that you have you DNS pointing to the right IP address? Seems highly unlikely that the ISP would block 80/443.
Yep, I'm 100% sure. It was working flawlessly when I had cable internet and the second I switched to fiber internet it stopped working. All of my port forwarding on my router is set up correctly and other ports I open show as open except 80 and 443. I was troubleshooting this in the dis cord with someone and we came to the conclusion it's the new isp blocking those ports and they suggested changing the ports traefik uses. Unfortunately that was the day dis cord was taken down.
 

watchmeexplode5

Citizen+
Jan 10, 2019
22
11
Are you testing canyouseeme via your server or another computer on your network? Because if it's the latter, it would state that the ports are closed to that computer.

If they really are blocking port 80/443 then on your router you can forward external port (eg: 8081) to internal 80. I think that should work (but I haven't tested it).

Another option is to run some form of openvpn so you can connect as if you are on the local network.

Traefik can be set to listen on different ports but it would wreak havoc when pgblitz automatic setups run. It's an option but I'm assuming it would be painful to get working and wouldn't recommend it.
 

justinglock40

Experienced
May 27, 2018
67
13
Yep, I'm 100% sure. It was working flawlessly when I had cable internet and the second I switched to fiber internet it stopped working. All of my port forwarding on my router is set up correctly and other ports I open show as open except 80 and 443. I was troubleshooting this in the dis cord with someone and we came to the conclusion it's the new isp blocking those ports and they suggested changing the ports traefik uses. Unfortunately that was the day dis cord was taken down.
Tried calling them and asking to unblock those ports for you
 

designgears

Active
Staff
Jan 21, 2018
35
17
on the host machine you can go to /opt/appdata/traefik/traefik.toml and change it in there. Then just reload the traefik container.
 
  • Like
Reactions: 1 user

sbot

Citizen+
Donor
Jun 19, 2018
25
4
what ports did you change it to? I want to run two servers and both use port 80 and port 443
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending