Discussion - HTTPS not forced for top level domain app | PlexGuide.com

Discussion HTTPS not forced for top level domain app

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

CyborgPirate

Experienced
Original poster
Aug 22, 2018
81
29
I recently installed v7.5.4 and decided to move plex to the top level domain app using the traefik program in plexguide.
I have noticed that the when visiting my top level domain, https is not enforced. With all other subdomains http is rerouted to https without me having to configure anything.

Just to clarify I did not used to use the top level domain for any plexguide apps so I dont know if this is an old problem or a new one.

Other than that I am loving the 7.x releases. Keep up the good work!

Edit: incase it is important I am running a brand new install of debian 9 on a hetzner machine
 
Last edited:

CyborgPirate

Experienced
Original poster
Aug 22, 2018
81
29
I recently installed v7.5.4 and decided to move plex to the top level domain app using the traefik program in plexguide.
I have noticed that the when visiting my top level domain, https is not enforced. With all other subdomains http is rerouted to https without me having to configure anything.

Just to clarify I did not used to use the top level domain for any plexguide apps so I dont know if this is an old problem or a new one.

Other than that I am loving the 7.x releases. Keep up the good work!

Edit: incase it is important I am running a brand new install of debian 9 on a hetzner machine

Edit2: it seems that it's just Plex as far as I can tell. Plex is my top level domain which is not forcing Https and also plex.domain.com is not Https either
 

meteo

Experienced
Staff
Nov 6, 2018
66
34
Do you use cloudflare?
Toggle setting for enable https rewrites.

Add a page rule for https://*domain.tld/*
bypass cache, force https rewrite, ssl full, disable apps.

if not using cloudflare i'm not sure,
options in plex to force certain domains/ports.
try change primary container, re-deploy & reboot.

dns setup like below on cloudflare
a record -> domain.tld ->server ip > ttl auto
a record -> * (wildcard, change orange cloud to grey) -> ip -> ttl auto
 
Last edited:

Admin9705

Administrator
Project Manager
Jan 17, 2018
5,107
2,056
Thanks for the help
 

CyborgPirate

Experienced
Original poster
Aug 22, 2018
81
29
Do you use cloudflare?
Toggle setting for enable https rewrites.

Add a page rule for https://*domain.tld/*
bypass cache, force https rewrite, ssl full, disable apps.

if not using cloudflare i'm not sure,
options in plex to force certain domains/ports.
try change primary container, re-deploy & reboot.

dns setup like below on cloudflare
a record -> domain.tld ->server ip > ttl auto
a record -> * (wildcard, change orange cloud to grey) -> ip -> ttl auto
I do use cloud flare! This is a great solution. Thank you.
 
Assists Greatly with Development Costs

Admin9705

Administrator
Project Manager
Jan 17, 2018
5,107
2,056
Yup. 7.6 will focus on treafik and know what the issues are. Ya v7 is running better
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending