Discussion - Install to GCE without PG running elsewhere | PlexGuide.com

Discussion Install to GCE without PG running elsewhere

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

bedpan

Citizen+
Original poster
Donor
Apr 3, 2018
26
5
Hey folks,

Beening running PG for some time. I have recently got a decent internet upgrade at home and now run Plex from my Unraid server linked to my tdrive. I continued to us GCE as my feeder. My credits have just run out and I was going to deploy to a new account when I remembered I no longer have PG running anywhere else..

Thoughts on setting up another feeder? Is there much to installing PG to GCE by hand or am I better of spinning up PG on a VM and deploying from there?

Thanks
 
  • Like
Reactions: 1 user

kennsann

Experienced
Sep 14, 2019
57
26
You can. You actually dont need PG to make one. There are just some checks PG does when you're in GCE environment and warns if you did not do it correctly.

I've launched a couple of GCE feederboxes without PG, no problems. I even made a super feederbox that would burn through the $300 credits in just two weeks because it was that expensive. That config was not even possible via the PG GCE Feederbox edition module.
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,114
@bedpan It just helps people so it prevents errors. Ya, the vm is easy to do or you can use a hetzner.cloud box for a few minutes to get it going.
 

bedpan

Citizen+
Original poster
Donor
Apr 3, 2018
26
5
Thanks Kennsann and Admin...
I will spin one up today and see how it goes... It did not seem like it did much beyond the automate the hardware side of things... Always a challenge for me to remember all the little details in moving to a new account though :)

Cheers!
Post automatically merged:

Soooo... I am setting up a hetzner cloud box.. I already had an account with them as I ran PG on one of there servers for the last couple years.. I could not figure out the right config for the disk for PG on GCE. There is an old wiki page for it but I could not find a current one that I could load pics on..
Post automatically merged:

Ok... Just ran through the automated GCE installer in PG.. Still getting this error..
Google Cloud Instance Detected, but you Failed to setup an NVME
drive per the wiki! This mistake only occurs on manual GCE
deployments. Most likely you setup an SSD instead! The install will
continue, but this will fail! Wipe the box and setup again with an
NVME Drive!
Post automatically merged:

Just ran through the auto installer in PG for GCE and still getting this error..

Google Cloud Instance Detected, but you Failed to setup an NVME
drive per the wiki! This mistake only occurs on manual GCE
deployments. Most likely you setup an SSD instead! The install will
continue, but this will fail! Wipe the box and setup again with an
NVME Drive!
thoughts?
Post automatically merged:

Seems to be working otherwise... Just this error during PG setup on the GCE box created by PG...

I will continue with the install later and see how it goes...
 
Last edited:
  • Like
Reactions: 1 user

kennsann

Experienced
Sep 14, 2019
57
26
This was a normal problem when you first install the "remote" PG instance (the one you use to create GCE), you need to input every value even if it was already present. I had that problem before.
 

bedpan

Citizen+
Original poster
Donor
Apr 3, 2018
26
5
It was a brand new install of PG on Hetzner.. When I did the GCE deploy every field was blank and I filled them all in.. Trying again..
 

bedpan

Citizen+
Original poster
Donor
Apr 3, 2018
26
5
I deleted everything from GC and started over. The only difference on this try is I let PG create the project where first kick at the can I already had a project that I used.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending