Welcome to PlexGuide.com

Register & Join Our Community Today!

Register Log in

Solved Installed then "Not Installed"

Assists Greatly with Development Costs
Status
Not open for further replies.
Thread starter #1

dicetomato

PG Veteran
Member
PG Version
5.077
Server Type
Local - Ubuntu Server
Trying to install V2 with Namecheap API. Popped in my namecheap username, api key, and my wildcard is setup. It says it's installed but immediately afterwards I get a "Traefik is not installed."

Something is off.
 
Read Deiteq's (Cofounder) Review & For a Discount Voucher!
Read Deiteq's (Cofounder) Review & For a Discount Voucher!
Thread starter #9
OP
OP
dicetomato

dicetomato

PG Veteran
Member
you need to run this as root or with sudo premissions :D
Bash:
florin@Lahaina:~$ sudo ansible-role portainer
[sudo] password for florin:
 [WARNING]: provided hosts list is empty, only localhost is available. Note that the
implicit localhost does not match 'all'


PLAY [localhost] *************************************************************************

TASK [Gathering Facts] *******************************************************************
ok: [localhost]

TASK [portainer : include_role] **********************************************************

TASK [variables : Register Domain] *******************************************************
changed: [localhost]

TASK [variables : Register IP] ***********************************************************
changed: [localhost]

TASK [variables : Register Ports] ********************************************************
changed: [localhost]

TASK [variables : Register HD Path] ******************************************************
changed: [localhost]

TASK [variables : Register Auth Path] ****************************************************
fatal: [localhost]: FAILED! => {"changed": true, "cmd": "cat /var/plexguide/server.ht", "delta": "0:00:00.001969", "end": "2018-05-16 09:37:11.602783", "msg": "non-zero return code", "rc": 1, "start": "2018-05-16 09:37:11.600814", "stderr": "cat: /var/plexguide/server.ht: No such file or directory", "stderr_lines": ["cat: /var/plexguide/server.ht: No such file or directory"], "stdout": "", "stdout_lines": []}
...ignoring

TASK [variables : Register Auth Token] ***************************************************
fatal: [localhost]: FAILED! => {"changed": true, "cmd": "cat /opt/appdata/plexguide/plextoken", "delta": "0:00:00.002112", "end": "2018-05-16 09:37:11.761181", "msg": "non-zero return code", "rc": 1, "start": "2018-05-16 09:37:11.759069", "stderr": "cat: /opt/appdata/plexguide/plextoken: No such file or directory", "stderr_lines": ["cat: /opt/appdata/plexguide/plextoken: No such file or directory"], "stdout": "", "stdout_lines": []}
...ignoring

TASK [portainer : create plexguide network] **********************************************
fatal: [localhost]: FAILED! => {"changed": false, "msg": "Cannot have both the docker-py and docker python modules installed together as they use the same namespace and cause a corrupt installation. Please uninstall both packages, and re-install only the docker-py or docker python module"}

PLAY RECAP *******************************************************************************
localhost                  : ok=7    changed=6    unreachable=0    failed=1   

florin@Lahaina:~$
View attachment 968
 

Admin9705

Administrator
Co-Founder
Ya, yo have that last part being the issue and is the source of all your problems. It's a problem for a rare few who had the older setups. Downgrading, upgrading will not fix the issue. It's an ansible one.

TASK [portainer : create plexguide network] **********************************************
fatal: [localhost]: FAILED! => {"changed": false, "msg": "Cannot have both the docker-py and docker python modules installed together as they use the same namespace and cause a corrupt installation. Please uninstall both packages, and re-install only the docker-py or docker python module"}

You will need to setup a new server, but you'll notice this issue is all over the web. Not the nextwork, but about the pip thing here!
 
Thread starter #11
OP
OP
dicetomato

dicetomato

PG Veteran
Member
Ya, yo have that last part being the issue and is the source of all your problems. It's a problem for a rare few who had the older setups. Downgrading, upgrading will not fix the issue. It's an ansible one.

TASK [portainer : create plexguide network] **********************************************
fatal: [localhost]: FAILED! => {"changed": false, "msg": "Cannot have both the docker-py and docker python modules installed together as they use the same namespace and cause a corrupt installation. Please uninstall both packages, and re-install only the docker-py or docker python module"}

You will need to setup a new server, but you'll notice this issue is all over the web. Not the nextwork, but about the pip thing here!
Any way to utilize plexguide's backups or config backups to make for an speedier re-install? And would you do a full clean install of Ubuntu?
 
The error I am receiving is this one.

fatal: [localhost]: FAILED! => {"changed": false, "msg": "Error starting container 53bcb0227485706dfa6907c4829881c57946c122781633b53de15bfd7da0e9a8: 500 Server Error: Internal Server Error (\"{\"message\":\"failed to create endpoint portainer on network bridge: unable to set hairpin mode on veth097cb6f via netlink: address family not supported by protocol\"}\")"}

Is there a fix to this?

Note: I am trying to run this on a seedbox.
 
Dammit! Me too.... Was just trying to re-run on a working setup to see if emby worked.

"Cannot have both the docker-py and docker python modules installed together as they use the same namespace and cause a corrupt installation. Please uninstall both packages, and re-install only the docker-py or docker python module"}


Do not have time for rebuild right now. I guess I'm just going to have to watch stuff for a couple of days instead of fiddlin'.
 

Admin9705

Administrator
Co-Founder
Dammit! Me too.... Was just trying to re-run on a working setup to see if emby worked.





Do not have time for rebuild right now. I guess I'm just going to have to watch stuff for a couple of days instead of fiddlin'.
Trust me, it's a rebuild for that. I tossed wiki 5.075 and below to prevent this rare glitch for users.
 

Deiteq

Administrator
Co-Founder
Any way to utilize plexguide's backups or config backups to make for an speedier re-install? And would you do a full clean install of Ubuntu?
Here is a quick wiki about the backup/restore feature built into PlexGuide...you will be able to find it on the main PlexGuide menu option H I believe!;)
https://github.com/Admin9705/PlexGuide.com-The-Awesome-Plex-Server/wiki/Backup-&-Restore

Basically all your configs for the apps are stored in /opt/appdata!

---- Automatically Merged Double Post ----

Dammit! Me too.... Was just trying to re-run on a working setup to see if emby worked.





Do not have time for rebuild right now. I guess I'm just going to have to watch stuff for a couple of days instead of fiddlin'.
Yeah I had to wipe mine recently....took me a weekend to back everything up including my rclone config and reinstall.o_O
 
Last edited:
After Signup, PM Admin9705 for a 20% Discount Voucher
Status
Not open for further replies.

Similar threads

Top