Solved - IP address problem when creating docker container with docker-compose | PlexGuide.com

Solved IP address problem when creating docker container with docker-compose

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now
Status
Not open for further replies.

macfreaker

Veteran
Original poster
Jul 16, 2018
145
59
I have created a docker compose file but after starting the container I can't connect to the container.
I have followed the guide on the link below to create a docker compose file.
Example on this forum

My docker compose file has this file as example but I don't get an internal IP address. I post my docker file here so that someone maybe sees why I don't get a IP address.
Code:
---
version: '2'
services:
  xteve:
    image: crobibero/xteve:latest
    restart: always
    container_name: xteve
    labels:
      traefik.enable: "true"
      traefik.frontend.auth.basic.users: ""
      traefik.docker.network: "plexguide"
      traefik.frontend.redirect.entryPoint: "https"
      traefik.frontend.rule: "Host:xteve.example.com,"
      traefik.port: "34400"
    ports:
      - "34400:34400"
    volumes:
      - /opt/appdata/xteve/data:/home/xteve/xteve
      - /opt/appdata/xteve/epg:/tmp/xteve
    environment:
      - "PGID=1000"
      - "PUID=1000"
networks:
  default:
    external:
      name: plexguide
Docker compose gives no error and is starting normal but as you can see in the picture below there is no ip address, while in the example of the link above there is a IP address.
I also don't see my configured port (34400) in portainer.

Screenshot 2018-11-26 at 18.58.00.png

I have seen that the container crashes but don't know why.

ezgif.com-video-to-gif.gif
 
Last edited:
  • Like
Reactions: 1 user

macfreaker

Veteran
Original poster
Jul 16, 2018
145
59
I have found the solution for this problem that I had:
  1. There was a problem with the docker container, so I use now another container and this works.
  2. The Traefik labels can not be used in the docker-compose.yml file for this container / app. I've removed these lines and it was ok.
Here is the docker-compose.yml that I use now and that is working.

Code:
---
version: '2'
services:
  xteve:
    image: bl0m1/xtevedocker:latest
    restart: always
    container_name: xteve
    ports:
      - "34400:34400"
    volumes:
      - /opt/appdata/xteve/data:/root/xteve
      - /opt/appdata/xteve/epg:/tmp/xteve
    environment:
      - "PGID=1000"
      - "PUID=1000"
networks:
  default:
    external:
      name: plexguide
Screenshot 2018-11-27 at 14.05.23.png
 
  • Like
Reactions: 1 users

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,109
self answered :D
 
  • Like
Reactions: 1 user

macfreaker

Veteran
Original poster
Jul 16, 2018
145
59
I don’t have directly a guide. But I have written a new composer file for PlexGuide where you can place the file in and do the install within the PlexGuide menu. I will see in a few days to post it.
 
  • Like
Reactions: 1 user

dishjuarez

Experienced
Apr 24, 2018
88
14
I don’t have directly a guide. But I have written a new composer file for PlexGuide where you can place the file in and do the install within the PlexGuide menu. I will see in a few days to post it.
hello had days that did not enter the forum and I find your post and I see that you have the solution to this problem, I tried to install xteve but it happened to me the same thing did not work, what did you do exactly? I thank you very much in advance.
 

macfreaker

Veteran
Original poster
Jul 16, 2018
145
59
The solution was using another docket image. See some posts back.
 

skijbal

Experienced
Oct 4, 2018
70
16
I have found the solution for this problem that I had:
  1. There was a problem with the docker container, so I use now another container and this works.
  2. The Traefik labels can not be used in the docker-compose.yml file for this container / app. I've removed these lines and it was ok.
Here is the docker-compose.yml that I use now and that is working.

Code:
---
version: '2'
services:
  xteve:
    image: bl0m1/xtevedocker:latest
    restart: always
    container_name: xteve
    ports:
      - "34400:34400"
    volumes:
      - /opt/appdata/xteve/data:/root/xteve
      - /opt/appdata/xteve/epg:/tmp/xteve
    environment:
      - "PGID=1000"
      - "PUID=1000"
networks:
  default:
    external:
      name: plexguide
View attachment 2266
I’ve tried this yml and it keeps erroring on line 2.
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,109
  • Like
Reactions: 1 users

macfreaker

Veteran
Original poster
Jul 16, 2018
145
59
Is the yaml
Just that the error occurs at line 2. It doesn’t tell me anything else.
Is the text correct copied. Because with yml files the positions of the characters are important.
 

macfreaker

Veteran
Original poster
Jul 16, 2018
145
59
Here is a yml file that I have created based on the template of @Admin9705. Try this one if you want and let me now if it's working.
 

Attachments

SirTranceALoT

Governer
Staff
Jun 14, 2018
319
147
I was late to this thread to. Testing now.

Screenshot 2018-12-28 11.44.30.png
 
Last edited:

SirTranceALoT

Governer
Staff
Jun 14, 2018
319
147
OK, working now. For some reason, I had to manually correct it while it was ok in the yml file. some be very carefull when copy/pasting.
 

macfreaker

Veteran
Original poster
Jul 16, 2018
145
59
Can you put the correction here. Because I have tested again and it was working here.
 

SirTranceALoT

Governer
Staff
Jun 14, 2018
319
147
For some reason, it copied this part
Code:
#!/bin/bash
#
# Title:      PlexGuide (Reference Title File)
# Author(s):  Admin9705
# URL:        https://plexguide.com - http://github.plexguide.com
# GNU:        General Public License v3.0
################################################################################
---
- hosts: localhost
Like this

Code:
#!/bin/bash
#
# Title:      PlexGuide (Reference Title File)
# Author(s):  Admin9705
# URL:        https://plexguide.com - http://github.plexguide.com
# GNU:        General Public License v3.0
################################################################################
--- -
 hosts: localhost
 
  • Like
Reactions: 1 user
Status
Not open for further replies.

Recommend NewsGroups

      Up To a 58% Discount!