Issue with Pgui | PlexGuide.com

Issue with Pgui

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

designator09

Citizen+
Original poster
Feb 4, 2019
22
3
Randomly it just stopped working, I reinstalled and still getting same issue. Log Below.

nginx: [alert] failed to load the 'resty.core' module (https://github.com/openresty/lua-resty-core); ensure you are using an OpenResty release from https://openresty.org/en/download.html (reason: module 'resty.core' not found:

no field package.preload['resty.core']

no file './resty/core.lua'

no file '/usr/share/luajit-2.1.0-beta3/resty/core.lua'

no file '/usr/local/share/lua/5.1/resty/core.lua'

no file '/usr/local/share/lua/5.1/resty/core/init.lua'

no file '/usr/share/lua/5.1/resty/core.lua'

no file '/usr/share/lua/5.1/resty/core/init.lua'

no file '/usr/share/lua/common/resty/core.lua'

no file '/usr/share/lua/common/resty/core/init.lua'

no file './resty/core.so'

no file '/usr/local/lib/lua/5.1/resty/core.so'

no file '/usr/lib/lua/5.1/resty/core.so'

no file '/usr/local/lib/lua/5.1/loadall.so'

no file './resty.so'

no file '/usr/local/lib/lua/5.1/resty.so'

no file '/usr/lib/lua/5.1/resty.so'

no file '/usr/local/lib/lua/5.1/loadall.so') in /etc/nginx/nginx.conf:70
 

Edrock200

MVP
Staff
Nov 17, 2019
607
217
Randomly it just stopped working, I reinstalled and still getting same issue. Log Below.

nginx: [alert] failed to load the 'resty.core' module (https://github.com/openresty/lua-resty-core); ensure you are using an OpenResty release from https://openresty.org/en/download.html (reason: module 'resty.core' not found:

no field package.preload['resty.core']

no file './resty/core.lua'

no file '/usr/share/luajit-2.1.0-beta3/resty/core.lua'

no file '/usr/local/share/lua/5.1/resty/core.lua'

no file '/usr/local/share/lua/5.1/resty/core/init.lua'

no file '/usr/share/lua/5.1/resty/core.lua'

no file '/usr/share/lua/5.1/resty/core/init.lua'

no file '/usr/share/lua/common/resty/core.lua'

no file '/usr/share/lua/common/resty/core/init.lua'

no file './resty/core.so'

no file '/usr/local/lib/lua/5.1/resty/core.so'

no file '/usr/lib/lua/5.1/resty/core.so'

no file '/usr/local/lib/lua/5.1/loadall.so'

no file './resty.so'

no file '/usr/local/lib/lua/5.1/resty.so'

no file '/usr/lib/lua/5.1/resty.so'

no file '/usr/local/lib/lua/5.1/loadall.so') in /etc/nginx/nginx.conf:70
Never seen this error before but try this:
Stop and remove pgui container in portainer.
On host:
cd /opt/appdata
sudo mv pgui pguiold
sudo pg
Option 5, option 1, option 1, pgui, A to install. See if it works now. If so you can remove the backup if you want:
cd /opt/appdata
sudo rm -rf pguiold

If it doesn't work you can restore your pgui data from before:
Stop docker stop pgui
cd /opt/appdata
sudo rm -rf pgui
sudo mv pguiold pgui
sudo docker start pgui
 

Townsmcp

Citizen
Mar 6, 2019
6
1
Getting the same issue here too. Im on 8.7.5. No changes from my side to the setup. I do however have WatchTower sending notifications through to Slack for any changes etc and can see there was an update to PGUI yesterday evening:

PGUI.png

The suggestion from @Edrock200 didnt work.
The full error message im getting is:

Code:
nginx: [alert] failed to load the 'resty.core' module (https://github.com/openresty/lua-resty-core); ensure you are using an OpenResty release from https://openresty.org/en/download.html (reason: module 'resty.core' not found:,

    no field package.preload['resty.core'],

    no file './resty/core.lua',

    no file '/usr/share/luajit-2.1.0-beta3/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/5.1/resty/core.lua',

    no file '/usr/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/common/resty/core.lua',

    no file '/usr/share/lua/common/resty/core/init.lua',

    no file './resty/core.so',

    no file '/usr/local/lib/lua/5.1/resty/core.so',

    no file '/usr/lib/lua/5.1/resty/core.so',

    no file '/usr/local/lib/lua/5.1/loadall.so',

    no file './resty.so',

    no file '/usr/local/lib/lua/5.1/resty.so',

    no file '/usr/lib/lua/5.1/resty.so',

    no file '/usr/local/lib/lua/5.1/loadall.so') in /etc/nginx/nginx.conf:70,

2020-09-12 20:37:59,848 INFO exited: nginx (exit status 1; not expected),

2020-09-12 20:38:01,852 INFO spawned: 'nginx' with pid 23,

2020/09/12 20:38:01 [alert] 23#23: detected a LuaJIT version which is not OpenResty's; many optimizations will be disabled and performance will be compromised (see https://github.com/openresty/luajit2 for OpenResty's LuaJIT or, even better, consider using the OpenResty releases from https://openresty.org/en/download.html),

nginx: [alert] detected a LuaJIT version which is not OpenResty's; many optimizations will be disabled and performance will be compromised (see https://github.com/openresty/luajit2 for OpenResty's LuaJIT or, even better, consider using the OpenResty releases from https://openresty.org/en/download.html),

2020/09/12 20:38:01 [alert] 23#23: failed to load the 'resty.core' module (https://github.com/openresty/lua-resty-core); ensure you are using an OpenResty release from https://openresty.org/en/download.html (reason: module 'resty.core' not found:,

    no field package.preload['resty.core'],

    no file './resty/core.lua',

    no file '/usr/share/luajit-2.1.0-beta3/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/5.1/resty/core.lua',

    no file '/usr/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/common/resty/core.lua',

    no file '/usr/share/lua/common/resty/core/init.lua',

    no file './resty/core.so',

    no file '/usr/local/lib/lua/5.1/resty/core.so',

    no file '/usr/lib/lua/5.1/resty/core.so',

    no file '/usr/local/lib/lua/5.1/loadall.so',

    no file './resty.so',

    no file '/usr/local/lib/lua/5.1/resty.so',

    no file '/usr/lib/lua/5.1/resty.so',

    no file '/usr/local/lib/lua/5.1/loadall.so') in /etc/nginx/nginx.conf:70,

nginx: [alert] failed to load the 'resty.core' module (https://github.com/openresty/lua-resty-core); ensure you are using an OpenResty release from https://openresty.org/en/download.html (reason: module 'resty.core' not found:,

    no field package.preload['resty.core'],

    no file './resty/core.lua',

    no file '/usr/share/luajit-2.1.0-beta3/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/5.1/resty/core.lua',

    no file '/usr/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/common/resty/core.lua',

    no file '/usr/share/lua/common/resty/core/init.lua',

    no file './resty/core.so',

    no file '/usr/local/lib/lua/5.1/resty/core.so',

    no file '/usr/lib/lua/5.1/resty/core.so',

    no file '/usr/local/lib/lua/5.1/loadall.so',

    no file './resty.so',

    no file '/usr/local/lib/lua/5.1/resty.so',

    no file '/usr/lib/lua/5.1/resty.so',

    no file '/usr/local/lib/lua/5.1/loadall.so') in /etc/nginx/nginx.conf:70,

2020-09-12 20:38:01,869 INFO exited: nginx (exit status 1; not expected),

2020-09-12 20:38:04,876 INFO spawned: 'nginx' with pid 24,

2020/09/12 20:38:04 [alert] 24#24: detected a LuaJIT version which is not OpenResty's; many optimizations will be disabled and performance will be compromised (see https://github.com/openresty/luajit2 for OpenResty's LuaJIT or, even better, consider using the OpenResty releases from https://openresty.org/en/download.html),

nginx: [alert] detected a LuaJIT version which is not OpenResty's; many optimizations will be disabled and performance will be compromised (see https://github.com/openresty/luajit2 for OpenResty's LuaJIT or, even better, consider using the OpenResty releases from https://openresty.org/en/download.html),

2020/09/12 20:38:04 [alert] 24#24: failed to load the 'resty.core' module (https://github.com/openresty/lua-resty-core); ensure you are using an OpenResty release from https://openresty.org/en/download.html (reason: module 'resty.core' not found:,

    no field package.preload['resty.core'],

    no file './resty/core.lua',

    no file '/usr/share/luajit-2.1.0-beta3/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/5.1/resty/core.lua',

    no file '/usr/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/common/resty/core.lua',

    no file '/usr/share/lua/common/resty/core/init.lua',

    no file './resty/core.so',

    no file '/usr/local/lib/lua/5.1/resty/core.so',

    no file '/usr/lib/lua/5.1/resty/core.so',

    no file '/usr/local/lib/lua/5.1/loadall.so',

    no file './resty.so',

    no file '/usr/local/lib/lua/5.1/resty.so',

    no file '/usr/lib/lua/5.1/resty.so',

    no file '/usr/local/lib/lua/5.1/loadall.so') in /etc/nginx/nginx.conf:70,

nginx: [alert] failed to load the 'resty.core' module (https://github.com/openresty/lua-resty-core); ensure you are using an OpenResty release from https://openresty.org/en/download.html (reason: module 'resty.core' not found:,

    no field package.preload['resty.core'],

    no file './resty/core.lua',

    no file '/usr/share/luajit-2.1.0-beta3/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core.lua',

    no file '/usr/local/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/5.1/resty/core.lua',

    no file '/usr/share/lua/5.1/resty/core/init.lua',

    no file '/usr/share/lua/common/resty/core.lua',

    no file '/usr/share/lua/common/resty/core/init.lua',

    no file './resty/core.so',

    no file '/usr/local/lib/lua/5.1/resty/core.so',

    no file '/usr/lib/lua/5.1/resty/core.so',

    no file '/usr/local/lib/lua/5.1/loadall.so',

    no file './resty.so',

    no file '/usr/local/lib/lua/5.1/resty.so',

    no file '/usr/lib/lua/5.1/resty.so',

    no file '/usr/local/lib/lua/5.1/loadall.so') in /etc/nginx/nginx.conf:70,

2020-09-12 20:38:04,897 INFO exited: nginx (exit status 1; not expected),

2020-09-12 20:38:05,898 INFO gave up: nginx entered FATAL state, too many start retries too quickly,
 
Last edited:

Townsmcp

Citizen
Mar 6, 2019
6
1
Update - change the docker image to 1.10.3 is a temp work around until root cause can be fixed:

richarvey/nginx-php-fpm:1.10.3

Latest version is 1.10.4 which breaks PGUI and was updated yesterday (my previous post with error log is awaiting approval to display at this time)
 
  • Like
Reactions: 1 user

PlexPower

Citizen+
Mar 18, 2019
16
11
What i do:

Portainer
Pgui
Duplicate/Edit
Image docker.io
richarvey/nginx-php-fpm:1.10.3
Deploy the container

If you have better... Tell me.
 
  • Like
  • Love
Reactions: 8 users

doob

Administrator
Project Manager
Jun 7, 2020
919
477
Simple

sudo docker stop pgui && sudo docker rm pgui && sudo rm -rf /opt/appdata/pgui

And fixed
Post automatically merged:

You run a version with shell exec command they can used as hijacked method.. FYI. ;)
All files will be stored on the host and not inside the docker
 

Ampzxbeta

Noobz
May 26, 2020
2
0
Just chiming in that my PGUI stopped loading as well. Trying what doob posted and will report back on status.


Edit: Doob Method didn't work sadly. Tried @PlexPower method, which was changing the Docker Image, worked perfectly.
 
Last edited:

doob

Administrator
Project Manager
Jun 7, 2020
919
477
It's a remove command for the UI ... lol ...
 

doob

Administrator
Project Manager
Jun 7, 2020
919
477
Switch to older versions of the docker
 

jjnz123

Citizen
Donor
Apr 14, 2020
7
4
I can confirm reverting back to richarvey/nginx-php-fpm:1.10.3 works.

10.4 is broken and causes Cloudflare bad gateway issue as well as no access via local-IP:8555.

Redeploy using 'duplicate/edit' button, change tag/image to richarvey/nginx-php-fpm:1.10.3 and redploy.
 

TheCrank

Citizen+
Apr 15, 2018
24
5
I can confirm reverting back to richarvey/nginx-php-fpm:1.10.3 works.

10.4 is broken and causes Cloudflare bad gateway issue as well as no access via local-IP:8555.

Redeploy using 'duplicate/edit' button, change tag/image to richarvey/nginx-php-fpm:1.10.3 and redploy.
Works! Thanks! :)
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending