Sonarr - Locked out of Sonarr | PlexGuide.com

Sonarr Locked out of Sonarr

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

spokodude

Citizen+
Original poster
Dec 23, 2018
22
1
PG Related
No
Server Type
Dedicated Remote
Hi guys, been using sonarr for ages and this has happened in the past, forcing me to do an entire server wipe. Very frustrating.
I use popup login to login to my sonarr via traefik on my subdomain. All has been fine for weeks until this morning when I went to login and it will not take my creds. I know their correct, their saved in my browser and I have not touched them or any config.
I have tried -
Restarting server
Reinstalling Sonarr via PG menu
Removing and reinstalling Sonarr from PG menu
Restoring from gdrive backup in PGvault
Deleting the container from portainer and reinstalling from PGbox
Sshing into the container and editing the sonarr config.xml, but it already shows <authentication>none

I'm at a loss, I really dont want to redo my entire server again. All other apps are logging in fine. Its pulling a config.xml from somewhere else and I cannot figure out why it does this... any ideas?
Post automatically merged:

Interesting... when I turn port guard off and connect to sonarr with my ip and port I am right in. I removed all the login restrictions and restarted sonarr. However, even still when trying to login with my subdomain it still is wanting login creds... really confused here...
 
Last edited:

Edrock200

MVP
Staff
Nov 17, 2019
543
195
If your using cloudflare, untick proxied on your sonarr dna entry so it says dns only, wait 5m, then try. Cloudflare maybe serving you from its cache.
 

spokodude

Citizen+
Original poster
Dec 23, 2018
22
1
If your using cloudflare, untick proxied on your sonarr dna entry so it says dns only, wait 5m, then try. Cloudflare maybe serving you from its cache.
Haven't tried this before... I do use cloudflare and logged in and did that. Now every browser I use complains that "My connection is not private" and says "You cannot visit sonarr.***.com right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.
 

Edrock200

MVP
Staff
Nov 17, 2019
543
195
Haven't tried this before... I do use cloudflare and logged in and did that. Now every browser I use complains that "My connection is not private" and says "You cannot visit sonarr.***.com right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.
Haven't tried this before... I do use cloudflare and logged in and did that. Now every browser I use complains that "My connection is not private" and says "You cannot visit sonarr.***.com right now because the website uses HSTS. Network errors and attacks are usually temporary, so this page will probably work later.
Thats odd. You can try setting the sts traefik label on the sonarr container to false. Otherwise retick proxied and it should come back. But this begs the question, is the ip address for your sonarr entry correct?
 

spokodude

Citizen+
Original poster
Dec 23, 2018
22
1
Ok, I think we're on to something... I had to get into the chrome hsts settings and remove the cached security settings before I was able to proceed to the site. Now with DNS turned off in cloudflare, and those settings deleted, going to my subdomain provided that security warning again, but I had the option to proceed anyway. Sonarr loaded right up.
Now I'm going to re-enable cloudflare DNS for sonarr and see if it continues to work before trying to re-enable sonarr login credentials...
Post automatically merged:

Issue appears to be resolved, something related to wifi and Comcast as my ISP. Thanks for the help diagnosing @Edrock200 !
 
Last edited:
  • Like
Reactions: 1 user

Recommend NewsGroups

      Up To a 58% Discount!

Trending