Chat - lost /dev/dri | PlexGuide.com

Chat lost /dev/dri

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

christianbjerg

Citizen+
Original poster
Sep 19, 2018
18
3
EDIT:
I was unaware that a line had been added to the very bottom of my /etc/default/grub file, where the nomodeset option was enabled. Haven't aclue as to how that got there. Removed it, and it's working again. Leaving the post to help others this might happen to

My server (Hetzner EX-62 nvme) all of a sudden has lost the /dev/dri directory, meaning I can't hardware transcode. It was working fine saturday nioght, but Sunday morning the Plex docker image was Unhealthy. I rebooted the server, and tried starting the container, and it failed, saying it couldn't fint the /dev/dri folder.
sudo lspci -v -s $(lspci | grep VGA | cut -d" " -f 1) gives the following output:
Code:
 VGA compatible controller: Intel Corporation Device 3e98 (prog-if 00 [VGA controller])
    Subsystem: Gigabyte Technology Co., Ltd Device d000
    Flags: bus master, fast devsel, latency 0, IRQ 11
    Memory at 50000000 (64-bit, non-prefetchable) [size=16M]
    Memory at 40000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 3000 [size=64]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: [40] Vendor Specific Information: Len=0c <?>
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [ac] MSI: Enable- Count=1/1 Maskable- 64bit-
    Capabilities: [d0] Power Management version 2
    Capabilities: [100] Process Address Space ID (PASID)
    Capabilities: [200] Address Translation Service (ATS)
    Capabilities: [300] Page Request Interface (PRI)
    Kernel modules: i915
So I should be able to get it working again.
I tried editing the /etc/modprobe.d/blacklist-hetzner.conf file, but it still has the blacklist lines commented, and my /etc/default/grub also looks the same, without the nomodeset line

Any ideas would be greatly appreciated. OS is Ubuntu 18.04
 
Last edited:
Feb 23, 2018
368
61

Recommend NewsGroups

      Up To a 58% Discount!

Trending