Discussion - Movies are downloading with NZBGET and are seeable in /mnt/unionfs but are not being moved to /mnt/move | PlexGuide.com

Discussion Movies are downloading with NZBGET and are seeable in /mnt/unionfs but are not being moved to /mnt/move

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

Xaritomi

Citizen
Original poster
Moderator
Staff
FreeLancer
Apr 12, 2020
10
2
So, I have been trying to figure this problem out for the last couple of days now and I just can't figure it out. So, I have installed everything and followed the Wiki down to the T but I still seem to have a problem.

So, I have setup Sonarr and Radarr based on the Wiki's instructions. I have added all the hard-points and everything does download. So, this is what I think is happening.


Log into Ombi => Requests a Movie or a TV series => Sends the request to the corresponding application ( Sonarr / Radarr ) => Sonarr / Radarr then downloads it using NZBGET =>
NZBGET starts the download which is in /mnt/incomplete/nzbget/<category> => Once download is complete, it gets sent over to /mnt/downloads/nzbget/<category>

Now /mnt/downloads/ is unified with the /mnt/unionfs folder so I can see the completed downloads when I go into the /mnt/unionfs folder. Plex can also see the newly added movies / tv shows as I have plex pointing to /mnt/unionfs/nzbget/<category> for the corresponding Libraries.

So everything up to downloading the TV Show or Movie and seeing it in plex is all working fine. The problem I have is the files are not being sent to /mnt/move. One thing I did do was delete folders in the /mnt/move directory as I wasn't sure if it was required, this might have been a mistake. As of this moment I have a folder called /nzbget within /mnt/move/ which I created myself. I did this because I was using SABNZBD to begin with but after reading the Wiki I was instructed to use NZBGET instead. Also I noticed when I was using SABNZBD that there was a folder called /sabnzbd in the /mnt/move directory. I would do a reinstall but I have done that a lot of times already and I feel that it's something really small that I am missing which will fix my issue.

I do want to say thanks for all the hard work that you admins as well as the community are doing, this project is amazing and I know how tough it can be to make something as complicated as this. I also understand that everyone will have problems and it's usually something small :)

Thanks again,
Brandon
 

turner123

Experienced
Donor
Nov 26, 2018
90
37
This has happened to me a couple of times i have redeployed my mounts and sorted it for me, maybe try that, also does anything else you place in "move" actually move to drive?
 
  • Like
Reactions: 1 user

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,112
For PGX, will work self healing mounts
 

Xaritomi

Citizen
Original poster
Moderator
Staff
FreeLancer
Apr 12, 2020
10
2
Thanks for the reply. So I have redeployed the mounts a couple of times and the problem still persists. Also, when I put a file in the /mnt/move directory, it does upload to google drive. Would you mind telling me what folders you have in your /mnt/move directory?
 

dreadmclaren

Citizen
Donor
Jan 14, 2019
10
6
Also, when I put a file in the /mnt/move directory, it does upload to google drive.
Are you 100% positive you remote mappings are set in Sonarr and Radarr and are spelled correctly? If you're manually placing a file in the /mnt/move directory and it is sending it to your google drive, that makes me think Sonarr and Radarr are not configured correctly.


Worse case, if you verified that and are feeling ambitious, you could "factory reset" PG and try it over again.

sudo rm -rf /opt/plexguide && sudo rm -rf /var/plexguide && sudo apt install curl -y && curl -s https://raw.githubusercontent.com/PGBlitz/Install/v8.6/install.sh | sudo -H sh
 
Last edited:

Xaritomi

Citizen
Original poster
Moderator
Staff
FreeLancer
Apr 12, 2020
10
2
1587248774245.png

This is what I have in Rafarr? I think it's correct?
Post automatically merged:

So I decided to completely reinstall PlexGuide, and when I say reinstall I mean the Ubuntu server as well. I am going to list out everything I have done, so that hopefully someone can help me solve this issue I am facing.

Ok, lets start off with the OS, I have installed Ubuntu 16.04 server edition.

This is running on a virtual machine from which I have allocated the following specifications:
4 vCPU's @ 4.5GHz
8GB Ram
150GB Storage, NVME SSD.

I have done a full system update, and installed plexguide via Method 2.
I selected 8.7.5 to be installed.

Once installation was complete, I proceeded to install the following core apps:
Plex,
Sonarr,
Radarr,
Ombi,
NZBGET,
NETSTAT

For Sonarr, I followed this guide from the Wiki

Hardpoints

1587278676496.png

For Radarr, I followed this Guide on the Wiki

Hardpoint

1587278736832.png

NZBGET

NZBGET settings have been left at default as most of them were preconfigured

PGClone has been set to Encrypted, and I have edited the upload speed for Rclone to be unlimited. I successfully deployed this and it created the /plexguide folder within my google drive root directory.

Here are some screenshots with the layout of my current setup

/mnt/move:

1587278895293.png

/mnt/downloads:

1587278949771.png

/mnt/unionfs:

1587279050644.png

Directories highlighted in red are relevant to plexguide.

So, again, it seems I am having the exact same issue as I did before even after a new completely fresh installation. Files do upload to GDrive when placed in /mnt/move manually but movies / tv shows downloaded with Sonarr and Radarr are just not being sent to /mnt/move automatically.

Thanks for all the help, I really do appreciate it.
 
Last edited:

turner123

Experienced
Donor
Nov 26, 2018
90
37
Paths are configured in radarr sonarr, you have remote settings set in both..?

The path for downloads for radarr would be /mnt/unionfs/movies /mnt/unionfs/tv

For a test add a movie in manually set the path to /mnt/unionfs/movies iv a feeling it will work..
 

Xaritomi

Citizen
Original poster
Moderator
Staff
FreeLancer
Apr 12, 2020
10
2
So do you mean something like this for the Remote Path Mapping?

1587280877533.png
 

turner123

Experienced
Donor
Nov 26, 2018
90
37
I have nothing in the remote path as its not needed, just goto add movie and select the path /mnt/unionfs/movies, iv a feeling it will move
1587281257048.png
 

Xaritomi

Citizen
Original poster
Moderator
Staff
FreeLancer
Apr 12, 2020
10
2
Hmm, I believe I have also set the root path to that directory as well.

1587282629671.png

I am downloading another movie to see if anything changes.
 

turner123

Experienced
Donor
Nov 26, 2018
90
37
why are you adding nzbget in the path? the path should be /mnt/unionfs/movies (only)
 
  • Like
Reactions: 1 user

Xaritomi

Citizen
Original poster
Moderator
Staff
FreeLancer
Apr 12, 2020
10
2
Oh I see, sorry about that. I didn't realise it was in a different directory. I will give that a try now.
Post automatically merged:

Ok, so that seems to have fixed the issue. Thanks so much for the help and the quick repys. I knew it was something as simple as that. Just one more question. Are you also pointing your plex to /mnt/unionfs/movies?
 
Last edited:

Recommend NewsGroups

      Up To a 58% Discount!

Trending