Discussion - Need Help With Traefik Problems? | PlexGuide.com

Discussion Need Help With Traefik Problems?

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

mtyax

Citizen
Donor
Donor
Mar 4, 2018
5
1
HELP!!!! EEEKKK.... OMG...

ok, got everything setup, bout to head of to bed and let this soak.....

problem.... Cloudflare and me are going round and round.... literly redirects..... everything cant get a single thing to load by name.... so if you can provide a sample how to fix cloudflare.... that would be great....
 

altoyda

Active
Patron
Jul 18, 2020
44
12
Info Let us know if you follow this and then let us know if you how many times you have tried why asking if you deploy too much it will not work.
Post automatically merged:

if you are able to get portainer up and going check this out info
 

bodgeup

Experienced+
Original poster
Staff
FreeLancer
Donor
Aug 12, 2018
129
42
HELP!!!! EEEKKK.... OMG...

ok, got everything setup, bout to head of to bed and let this soak.....

problem.... Cloudflare and me are going round and round.... literly redirects..... everything cant get a single thing to load by name.... so if you can provide a sample how to fix cloudflare.... that would be great....
On CF are your DNS records using orange or grey clouds?? Id advise setting all records to Grey clouds while deploying then once traefik is deployed and the certs valid you can then switch records to the orange clouds, CF Proxy doesnt play well with NAT apps etc??
 
  • Like
Reactions: 1 user
Mar 27, 2020
40
10
I have a problem. Though I guess it was my own stupidity.
Everything was working fine and dandy. Later I tried to install Jellyfin but it wouldn't load. My idiot brain did not realize that I forgot to add a CNAME for Jellyfin in CF.
So, I decided to redeploy Traefik to see if that works. Thing is, Traefik does not want to redeploy. It keeps telling me it failed. There is nothing that looks like an error.
I destroyed the container, I changed the delay from 60 to 90.
Why would it work fine for months on end, but stop working as soon as I redeployed it??
When I deploy and it says "Failed" and I still try to go to the app, it gives me Error 526. So there is a problem with my certificate?

Edit: Turns out, I am the idiot. I have my domain with GoDaddy. But CDN with Cloudflare. So in Traefik I needed to put the API for Cloudflare and not for GoDaddy. Now everything works.
 
Last edited:
  • Like
Reactions: 1 user

altoyda

Active
Patron
Jul 18, 2020
44
12
Good that you got it working @PSyCHoHaMSTeRza with the setup with traefik if it fails they have something say if it fails it's 75% on us I have find that out over 100% with me something stupid I did. Happy you got it working.
 

evlo

Active
Feb 13, 2020
32
6
What did I messed up this time, it all seemed so easy :D
Could it just be that my server is too slow, portainer may take about 30 seconds or so to work after i run traefik deployment!
But it seems to be that if I enable proxyfied on cloudflare I can no longer access traefik by port, it only works sometimes, i think it is a fluke I tried to follow https://plexguide.com/wiki/traefik-cloudflare/#3-crypto-settings - but I also tried to disable HSTS, but no change.

https://domain:9000 gives me ERR_SSL_PROTOCOL_ERROR
http://domain:9000 gives me web interface

on restarting plexguide I get:
domain's rated limited exceed | Traefik (LetsEncrypt)! Takes upto one week to clear up (or use a new domain)


1604634577080.png
 
Last edited:

bodgeup

Experienced+
Original poster
Staff
FreeLancer
Donor
Aug 12, 2018
129
42
did you look at my article here for guidance?

 

evlo

Active
Feb 13, 2020
32
6
Is there a way to at least see LetsEncrypt status for myself?
Post automatically merged:


Post automatically merged:


Post automatically merged:


Post automatically merged:

If you’ve hit a rate limit, we don’t have a way to temporarily reset it. You’ll need to wait until the rate limit expires after a week. We use a sliding window
Post automatically merged:

But I have no Idea which limit I did hit, I did not try THAT many times.
Post automatically merged:

I guess the issue is
Duplicate Certificate limit of 5 per week.
Post automatically merged:

Also for other, who don't read, same as me, you can see certs here https://crt.sh so you know how long you will need to wait.
Post automatically merged:


is the way
Post automatically merged:

How can I add alternate urls/redirects?
ie. radar.MYDOMAIN to radarr.MYDOMAIN
?

Also I changed top level domain app from ombi to oraganizr and now I get 404 on the https://MYDOMAIN do I need to redeploy?
 
Last edited:

bodgeup

Experienced+
Original poster
Staff
FreeLancer
Donor
Aug 12, 2018
129
42
try here


And here found this later on and think its the one i was thinking of but took me while to find it again ive used this before!

 
Last edited:

Recommend NewsGroups

      Up To a 58% Discount!

Trending