Netcup 4K Stream Buffering | PlexGuide.com

Netcup 4K Stream Buffering

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

bxta

Citizen+
Original poster
Donor
Jun 11, 2019
21
6
Hello, everyone,
so far I was only reading active, but now I need help from the professionals ;) !

I am using a Netcup RS 4000 G8SE (6x Intel® Xeon
Gold 6140 , 32GB RAM, 140GB SSD ), have a GSuite account and a domain at GoDaddy.

The server runs Ubuntu 18 and I have set up PGBlitz with Traefik, Plex, Potainer, etc.By the way, the installation of the server ran perfectly, many thanks to the developers. Awesome!

My library has 90% 1080p content and neither I nor my Plex users have any problems with 1080p content..

The CPU never works more than 5-10%.

Now I have some 4K movies that I want to play on my OLED65C97LA.
UHD Content has its own library, only I can use it so far.

Unfortunately the TV has to buffer very often. The server does not transcode, Direct Play is active and I can see from the server CPU that there is no increased server load (CPU 5 - 7 % ).

The TV is with VDSL DOWN 100MBit / UP40 MBit via Ethernet cable in the Internet (no WLAN).
Nevertheless it has to be buffered constantly at 4K. I Tried content with very high Bitrate (80Mb/s ) and lower (20Mb/s). Both is buffering...

Enclosed some server test data:

CPU model : Intel(R) Xeon(R) Gold 6140 CPU @ 2.30GHz
Number of cores : 6
CPU frequency : 2294.606 MHz
Total size of Disk : 140.1 GB (27661.1 GB Used)
Total amount of Mem : 32167 MB (1698 MB Used)
Total amount of Swap : 0 MB (0 MB Used)
System uptime : 0 days, 20 hour 42 min
Load average : 0.10, 0.13, 0.10
OS : Ubuntu 18.04.4 LTS
Arch : x86_64 (64 Bit)
Kernel : 4.15.0-96-generic
----------------------------------------------------------------------
I/O speed(1st run) : 321 MB/s
I/O speed(2nd run) : 640 MB/s
I/O speed(3rd run) : 629 MB/s
Average I/O speed : 530.0 MB/s
----------------------------------------------------------------------
Node Name IPv4 address Download Speed
CacheFly 205.234.175.175 103MB/s
Linode, Tokyo2, JP 139.162.65.37 8.52MB/s
Linode, Singapore, SG 139.162.23.4 13.4MB/s
Linode, London, UK 176.58.107.39 111MB/s
Linode, Frankfurt, DE 139.162.130.8 123MB/s
Linode, Fremont, CA 50.116.14.9 14.2MB/s
Softlayer, Dallas, TX 173.192.68.18 15.0MB/s
Softlayer, Seattle, WA 67.228.112.250 12.1MB/s
Softlayer, Frankfurt, DE 159.122.69.4 107MB/s
Softlayer, Singapore, SG 119.81.28.170 11.1MB/s
Softlayer, HongKong, CN 119.81.130.170 10.3MB/s
----------------------------------------------------------------------


Speedtest from Client to Server (community app)
Ping 35ms
Jitter 0.8ms
Down: 102Mbps
Up: 35Mbps


GDrive Speed Test
Allocating 4G test file...
Starting upload to gdrive...
Transferred: 4G / 4 GBytes, 100%, 86.390 MBytes/s, ETA 0s
Errors: 0
Checks: 0 / 0, -
Transferred: 1 / 1, 100%
Elapsed time: 47.4s

Upload complete, deleting local file...
Starting download from gdrive...
Transferred: 4G / 4 GBytes, 100%, 84.250 MBytes/s, ETA 0s
Errors: 0
Checks: 0 / 0, -
Transferred: 1 / 1, 100%
Elapsed time: 48.6s



Does any one has an Idea where i can look at, and how to figure out why 4K is buffering?

Thanks a lot and stay healthy!
 

turner123

Experienced
Donor
Nov 26, 2018
90
37
Plex struggles with actual 4k are you playing it direct? best iv tried is xplay app plays 4k perfect.
 

bxta

Citizen+
Original poster
Donor
Jun 11, 2019
21
6
Hello, yes its set to direct play . Tautulli shows that Directplay is working...
 

Dexter.

Active
Donor
Jan 25, 2020
46
10
I have just a VPS2000 G8 from Netcup and have no buffering issues with 4k content. About 3 weeks ago I had it for 2-3 days but then it went automatically back to work normal (I think the reason was because Corona).

I have no really hint for you, but maybe some of your friends could try to stream 4k with a different device. I'm not 100% sure, but I think in the past i read a post that someone had massive speed problems with a LG tv. Maybe you can check what DL rate the LG actually gets.
 

bxta

Citizen+
Original poster
Donor
Jun 11, 2019
21
6
I tired XPlay and its the same Problem with the Buffering. No Transcoding at all on the Server side.

I also run a Speedtest on my LG Oled and i get 100Mbit download. Should all be fine...:/
 

turner123

Experienced
Donor
Nov 26, 2018
90
37
Plex app on my LG OLED buffered Xplay is 99.9% fine but im wired and have 360mb down.
Also try change the audio from 7.1 to 5.1 might find plays better.
 

spaceman07

Citizen+
Nov 25, 2019
20
7
Environment:
Netcup root server with 10 cores

Sorry to bring more negative to the thread as i was planing to ask the same question.. getting alot of buffering with 4K content but ok with others.
I am using nvidia shield pro connected via ethernet with plex for kodi set to direct play.

Some of my troubleshooting:
I have tried it with other VPS's ethernet servers and hetzner cloud with the new EPYC 16 Cores.

Could it be more to do with the rclone mount settings possibly?
rclone v1.51.0
- os/arch: linux/amd64
- go version: go1.13.7

Mount Settings:
--allow-other \
--fast-list \
--no-modtime \
--dir-cache-time 30s \
--umask 002 \
--buffer-size 256M \
--poll-interval 15s \
--timeout 1h \
--tpslimit 10 \
--tpslimit-burst 10

Hopefully someone can help us with this as it appears we are on similar boat!
 

Edrock200

MVP
Staff
Nov 17, 2019
607
217
You need to set chunk size and max chunk size in rclone. Chunk size (recommend setting to 64M or 128M) is the initial size of the chunk it grabs from Google. Max chunk (recommend 1024 or 2096M) is a little different. When rclone grabs sequential chunks, it will double the size of each grab up to the max chunk size. This chunk size resets anytime you seek, stop or start playback.

I would also recommend trying cloudflares cdn if you aren't already. It's free and fairly easy to setup with plexguide. For me, with a 1gig connection at home, makes the a huge different. 200mbs without, 800+ with.

There's a lot of other settings missing in your rclone config too like vfs cache and your dir cache should be much higher. Mine is set to 72h.
 
  • Like
Reactions: 1 user

bxta

Citizen+
Original poster
Donor
Jun 11, 2019
21
6
This are my Setting ( default PGClone...)

⏫ Upload Settings Default Current
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
[1] BW Limit [9M]
[2] Drive-Chunk-Size 64M [128M]
[3] Transfers 8 [8]
[4] Max-Transfer 750G [750G]

⏬ Download Settings Default Current
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
[5] Buffer-Size 16M [16M]
[6] VFS-Read-Chunk-Size 64M [64M]
[7] VFS-Read-Chunk-Size-Limit 1024M [1024M]

? VFS Cache Mode Settings Default Current
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
[8] VFS-Cache-Mode writes [writes]
[9] VFS-Cache-Max-Age 1h [1h]
[10] VFS-Cache-Max-Size 100G [off]

? Misc Settings Default Current
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
[11] Dir-Cache-Time 5m [5m]
[12] Log-Level NOTICE [NOTICE]
[13] User Agent [rclone/v1.48]


Is there anything which i can change?

I will also try to setup cloudflare...
Post automatically merged:

Hello again,
i just grab my old Odroid C2 and install OpenPht Plex Client. I tried a Move which is always buffering and on the Odroid it seems so work good. No Buffering, while LG PLex app and XPlay still buffer...

On the other hand, if i stream a 4K Move from my local Plex Server (1gBit Eth) there is also no buffering with the Plex app on the LG TV...

hmmm...its some kind of strange to me.
 
Last edited:
  • Like
Reactions: 1 user

neik

Experienced
Feb 5, 2018
51
12
I only have a VPS1000 G8 and am able to stream 4K stuff.
Only difference: I am using Emby and not Plex, maybe a issue with Plex?
 

Edrock200

MVP
Staff
Nov 17, 2019
607
217
I would install the speedtest container and see what speed you are getting to your house from your vps.
 

bxta

Citizen+
Original poster
Donor
Jun 11, 2019
21
6
With my Odroid PLEX Client or apple tv i dont have any issues with 4K streaming...seems to be a Client Issue with my LG TV. Solved for me.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending