Discussion PG Clone "Cannot Execute Binary File"

Behole

Junior Member
Original poster
Local time
1:22 AM
Nov 15, 2019
3
1
Mount Type
Move Unencrypted
Server Type
Local - Dedicated Server
[NOOB WARNING] Trying to set up PGBlitz on 16.04. Im getting 3 errors when going through the validation checks for gDrive.

/opt/pgclone/fucntions/ouathcheck.sh: Line 18 /usr/bin/rclone: cannot execute binary file: Exec format error
*Same error for lines 20 and 21

This is my first time installing PGBlitz and I have been trying to follow the wiki step by step but like I said, NOOB.

Any kind of guidance will be massively appreciated!!!

J
 

Behole

Junior Member
Original poster
Local time
1:22 AM
Nov 15, 2019
3
1
The latest I suppose. I installed via method 1 on this site via terminal. Is there a way to confirm the version for clarity?

edit: I believe it was 8.6._ (I am away from my computer). I started with 8.5 but then it asked me to upgrade. Im guessing that may be the issue?
Post automatically merged:

So I went back and reinstalled 8.5 - Same error

/opt/pgclone/functions/oauthcheck.sh: line 18: /usr/bin/rclone: cannot execute binary file: Exec format error

/opt/pgclone/functions/oauthcheck.sh: line 20: /usr/bin/rclone: cannot execute binary file: Exec format error

/opt/pgclone/functions/oauthcheck.sh: line 21: /usr/bin/rclone: cannot execute binary file: Exec format error
Post automatically merged:

I'm guessing its an issue with the way my gDrive is set up but the wiki I am steered to, I cannot for the life of me find it!
 
Last edited:
  • Like
Reactions: CrashpiG

AdamBearWA

Junior Member
Local time
4:22 PM
Dec 8, 2018
16
7
What's the output of these 2 commands?
Bash:
lsb_release -a
Bash:
rclone version --check
 

Behole

Junior Member
Original poster
Local time
1:22 AM
Nov 15, 2019
3
1
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

-bash: /usr/bin/rclone: cannot execute binary file: Exec format error

that’s prob not good lol

*on mobile
 
Last edited:

AdamBearWA

Junior Member
Local time
4:22 PM
Dec 8, 2018
16
7
Could be a mix up between 32/64 bit apps or just that some required stuff isn't installed.

Run these commands:
Bash:
sudo apt install lsb-core
Bash:
sudo apt install rclone
Then try the ones from before again. Hopefully there's no more errors
Post automatically merged:

Also, what's the output of the following command?
Bash:
arch
 
Last edited:
  • Like
Reactions: Armin

CrashpiG

Full Member
Donor
Local time
4:22 AM
Jan 29, 2018
42
11
Trinidad and Tobago
[email protected]:~# arch
x86_64
[email protected]:~#

i also have this error


/opt/pgclone/functions/oauth.sh: line 128: curl: command not found
/opt/pgclone/functions/oauth.sh: line 129: curl: command not found

━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
🚀 Listed Team Drives
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━


━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
🚀 No Team Drives Exist or Bad Token!
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

NOTE1: Create a Team Drive First or Share on to this account and retry the
process again!

NOTE2: If a bad token, ensure that you are using the correct account when
signing in (and/or conducting a proper copy and paste of the token)!
 
Last edited:
Assists Greatly with Development Costs

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Members online

Maintenance Donations

Recommend NewsGroups

      Up To a 58% Discount!

Trending