Discussion - pg move unencrypted - stream stopps/stutters | PlexGuide.com

Discussion pg move unencrypted - stream stopps/stutters

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

stammbraeu

Experienced+
Original poster
Staff
Donor
Mar 21, 2018
112
42
Hi

I have the problem that my streams are very unstable for a while - i can play for some minutes (no matter what the quality) than it stops and stutters all the way - i can stop the stream and start again and it works for a couple of minutes - than i have to repeat

usability especially for my wife is ....

I added my google credentials which lead to massive improvement in the loading speed of the stream but the stability got worse


Server is a dedicated one from Hetzner with enough transcoding power for 4 streams but as my clients run on Lan i mostly use direct play anyhow

Gdrive is around 80 TB

main Client is a Nvidia Shield, a Windows 10 i7, a android tablet - all of them experience the same problem


Any ideas how to improve the stability?
Is there a way to downgrade to plexdrive - never had a problem with it

All the best
Stammbraeu
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,116
to be honest, my server is stream 10 clients and it's fine. I have my own keys. I use an apple tv 4k, hate the shield (i own one and would buffer - no offense), i have a nightgear x9000 wireless router that's nuts plus an isp with 500/50. There are alot of factors in play. Could be your isp, routes from google, malware, ps4 updates... anything :D . The best way to test things is build a local pg box on a vm and see what results or use the hertzner cloud. it's hard to troubleshoot only from one source :D, hey the upside is 6.066 deploys a GCE box for you, so you can even deploy a google test vm :D
 

Datamonkeh

Data Hoarding Primate
Project Manager
Donor
Donor
Jan 20, 2018
861
393
As above you really need to exclude variables.
Server spec?
Media details - use a known good media file that played OK previously.
Dockers running?
IO Wait/CPU load (see netdata docker), try stopping anything intensive like NZB processing.
Speedtest results (local and remote)?
You say 4 transcodes, but why are you having to transcode? Transciding=bad.
How’s Tatulli reporting your playback?
You say LAN clients, that doesn’t mean much, do you mean wired? If so, good, Wi-fi=bad.
Have you tried changing the transcode buffer time to say 120 sec?

In simple terms if the servers connection to GDrive is slow, it can’t re-stream quickly enough, if you have other tasks running that are CPU intensive and then transcode as well you may see slowdown.
 
Last edited:
  • Like
Reactions: 1 user

stammbraeu

Experienced+
Original poster
Staff
Donor
Mar 21, 2018
112
42
Hi

My server specs:
1 x Dedicated Root Server SB41
* Intel Xeon E3-1271V3
* 2x HDD SATA 2,0 TB Enterprise
* 4x RAM 8192 MB DDR3 ECC
* NIC 1 Gbit
* - Intel I210
* Standort: FSN1
* Rescue-System (Englisch)


Results from speedtest (installed via plexguide):
Download
176.11
Mbps

Upload
26.42
Mbps

Ping
23.24
ms

Jitter
1.11
ms


Installed dockers:
plex
speedtest
netdata
tautulli
portainer
ombi4k
ombi
radarr
radarr4k
sonarr
sonarr4k
sabnzbd
traefik
watchtower

i tried also to kill all container but plex to test potential problems - even with just plex up and running i have the same problem

Tautulli:
Direct Play on all fronts - stream container video audio subtitle

Netdata:
Memory Usage: around 350MB
CPU: basically nothing
Disk IO: basically nothing


All my clients (except the Tablet) are wired via LAN on a Gigabit Network - internal traffic tests show no problem on that side as well

My internet connection is at a stable 250/25



Is there a way to test the speed between my hetzner server and my google cloud?

All the best
Stammbraeu
 

Datamonkeh

Data Hoarding Primate
Project Manager
Donor
Donor
Jan 20, 2018
861
393
Upload 26.42mbps? On a gigabit product that looks really, really low. What’s the resolution/average bit-rate of the media you’re trying to stream? Can you test on say a 720/1080 TV rip as they tend to be small?
 

stammbraeu

Experienced+
Original poster
Staff
Donor
Mar 21, 2018
112
42
thats the upload of my isp at home - only for clients - therefore only the 250 are relevant

the plex server is a dedicated hetzner server with a gigabit nic and definitly fast enough -
i had before my problems no problem to stream 4K material

and what makes it really weird - it makes no difference whether its a 4K movie or a 720p series
it works for a while and than starts to stutter

all the best
Stammbraeu
 

Datamonkeh

Data Hoarding Primate
Project Manager
Donor
Donor
Jan 20, 2018
861
393
thats the upload of my isp at home - only for clients - therefore only the 250 are relevant

the plex server is a dedicated hetzner server with a gigabit nic and definitly fast enough -
i had before my problems no problem to stream 4K material

and what makes it really weird - it makes no difference whether its a 4K movie or a 720p series
it works for a while and than starts to stutter

all the best
Stammbraeu
My bad, I missed the transition from the remote server specs to your local speed test results from the speedtest server you installed on it. Bandwidth between you and the server is fine, I took it they were the simple speedtest results from the remote server, though I did wonder when jitter was added to it :)

Initial thoughts are about the same as your initial idea, bandwidth between the server and google. What does the advanced speed test show on the remote server (option 8 from menu iirc?).
 
  • Like
Reactions: 1 user

stammbraeu

Experienced+
Original poster
Staff
Donor
Mar 21, 2018
112
42
Made a test on the server
Benchmark started on 14-Oct-2018 15:50:20

## System Information

OS Name : Ubuntu 18.04.1 LTS (64 bit)
Kernel : Dedicated / 4.15.0-36-generic
Hostname : Ubuntu-1804
CPU Model : Intel(R) Xeon(R) CPU E3-1271 v3 @ 3.60GHz
CPU Cores : 8 cores @ 1616.619 MHz
CPU Cache : 8192 KB
Total RAM : 31900 MiB (Free 27862 MiB)
Total SWAP : 32735 MiB (Free 32653MiB)
Total Space : 1.1PB (51% used)
Running for : 16hrs 37min 52sec


## CDN Speedtest

CacheFly : 24.70 MiB/s | 197.64 Mbps | ping 5.739ms
CDN.net : 1.72 KiB/s | 0.01 Mbps | ping 5.269ms

## North America Speedtest

Softlayer, Washington, USA : 1.12 MiB/s | 8.97 Mbps | ping 138.567ms
SoftLayer, San Jose, USA : 702.10 KiB/s | 5.49 Mbps | ping 154.618ms
SoftLayer, Dallas, USA : 1.04 MiB/s | 8.30 Mbps | ping 115.676ms
Vultr, New Jersey, USA : 1.82 MiB/s | 14.60 Mbps | ping 84.931ms
Vultr, Seattle, USA : 962.05 KiB/s | 7.52 Mbps | ping 158.443ms
Vultr, Dallas, USA : 1.09 MiB/s | 8.76 Mbps | ping 134.420ms
Vultr, Los Angeles, USA : 811.99 KiB/s | 6.34 Mbps | ping 163.869ms
Ramnode, New York, USA : 1.36 MiB/s | 10.90 Mbps | ping 94.927ms
Ramnode, Atlanta, USA : 1.19 MiB/s | 9.49 Mbps | ping 110.660ms
OVH, Beauharnois, Canada : 1.40 MiB/s | 11.23 Mbps | ping 92.783ms


## Europe Speedtest

Vultr, London, UK : 10.21 MiB/s | 81.67 Mbps | ping 16.067ms
LeaseWeb, Frankfurt, Germany : 25.25 MiB/s | 202.00 Mbps | ping 5.587ms
Hetzner, Germany : 40.63 MiB/s | 325.07 Mbps | ping 2.775ms
Ramnode, Alblasserdam, NL : 5.23 MiB/s | 41.82 Mbps | ping 22.890ms
Vultr, Amsterdam, NL : 13.82 MiB/s | 110.53 Mbps | ping 11.213ms
EDIS, Stockholm, Sweden : 5.36 MiB/s | 42.90 Mbps | ping 30.948ms
OVH, Roubaix, France : 11.59 MiB/s | 92.70 Mbps | ping 12.946ms
Online, France : 10.15 MiB/s | 81.20 Mbps | ping 15.785ms
Prometeus, Milan, Italy : 5.51 MiB/s | 44.06 Mbps | ping 28.189ms


## Exotic Speedtest

Sydney, Australia : 256.06 KiB/s | 2.00 Mbps | ping 326.524ms
Lagoon, New Caledonia : 94.41 KiB/s | 0.74 Mbps | ping 344.645ms
Hosteasy, Moldova : 2.89 MiB/s | 23.12 Mbps | ping 39.611ms
Prima, Argentina : 331.61 KiB/s | 2.59 Mbps | ping 220.640ms


## Asia Speedtest

SoftLayer, Singapore : 526.52 KiB/s | 4.11 Mbps | ping 190.666ms
Linode, Tokyo, Japan : 453.86 KiB/s | 3.55 Mbps | ping 259.350ms
Linode, Singapore : 498.61 KiB/s | 3.90 Mbps | ping 252.902ms
Vultr, Tokyo, Japan : 433.77 KiB/s | 3.39 Mbps | ping 259.788ms


## IO Test

CPU Speed:
bzip2 512MB - 148 MB/s
sha256 512MB - 235 MB/s
md5sum 512MB - 676 MB/s

Disk Speed (512MB):
I/O Speed - 2.6 GB/s
I/O Direct - 19.4 MB/s

RAM Speed (1024MB):
Avg. write - 4846.9 MB/s
Avg. read - 7645.9 MB/s


-------------------------------

the US results are clear but the european (which are the one relevant to me) partly disturb me
e.g.
Ramnode, Alblasserdam, NL : 5.23 MiB/s | 41.82 Mbps | ping 22.890ms
Prometeus, Milan, Italy : 5.51 MiB/s | 44.06 Mbps | ping 28.189m

shouldnt those values be way higher?
 

Datamonkeh

Data Hoarding Primate
Project Manager
Donor
Donor
Jan 20, 2018
861
393
Have a look at the speed test thread for comparison, they are low. What would be useful is if the Drive benchmark hadn't been pulled from the speediest results (not by you).
 

mythbuster

Active
Sep 23, 2018
30
16
Stammbraeu, have you had any luck with this? I am encountering the exact same issue on my home server (Ubuntu 18.04 VM on ESXi). I have done exhaustive troubleshooting and have more than enough resources and bandwidth - seems to be an issue retrieving the files from Google Drive using the API. I have ensured I am using my own API keys and have no issues with downloading content or the upload to Drive. But Plex continues to buffer during direct playback over my local network...

Have you found a way to test the connection to Google Drive servers?
 

stammbraeu

Experienced+
Original poster
Staff
Donor
Mar 21, 2018
112
42
No - i decided to kill the server and start a new one (and use the current backups) at a different provider

based on the speedtests i saw that at least parts of the relevant european connections was slow so maybe this will fix my problem

all the best
Stammbraeu
 

stammbraeu

Experienced+
Original poster
Staff
Donor
Mar 21, 2018
112
42
i have setup a new server at servdiscount (myloc) and after some problem the server is now up and running

First results:
Its way better but i had some stutters as well - i'm really frustrated

I really like the suite and all the features plexguide provides but in the end all of it has one final purpose and thats watching videos

gonna try tweaking around some more

if any1 has some ideas what to check or to change i'm open minded

Is there a way to test the connection between my google drive and the server?
for me its the most likely bottleneck but i have no clue why it worked out for some months without a problem
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending