Discussion PGBlitz not moving anything from the 'move' folder to tdrive > gdrive ...

RiCH

Full Member
Original poster
Local time
7:04 PM
Jun 29, 2019
37
2
Mount Type
Blitz Encrypted
Server Type
Other
Hi, I need some help please guys...

(Windows 10 / Running on wls), I have set everything up as per the wiki and all checks pass:

Conducting RClone Mount Checks ~ pgclone.pgblitz.com
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

GDRIVE : Passed
TDRIVE : Passed
GDSA01 : Passed
GCRYPT1: Passed
GCRYPT2: Passed
TCRYPT1: Passed
TCRYPT2: Passed
GDSA01C: Passed

PLAY [localhost] ***************************************************************
Proocessing Disk : /mnt/h/PGBlitz
Yet whatever is sent to the 'move' folder isn't being uploaded to tdrive ...


There are Docker errors, but I know they are due to WLS and that PGBlitz should still work correctly.

fatal: [127.0.0.1]: FAILED! => {"changed": true, "cmd": "docker stop $(docker ps -a -q)", "delta": "0:00:00.140892", "end": "2019-07-04 06:41:47.451410", "msg": "non-zero return code", "rc": 1, "start": "2019-07-04 06:41:47.310518", "stderr": "Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?\n\"docker stop\" requires at least 1 argument.\nSee 'docker stop --help'.\n\nUsage: docker stop [OPTIONS] CONTAINER [CONTAINER...]\n\nStop one or more running containers", "stderr_lines": ["Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?", "\"docker stop\" requires at least 1 argument.", "See 'docker stop --help'.", "", "Usage: docker stop [OPTIONS] CONTAINER [CONTAINER...]", "", "Stop one or more running containers"], "stdout": "", "stdout_lines": []}
to retry, use: --limit @/opt/pgclone/ymls/remove.retry

PLAY RECAP *********************************************************************
127.0.0.1 : ok=0 changed=0 unreachable=0 failed=1


These errors seem to be the reason that PGBlitz isn't working:

TASK [Reload Service - gdrive] *************************************************
Thursday 04 July 2019 06:41:51 +0100 (0:00:00.641) 0:00:01.815 *********
fatal: [127.0.0.1]: FAILED! => {"changed": false, "msg": "failure 1 during daemon-reload: Failed to connect to bus: No such file or directory\n"}
to retry, use: --limit @/opt/pgclone/ymls/mount.retry
TASK [Reload Service - tdrive] *************************************************
Thursday 04 July 2019 06:41:56 +0100 (0:00:00.637) 0:00:01.812 *********
fatal: [127.0.0.1]: FAILED! => {"changed": false, "msg": "failure 1 during daemon-reload: Failed to connect to bus: No such file or directory\n"}
to retry, use: --limit @/opt/pgclone/ymls/mount.retry
TASK [Reload Service - gcrypt] *************************************************
Thursday 04 July 2019 06:42:01 +0100 (0:00:00.640) 0:00:01.811 *********
fatal: [127.0.0.1]: FAILED! => {"changed": false, "msg": "failure 1 during daemon-reload: Failed to connect to bus: No such file or directory\n"}
to retry, use: --limit @/opt/pgclone/ymls/crypt.retry
TASK [Reload Service - tcrypt] *************************************************
Thursday 04 July 2019 06:42:05 +0100 (0:00:00.649) 0:00:01.823 *********
fatal: [127.0.0.1]: FAILED! => {"changed": false, "msg": "failure 1 during daemon-reload: Failed to connect to bus: No such file or directory\n"}
to retry, use: --limit @/opt/pgclone/ymls/crypt.retry
TASK [Reload PG Blitz Service] *************************************************
Thursday 04 July 2019 06:42:29 +0100 (0:00:00.541) 0:00:20.603 *********
fatal: [127.0.0.1]: FAILED! => {"changed": false, "msg": "failure 1 during daemon-reload: Failed to connect to bus: No such file or directory\n"}
to retry, use: --limit @/opt/pgclone/ymls/pgunion.retry


My system:

~# df -h
Filesystem Size Used Avail Use% Mounted on
rootfs 465G 395G 70G 86% /
none 465G 395G 70G 86% /dev
none 465G 395G 70G 86% /run
none 465G 395G 70G 86% /run/lock
none 465G 395G 70G 86% /run/shm
none 465G 395G 70G 86% /run/user
cgroup 465G 395G 70G 86% /sys/fs/cgroup
C:\ 465G 395G 70G 86% /mnt/c
D:\ 5.5T 32G 5.5T 1% /mnt/d
E:\ 1.9T 1.8T 53G 98% /mnt/e
F:\ 1.9T 1.9T 5.6G 100% /mnt/f
G:\ 224G 159G 66G 71% /mnt/g
H:\ 477G 193G 285G 41% /mnt/h
J:\ 1.9T 1.8T 36G 99% /mnt/j
R:\ 1.9T 843G 1021G 46% /mnt/r


Can anyone please help with how to fix the above 'No such file or directory\n' errors ....
 
Last edited:

doperyde

Respected Member
Staff
Local time
12:04 PM
Mar 7, 2018
53
23
ID. USA
running pgb on win10 WSL isn't considered to be supported and i've not heard of anyone getting things working successfully. there might be a chance they're able to get it working on WSL2, but so far admin hasn't had success getting things working in either.
why not just spin up a VM?

it looks pretty clear from the output of df that the pg mounts are not deployed.
 
T

TheShadow

Guest
This is not supported, please use real Ubuntu and not WSL. WSL2 has improved things but there are still gaps.
 

nachobel

Senior Member
Staff
Donor
Local time
11:04 AM
Feb 2, 2019
140
34
You could bake your own rclone/arr services setup, but really it'll be much easier to either partition an ubuntu install or use a VM, as others have said.
 

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.


Maintenance Donations

Recommend NewsGroups

      Up To a 58% Discount!

Trending