plex.domain.com not working | PlexGuide.com

plex.domain.com not working

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now
S

subse7en

Guest
That issue seems to be with the local plex install. It sets the network to hosts, maybe that's why?

Anyway, my issue w/ using traefik was b/c I chose the wrong option.
I was confused Plex Remote/Local. I did Plex (Local) instead of (Plex Remote). I reinstalled plex w/ remote and now the reverse proxy is working instead of bad gateway.

I was thinking Plex Remote: Remote as in not going to be hosted on this server, which was wrong.
 

djzidon

Experienced
Jul 7, 2018
82
13
Interesting. I have always, however, chosen Plex Remote. Excited for this to be resolved someday as well
 

ChunkDus

Active
Donor
Oct 11, 2018
44
11
That issue seems to be with the local plex install. It sets the network to hosts, maybe that's why?

Anyway, my issue w/ using traefik was b/c I chose the wrong option.
I was confused Plex Remote/Local. I did Plex (Local) instead of (Plex Remote). I reinstalled plex w/ remote and now the reverse proxy is working instead of bad gateway.

I was thinking Plex Remote: Remote as in not going to be hosted on this server, which was wrong.

But can you connect on Plex app? Remote acces on Plex is OK when you enable it with traefik and plexguide/bridge network?


I'm trying to get Plex with Traefik, but didn't work remote access, then maybe, y selected plex local like you, but it a bit strange, because if you select local, is only for server, can't connect on internet (In my opinion or what i interpretate with local/remote), btw if you'r working with remote + traefik, maybe i need to reinstall plex like 'Plex Remote' and configure all again :( , but at the moment, if i active network bridge/plexguide, working traefik, but not remote access or app's.

Only Plex Remote working if i enable host network, and then, traefik dont work with Plex.


Thank you for all
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,116
this has been a known issue, but cannot understand myself why it's happening. i've seen it work at times.
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,116
Hello again!! ^^ . Amazing work with your new versions ;) .

What issue exactly?

Thank you
haha thank you :D more to keep coming. converting legacy and bug squashing
 

timekills

VIP
Staff
Donor
Sep 12, 2018
368
193
When using Cloudflare and Traefik, use the following setup (yes - I know this is different than the CDN instructions. Following the CDN rules exactly as written resulted in intermittent remote access for me on Hetzner dedicated and a VPS.)

1. Under "Network/Custom server access URLs" use https://TLD:443
1a. Note the https and the :443 at the end. Seems redundant, but required.
1b. TLD is plex.yourdomain.com or plex.yourdomain.net or whatever you're using

2. Recommend under "Network/LAN Networks" and under "Network/List of IP addresses and networks that are allowed without auth" enter 172.17.0.0/16,172.18.0.0/16
2a. Those are the internal subnets for the plexguide and bridge networks
2b. This suggestion isn't directly relevant to Cloudflare, but helpful regardless

3. Under "Remote Access" check - yes, check - "Manually specify port" and use the standard 32400 port.

4. In Cloudflare under the "DNS" tab ensure you have a Plex A or CNAME.
4a. Best business practice is to have one A Record that points your TLD without the prename - i.e. yourdomain.com NOT www.yourdomain.com. All the other subdomains should be CNAME. So you'd add one CNAME for plex.yourdomain.com using Plex under the Name column and yourdomain.com under the Value column. You can use the @ symbol instead of typing yourdomain.com for the Value column as a shortcut. Whether you use a CNAME for each subdomain or create an A Record for each subdomain is up to you and somewhat immaterial to this discussion, but the correct way is to only havean A record to point a domain (or domains) to an IP and the subdomains using CNAMEs. Either will work here however.)
4b. in the Plex record make sure the orange cloud (using Cloudflare) is ENABLED
4c. If using CNAME records, you must have AT LEAST the TLD included as an A record. That should have been pulled over automatically when you created your Cloudflare account. Check to ensure you have a line that tells Cloudflare what the IP for your server is, and the TLD to assoicate it with [the purpose of an A record] as in the screenshot below:
2163

5. In Cloudflare make a page rule for https://plex.TLD/* with the rules SSL: Full, Cache Level: Bypass, Automatic HTTPS Rewites: On
5a. Note the /* at the end. Important. Required.
5b. Again the "plex.TLD" is whatever you used in #1 (i.e. maybe plex.ihopethisfsckingworks.com)
5c. The other rules from the CDN page aren't necessary. You can add them - they won't hurt - but why complicate things?

Now go back and retry in Plex/Remote access to enable remote access. BE PATIENT.
It can take a while - 10 minutes sometimes initially - for your Plex server to restart and populate through Traefik and then Cloudlfare, and sometimes even longer for Cloudflare to push the DNS settings through the global Internet, especially if new.

You'll also occasionally see the dreaded red ! by remote access when you go to settings in the future for a moment or two. That's normal. However, unlike the CDN settings, it will go back to the green check mark. If it ever doesn't after a few moments (it depends on how quickly Plex.tv is able to hit Cloudflare and then Cloudflare to reach your server...could be ms or could be a couple seconds) go and re-enable Remote Access. This has happened only once to me in weeks, and really I think it was because I was messing around with other settings and testing stuff.
 
Last edited:
  • Like
Reactions: 7 users

ChunkDus

Active
Donor
Oct 11, 2018
44
11
When using Cloudflare and Traefik, use the following setup (yes - I know this is different than the CDN instructions. Following the CDN rules exactly as written resulted in intermittent remote access for me on Hetzner dedicated and a VPS.)

1. Under "Network/Custom server access URLs" use https://TLD:443
1a. Note the https and the :443 at the end. Seems redundant, but required.
1b. TLD is plex.yourdomain.com or plex.yourdomain.net or whatever you're using

2. Recommend under "Network/LAN Networks" and under "Network/List of IP addresses and networks that are allowed without auth" enter 172.17.0.0/16,172.18.0.0/16
2a. Those are the internal subnets for the plexguide and bridge networks
2b. This suggestion isn't directly relevant to Cloudflare, but helpful regardless

3. Under "Remote Access" check - yes, check - "Manually specify port" and use the standard 32400 port.

4. In Cloudflare under the "DNS" tab ensure you have a Plex A or CNAME (by the way, you can always delete the A record created and use a CNAME in it's place. Which you should use is somewhat immaterial to this discussion, but there are pros and cons to both. Either will eork here however.)
4a. in the Plex record make sure the orange cloud (using Cloudflare) is ENABLED

5. In Cloudlfare make a page rule for https://plex.TLD/* with the rules SSL: Full, Cache Level: Bypass, Automatic HTTPS Rewites: On
5a. Note the /* at the end. Important. Required.
5b. Again the "plex.TLD" is whatever you used in #1 (i.e. maybe plex.ihopethisfsckingworks.com)
5c. The other rules from the CDN page aren't necessary. You can add them - they won't hurt - but why complicate things?

Now go back and retry in Plex/Remote access to enable remote access. BE PATIENT.
It can take a while - 10 minutes sometimes initially - for your Plex server to restart and populate through Traefik and then Cloudlfare, and sometimes even longer for Cloudflare to push the DNS settings through the global Internet, especially if new.

You'll also occasionally see the dreaded red ! by remote access when you go to settings in the future for a moment or two. That's normal. However, unlike the CDN settings, it *will* go back to the green check mark. If it ever doesn't after a few moments (it depends on how quickly Plex.tv is able to hit Cloudflare and then Cloudflare to reach your server...could be ms or could be a couple seconds) go and re-enable Remote Access. This has happened only once to me in weeks, and really I think it was because I was messing around with other settings and testing stuff.
Wow amazing! This worked!!! Thank you so much!! I didn't know what i could do more.

Regards!
 
Last edited:
  • Like
Reactions: 1 users

Biny

Active
Mar 20, 2018
36
11
I got mine working by making sure my docker network for plexguide existed under the plex container. Also had to recreate all my networks as there was some overlap.
 
  • Like
Reactions: 1 user

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,116
oh good to know!
 

titooo7

Veteran
Jul 31, 2018
154
30
When using Cloudflare and Traefik, use the following setup (yes - I know this is different than the CDN instructions. Following the CDN rules exactly as written resulted in intermittent remote access for me on Hetzner dedicated and a VPS.)

1. Under "Network/Custom server access URLs" use https://TLD:443
1a. Note the https and the :443 at the end. Seems redundant, but required.
1b. TLD is plex.yourdomain.com or plex.yourdomain.net or whatever you're using

2. Recommend under "Network/LAN Networks" and under "Network/List of IP addresses and networks that are allowed without auth" enter 172.17.0.0/16,172.18.0.0/16
2a. Those are the internal subnets for the plexguide and bridge networks
2b. This suggestion isn't directly relevant to Cloudflare, but helpful regardless

3. Under "Remote Access" check - yes, check - "Manually specify port" and use the standard 32400 port.

4. In Cloudflare under the "DNS" tab ensure you have a Plex A or CNAME (by the way, you can always delete the A record created and use a CNAME in it's place. Which you should use is somewhat immaterial to this discussion, but there are pros and cons to both. Either will work here however.)
4a. in the Plex record make sure the orange cloud (using Cloudflare) is ENABLED

5. In Cloudflare make a page rule for https://plex.TLD/* with the rules SSL: Full, Cache Level: Bypass, Automatic HTTPS Rewites: On
5a. Note the /* at the end. Important. Required.
5b. Again the "plex.TLD" is whatever you used in #1 (i.e. maybe plex.ihopethisfsckingworks.com)
5c. The other rules from the CDN page aren't necessary. You can add them - they won't hurt - but why complicate things?

Now go back and retry in Plex/Remote access to enable remote access. BE PATIENT.
It can take a while - 10 minutes sometimes initially - for your Plex server to restart and populate through Traefik and then Cloudlfare, and sometimes even longer for Cloudflare to push the DNS settings through the global Internet, especially if new.

You'll also occasionally see the dreaded red ! by remote access when you go to settings in the future for a moment or two. That's normal. However, unlike the CDN settings, it *will* go back to the green check mark. If it ever doesn't after a few moments (it depends on how quickly Plex.tv is able to hit Cloudflare and then Cloudflare to reach your server...could be ms or could be a couple seconds) go and re-enable Remote Access. This has happened only once to me in weeks, and really I think it was because I was messing around with other settings and testing stuff.
Hello,

I'm following your instruction but I have some doubts in regards to point 4.
Should we write plex.mydomain.com as CNAME records in cloudflare?
And what about record A? If I delete it it then cloudflare site has a mesage saying:

"An A, AAAA or CNAME record was not found pointing to the root domain. The mydomain.com domain will not resolve."

thanks a lot for the help. This community is great
 

timekills

VIP
Staff
Donor
Sep 12, 2018
368
193
Hello,

I'm following your instruction but I have some doubts in regards to point 4.
Should we write plex.mydomain.com as CNAME records in cloudflare?
And what about record A? If I delete it it then cloudflare site has a mesage saying:

"An A, AAAA or CNAME record was not found pointing to the root domain. The mydomain.com domain will not resolve."

thanks a lot for the help. This community is great
Note that I wrote that it can be either A record or CNAME. For this situation, it doesn't matter. We can discuss why I went with CNAME rather than the plexguide created A records, but as long as you have one or the other you're fine.

If you're using CNAME, however, you have to have AT LEAST one A record that points your TLD to your IP. If you followed the original Cloudflare instructions, it should have pulled that over from your original DNS provider.

If not - and it sounds like it didn't - ensure you have/create the following record in the DNS section (listed by column heading:
Type: A
Name: TLD (I don't know yours but if you want plex.mydomain.com for example, it should be just the mydomain.com portion.)
Value: Whatever the IP for your server is
TTL: Automatic
Status: Orange cloud.

TLDexampleCloudflare.png
 
Last edited:
  • Like
Reactions: 1 user

titooo7

Veteran
Jul 31, 2018
154
30
Note that I wrote that it can be either A record or CNAME. For this situation, it doesn't matter. We can discuss why I went with CNAME rather than the plexguide created A records, but as long as you have one or the other you're fine.

If you're using CNAME, however, you have to have AT LEAST one A record that points your TLD to your IP. If you followed the original Cloudflare instructions, it should have pulled that over from your original DNS provider.

If not - and it sounds like it didn't - ensure you have/create the following record in the DNS section (listed by column heading:
Type: A
Name: TLD (I don't know yours but if you want plex.mydomain.com for example, it should be just the mydomain.com portion.)
Value: Whatever the IP for your server is
TTL: Automatic
Status: Orange cloud.

View attachment 2162
Thank you! I got it working now!

I can access to https://plex.mydomain.com now!

It ask me for user and password, which is the same one that I use to login via SSH. Is that normal?

I assume that since it ask for my server user and password then this URL is not to be shared with the friend I added to my Plex library, right?
 

timekills

VIP
Staff
Donor
Sep 12, 2018
368
193
Thank you! I got it working now!

I can access to https://plex.mydomain.com now!

It ask me for user and password, which is the same one that I use to login via SSH. Is that normal?

I assume that since it ask for my server user and password then this URL is not to be shared with the friend I added to my Plex library, right?
Hmm. This is in addition to the standard Plex authentication?
Do you have Application Guard turned on through Plexguide, perhaps?

I don't use Application Guard, but it does add a additional username/password to the apps. It's designed to provide entry protection to those apps that don't have it by default, but I believe it gets assigned to everything.

Regardless, it's usually best to have people you share access with reach the server through Plex's site (https://plex.tv) rather directly to the server anyway. I don't know if that would still make the Application Guard kick in or not.

edit: another member said when installing the "Application Guard" was turned on by default. I've done a couple upgrades and clean installs in the past few days and didn't see that, but the menu almost makes it seem as if you're supposed to close the ports and apply application guard rather than those being optional. So check to see if you did, and remove application guard and then check Plex again.
 
Last edited:

titooo7

Veteran
Jul 31, 2018
154
30
Hmm. This is in addition to the standard Plex authentication?
Do you have Application Guard turned on through Plexguide, perhaps?

I don't use Application Guard, but it does add a additional username/password to the apps. It's designed to provide entry protection to those apps that don't have it by default, but I believe it gets assigned to everything.

Regardless, it's usually best to have people you share access with reach the server through Plex's site (https://plex.tv) rather directly to the server anyway. I don't know if that would still make the Application Guard kick in or not.

edit: another member said when installing the "Application Guard" was turned on by default. I've done a couple upgrades and clean installs in the past few days and didn't see that, but the menu almost makes it seem as if you're supposed to close the ports and apply application guard rather than those being optional. So check to see if you did, and remove application guard and then check Plex again.
Yes I have appguard enabled, but I'll go back to this part later....

I still think I'm doing something wrong because I could access plex via https://plex.mydomain.com but I still couldn't access other apps in the same way (portainer.mydomain.com, nzbget.mydomain.com, etcetera)

1- Is this how it's supposed to look like (ficticiuous domain name and ip address below)?
question.png

2-Before deploying Traefik I had the A and CNAME values in grey and only changed them to orange after Traefik was deployed, then I re-deployed it changing both to orange before the deployment. But I didnt appreciate any changes... plex.mydomain works but stuff like portainer.mydomain.com doesn't
 

timekills

VIP
Staff
Donor
Sep 12, 2018
368
193
Yes, your Cloudflare DNS settings for the A record (TLD pointing to IP) and the Plex CNAME look correct.

You're kind of changing the problem on me now though...
1. Regarding the other password requirement when you access https://plex.mydomain.com - that IS BECAUSE you have appguard enabled.
2. If you're having problems with apps OTHER THAN PLEX, I recommend you start a new thread. You wrote in another post/thread that you can get to portainer.mydomain.com but couldn't get to Plex.

In the meantime, the page https://plexguide.com/threads/heimd...-traefik-fix-with-cloudflare.2259/#post-12187 that I believe you've looked at previously has the Cloudflare settings for page rules.

If you set those rules AND make sure you have a CNAME or A record for each of your apps, you should be good to go. Please remember it takes time for the DNS infor to propagate through the Internet when you add or change something in Cloudflare.

I.E. if you use Plex, Portainer, SabNZBD, Sonarr and Radarr, you need to have a DNS record for each of those in the DNS settings in Cloudflare. The wildcard page rule will cover all those sites in the page rule settings, but if there isn't a CNAME or A record for the site in the DNS tab, Cloudflare will ignore it. Even if you have a rule for * in DNS - unless you're a paying customer, it won't do wildcards in DNS, only allowed in page rules.

The DNS tab example is in that link as well.

2-Before deploying Traefik I had the A and CNAME values in grey and only changed them to orange after Traefik was deployed, then I re-deployed it changing both to orange before the deployment. But I didnt appreciate any changes... plex.mydomain works but stuff like portainer.mydomain.com doesn't
I'm not sure why/how you were using Cloudflare without Traefilk. But if the clouds were gray colored, then you weren't really using Cloudflare's DNS. It was simply another hop pushing it to your server.

Make sure each app has a CNAME in Cloudflare, and that it points to your TLD - just like you did with Plex.

Make sure you add the Cloudflare page rules that I show at https://plexguide.com/threads/heimd...-traefik-fix-with-cloudflare.2259/#post-12187

If - after waiting maybe up to half and hour - the sites don't work, you can try either rebooting or re-doing the Traefik install. But be patient. It takes a while for Traefik to rebuild the containers, the settings to propagate to Cloudflare, and then from Cloudflare.
 
Last edited:
  • Like
Reactions: 1 user

titooo7

Veteran
Jul 31, 2018
154
30
Yes, your Cloudflare DNS settings for the A record (TLD pointing to IP) and the Plex CNAME look correct.

You're kind of changing the problem on me now though...
1. Regarding the other password requirement when you access https://plex.mydomain.com - that IS BECAUSE you have appguard enabled.
2. If you're having problems with apps OTHER THAN PLEX, I recommend you start a new thread. You wrote in another post/thread that you can get to portainer.mydomain.com but couldn't get to Plex.

In the meantime, the page https://plexguide.com/threads/heimd...-traefik-fix-with-cloudflare.2259/#post-12187 that I believe you've looked at previously has the Cloudflare settings for page rules.

If you set those rules AND make sure you have a CNAME or A record for each of your apps, you should be good to go. Please remember it takes time for the DNS infor to propagate through the Internet when you add or change something in Cloudflare.

I.E. if you use Plex, Portainer, SabNZBD, Sonarr and Radarr, you need to have a DNS record for each of those in the DNS settings in Cloudflare. The wildcard page rule will cover all those sites in the page rule settings, but if there isn't a CNAME or A record for the site in the DNS tab, Cloudflare will ignore it. Even if you have a rule for * in DNS - unless you're a paying customer, it won't do wildcards in DNS, only allowed in page rules.

The DNS tab example is in that link as well.



I'm not sure why/how you were using Cloudflare without Traefilk. But if the clouds were gray colored, then you weren't really using Cloudflare's DNS. It was simply another hop pushing it to your server.

Make sure each app has a CNAME in Cloudflare, and that it points to your TLD - just like you did with Plex.

Make sure you add the Cloudflare page rules that I show at https://plexguide.com/threads/heimd...-traefik-fix-with-cloudflare.2259/#post-12187

If - after waiting maybe up to half and hour - the sites don't work, you can try either rebooting or re-doing the Traefik install. But be patient. It takes a while for Traefik to rebuild the containers, the settings to propagate to Cloudflare, and then from Cloudflare.
Sorry the confusion!
Summary: I added cnam for each container and now I can access all of them with containername.mydomain.com

I don't mind having the authentication pop-up activated due to appguard. Actually I prefer it that way as I prefer if nobody knows what is hosted on that domain.
 
  • Like
Reactions: 1 user

tonycfromit

Experienced
Staff
Mar 16, 2018
85
40
Note that I wrote that it can be either A record or CNAME. For this situation, it doesn't matter. We can discuss why I went with CNAME rather than the plexguide created A records, but as long as you have one or the other you're fine.

If you're using CNAME, however, you have to have AT LEAST one A record that points your TLD to your IP. If you followed the original Cloudflare instructions, it should have pulled that over from your original DNS provider.

If not - and it sounds like it didn't - ensure you have/create the following record in the DNS section (listed by column heading:
Type: A
Name: TLD (I don't know yours but if you want plex.mydomain.com for example, it should be just the mydomain.com portion.)
Value: Whatever the IP for your server is
TTL: Automatic
Status: Orange cloud.

View attachment 2162

THANK YOU SO MUCH!!!! This made things work much better. This second post made me see a typo I made (put a ^ instead of a * ) on a line above it that has been haunting me for WEEEEEKS!!!! OH GAWD THAT WAS PAINFUL!
 
  • Like
Reactions: 1 user

eliMoon

Citizen
Dec 2, 2018
10
1
Hello, reading this thread and new to hosting Plex on cloud instances after PlexCloud was disabled. Anyways I'm currently on a Hetzner instance and and am having some trouble wrapping my head around what kind of performance (if any) can be gained from setting up something like this vs the Remote Access route?

My setup is as follows:
- Hetzner CCX11 (dedicated CPU)
- Germany location
- Plex Remote Access Enabled
- Cloudflare (via Traefik) working for (speedtest, portainer)

I access Plex via native apps from different platforms (Xbox One, iPhone, Apple Tv, Vizio TV, Amazon Firestick, Amazon Tablet) I'm testing from 3 different locations around Texas.

Here's the stats from one of the locations I'm testing:
Speedtest.Net results from test location #1
Screen Shot 2018-12-25 at 4.54.38 PM.png
speedtest.TLD.com results from test location #1 (cloudflare w/Traefik deployment)
Screen Shot 2018-12-25 at 4.53.36 PM.png

ip:8223 results from test location #1
Screen Shot 2018-12-25 at 4.53.53 PM.png
 

yuvrajgill10

Citizen+
Dec 1, 2018
21
3
When using Cloudflare and Traefik, use the following setup (yes - I know this is different than the CDN instructions. Following the CDN rules exactly as written resulted in intermittent remote access for me on Hetzner dedicated and a VPS.)

1. Under "Network/Custom server access URLs" use https://TLD:443
1a. Note the https and the :443 at the end. Seems redundant, but required.
1b. TLD is plex.yourdomain.com or plex.yourdomain.net or whatever you're using

2. Recommend under "Network/LAN Networks" and under "Network/List of IP addresses and networks that are allowed without auth" enter 172.17.0.0/16,172.18.0.0/16
2a. Those are the internal subnets for the plexguide and bridge networks
2b. This suggestion isn't directly relevant to Cloudflare, but helpful regardless

3. Under "Remote Access" check - yes, check - "Manually specify port" and use the standard 32400 port.

4. In Cloudflare under the "DNS" tab ensure you have a Plex A or CNAME (by the way, you can always delete the A record created and use a CNAME in it's place. Which you should use is somewhat immaterial to this discussion, but there are pros and cons to both. Either will work here however.)
4a. in the Plex record make sure the orange cloud (using Cloudflare) is ENABLED
4b. If using CNAME records, you must have AT LEAST the TLD included as an A record. That should have been pulled over automatically when you created your Cloudflare account. Check to ensure you have a line that tells Cloudflare what the IP for your server is, and the TLD to assoicate it with [the purpose of an A record] as in the screenshot below:
View attachment 2163

5. In Cloudflare make a page rule for https://plex.TLD/* with the rules SSL: Full, Cache Level: Bypass, Automatic HTTPS Rewites: On
5a. Note the /* at the end. Important. Required.
5b. Again the "plex.TLD" is whatever you used in #1 (i.e. maybe plex.ihopethisfsckingworks.com)
5c. The other rules from the CDN page aren't necessary. You can add them - they won't hurt - but why complicate things?

Now go back and retry in Plex/Remote access to enable remote access. BE PATIENT.
It can take a while - 10 minutes sometimes initially - for your Plex server to restart and populate through Traefik and then Cloudlfare, and sometimes even longer for Cloudflare to push the DNS settings through the global Internet, especially if new.

You'll also occasionally see the dreaded red ! by remote access when you go to settings in the future for a moment or two. That's normal. However, unlike the CDN settings, it *will* go back to the green check mark. If it ever doesn't after a few moments (it depends on how quickly Plex.tv is able to hit Cloudflare and then Cloudflare to reach your server...could be ms or could be a couple seconds) go and re-enable Remote Access. This has happened only once to me in weeks, and really I think it was because I was messing around with other settings and testing stuff.
Hello, I just did this and it worked...well sort of.

Unfortunately, doing this broke connections to Plex via PS4 and iOS. The only way to run stuff from Plex right now is https://plex.mydomain.ltd

Any ideas? I'm on 7.7.3
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending