Plex - Plex is purplexing | PlexGuide.com

Plex Plex is purplexing

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

Edrock200

MVP
Staff
Nov 17, 2019
744
265
If I try connecting it gives me a packet_write_wait error. Connection to IP port 22: broken pipe
Post automatically merged:

Here's the logs
From the host go to /opt/appdata/plex/database/.../Logs and copy to /mnt/gdrive or /mnt/tdrive. Then download from google drive web.
 

timmeh

Veteran
Feb 14, 2019
174
35
Dumb question but is the date / time on your server and/or the container correct?
Yep, time and date are correct
Post automatically merged:

From the host go to /opt/appdata/plex/database/.../Logs and copy to /mnt/gdrive or /mnt/tdrive. Then download from google drive web.
Post automatically merged:

In portainer I changed the label
traefik.protocol
to http and the 502 error has now gone, however I still can't claim the server...
 

Attachments

Last edited:

Edrock200

MVP
Staff
Nov 17, 2019
744
265
Yep, time and date are correct
Post automatically merged:


Post automatically merged:

In portainer I changed the label
traefik.protocol
to http and the 502 error has now gone, however I still can't claim the server...
Did you add a new claim code?
 

timmeh

Veteran
Feb 14, 2019
174
35
Open the Plex container in portainer and click dupe/edit. Go to env variables. Paste in a new claim code in the claim code env variable value. Deploy.
Have tried that loads of times... it still doesn't work. I've also tried adding the same code to teh preference.xml file AND the container. That didn't work. Then I've tried just adding it to the preferences.xml and not the container and that didn't work... 🤷‍♂️
Post automatically merged:

By the way, after running ssh -N -L localhost:32400:localhost:32400 [email protected] on my mac then going to: localhost:32400 I am given an XML file which shows me that the server is definitely there. It has a machine identifier, friendly name etc... but no token or claim code associated with it.
Can I edit that XML to force the claim?
 
Last edited:

Edrock200

MVP
Staff
Nov 17, 2019
744
265
Have tried that loads of times... it still doesn't work. I've also tried adding the same code to teh preference.xml file AND the container. That didn't work. Then I've tried just adding it to the preferences.xml and not the container and that didn't work... 🤷‍♂️
Post automatically merged:

By the way, after running ssh -N -L localhost:32400:localhost:32400 [email protected] on my mac then going to: localhost:32400 I am given an XML file which shows me that the server is definitely there. It has a machine identifier, friendly name etc... but no token or claim code associated with it.
Can I edit that XML to force the claim?
Try localhost:32400/web
 
  • Like
Reactions: 1 user

timmeh

Veteran
Feb 14, 2019
174
35
YES! It's worked. Libraries are scanning. Whoop! Leg-end.
So now come setup worked on my mac but not on the dedi?

I've been a week without Plex and the shakes were getting bad.
 
Last edited:

Edrock200

MVP
Staff
Nov 17, 2019
744
265
YES! It's worked. Libraries are scanning. Whoop! Leg-end.
So now come setup worked on my mac but not on the dedi?
Not sure TBH. It seems to happen from time to time but not quite as persistent as your experience. Without knowing the exact order of troubleshooting steps I can't say for sure but at least now you know the ssh tunnel trick. It's a great way to get to apps on your box if the traefik front end is down without needing to expose ports to the internet.
 
  • Like
Reactions: 1 user

Recommend NewsGroups

      Up To a 58% Discount!

Trending