Portainer - Portainer Busted | PlexGuide.com

Portainer Portainer Busted

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

bobbarker

Citizen
Original poster
Apr 24, 2018
10
1
After upgrading to version 6 I'm getting this error and portainer/plex aren't starting:

Code:
fatal: [127.0.0.1]: FAILED! => {"cache_update_time": 1531102574, "cache_updated": true, "changed": false, "msg": "'/usr/bin/apt-get -y -o \"Dpkg::Options::=--force-confdef\" -o \"Dpkg::Options::=--force-confold\"  --force-yes   install 'docker-ce=18.03.1~ce-0~ubuntu'' failed: W: --force-yes is deprecated, use one of the options starting with --allow instead.\nE: Version '18.03.1~ce-0~ubuntu' for 'docker-ce' was not found\n", "rc": 100, "stderr": "W: --force-yes is deprecated, use one of the options starting with --allow instead.\nE: Version '18.03.1~ce-0~ubuntu' for 'docker-ce' was not found\n", "stderr_lines": ["W: --force-yes is deprecated, use one of the options starting with --allow instead.", "E: Version '18.03.1~ce-0~ubuntu' for 'docker-ce' was not found"], "stdout": "Reading package lists...\nBuilding dependency tree...\nReading state information...\n", "stdout_lines": ["Reading package lists...", "Building dependency tree...", "Reading state information..."]}
---- Automatically Merged Double Post ----

Also in 6.009 I'm getting this error:
Code:
An exception occurred during task execution. To see the full traceback, use -vvv. The error was: TypeError: create_host_config() got an unexpected keyword argument 'init'
fatal: [127.0.0.1]: FAILED! => {"changed": false, "module_stderr": "Traceback (most recent call last):\n  File \"/tmp/ansible_LnfNgc/ansible_module_docker_container.py\", line 2081, in <module>\n    main()\n  File \"/tmp/ansible_LnfNgc/ansible_module_docker_container.py\", line 2076, in main\n    cm = ContainerManager(client)\n  File \"/tmp/ansible_LnfNgc/ansible_module_docker_container.py\", line 1703, in __init__\n    self.present(state)\n  File \"/tmp/ansible_LnfNgc/ansible_module_docker_container.py\", line 1723, in present\n    new_container = self.container_create(self.parameters.image, self.parameters.create_parameters)\n  File \"/tmp/ansible_LnfNgc/ansible_module_docker_container.py\", line 825, in create_parameters\n    host_config=self._host_config(),\n  File \"/tmp/ansible_LnfNgc/ansible_module_docker_container.py\", line 931, in _host_config\n    return self.client.create_host_config(**params)\n  File \"/usr/local/lib/python2.7/dist-packages/docker/api/container.py\", line 157, in create_host_config\n    return utils.create_host_config(*args, **kwargs)\nTypeError: create_host_config() got an unexpected keyword argument 'init'\n", "module_stdout": "", "msg": "MODULE FAILURE", "rc": 1}
---- Automatically Merged Double Post ----

Code:
ansible is already the newest version (2.6.1-1ppa~bionic).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Hit:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Hit:3 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:4 https://download.docker.com/linux/ubuntu bionic InRelease
Hit:5 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit:6 http://ppa.launchpad.net/ansible/ansible-2.5/ubuntu bionic InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libghc-hopenpgp-dev-2.5.5-1a309:i386' for regex '2.5.5'
Note, selecting 'libkdecorations2-5v5' for regex '2.5.5'
Note, selecting 'libghc-hopenpgp-prof-2.5.5-40aec' for regex '2.5.5'
Note, selecting 'libghc-hopenpgp-dev-2.5.5-40aec' for regex '2.5.5'
Note, selecting 'libghc-hopenpgp-prof-2.5.5-1a309:i386' for regex '2.5.5'
Note, selecting 'libghc-hopenpgp-dev' instead of 'libghc-hopenpgp-dev-2.5.5-40aec'
Note, selecting 'libghc-hopenpgp-prof' instead of 'libghc-hopenpgp-prof-2.5.5-40aec'
Note, selecting 'libghc-hopenpgp-dev:i386' instead of 'libghc-hopenpgp-dev-2.5.5-1a309:i386'
Note, selecting 'libghc-hopenpgp-prof:i386' instead of 'libghc-hopenpgp-prof-2.5.5-1a309:i386'
ansible is already the newest version (2.6.1-1ppa~bionic).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libghc-hopenpgp-dev : Depends: libghc-aeson-dev-1.1.2.0-165b0
                       Depends: libghc-attoparsec-dev-0.13.1.0-822ef
                       Depends: libghc-base-dev-4.9.1.0-d28d6
                       Depends: libghc-base16-bytestring-dev-0.1.1.6-5233a
                       Depends: libghc-base64-bytestring-dev-1.0.0.1-d047c
                       Depends: libghc-bifunctors-dev-5.4.2-df769
                       Depends: libghc-binary-dev-0.8.3.0-b46b7
                       Depends: libghc-binary-conduit-dev-1.2.5-bf906
                       Depends: libghc-byteable-dev-0.1.1-b0cc6
                       Depends: libghc-bytestring-dev-0.10.8.1-45b2c
                       Depends: libghc-bzlib-dev-0.5.0.5-a6fc7
                       Depends: libghc-conduit-dev-1.2.12.1-3c1f0
                       Depends: libghc-conduit-extra-dev-1.1.17-f30bb
                       Depends: libghc-containers-dev-0.5.7.1-cd211
                       Depends: libghc-crypto-cipher-types-dev-0.0.9-897f5
                       Depends: libghc-cryptonite-dev-0.23-24093
                       Depends: libghc-data-default-class-dev-0.1.2.0-38d56
                       Depends: libghc-errors-dev-2.2.2-41851
                       Depends: libghc-hashable-dev-1.2.6.1-04604
                       Depends: libghc-incremental-parser-dev-0.2.5.2-72bab
                       Depends: libghc-ixset-typed-dev-0.3.1.1-f7804
                       Depends: libghc-lens-dev-4.15.4-f1553
                       Depends: libghc-memory-dev-0.14.11-1fadd
                       Depends: libghc-monad-loops-dev-0.4.3-cbc54
                       Depends: libghc-nettle-dev-0.2.0-e3485
                       Depends: libghc-network-dev-2.6.3.2-1688b
                       Depends: libghc-network-uri-dev-2.6.1.0-4a1ab
                       Depends: libghc-newtype-dev-0.2-fbcdd
                       Depends: libghc-openpgp-asciiarmor-dev-0.1-97aa6
                       Depends: libghc-resourcet-dev-1.1.9-53ff1
                       Depends: libghc-securemem-dev-0.1.9-5b6bc
                       Depends: libghc-semigroups-dev-0.18.3-16af2
                       Depends: libghc-split-dev-0.2.3.2-ffd3d
                       Depends: libghc-text-dev-1.2.2.2-5429b
                       Depends: libghc-time-dev-1.6.0.1-37aff
                       Depends: libghc-time-locale-compat-dev-0.1.1.3-22eee
                       Depends: libghc-transformers-dev-0.5.2.0-1d020
                       Depends: libghc-unordered-containers-dev-0.2.8.0-40548
                       Depends: libghc-wl-pprint-extras-dev-3.5.0.5-618ee
                       Depends: libghc-zlib-dev-0.6.1.2-a4a43
                       Conflicts: libghc-hopenpgp-dev:i386 but 2.5.5-3build12 is to be installed
 libghc-hopenpgp-dev:i386 : Depends: libghc-aeson-dev-1.1.2.0-83cd7:i386
                            Depends: libghc-attoparsec-dev-0.13.1.0-c05de:i386
                            Depends: libghc-base-dev-4.9.1.0-5a696:i386
                            Depends: libghc-base16-bytestring-dev-0.1.1.6-c8f62:i386
                            Depends: libghc-base64-bytestring-dev-1.0.0.1-caecc:i386
                            Depends: libghc-bifunctors-dev-5.4.2-a264c:i386
                            Depends: libghc-binary-dev-0.8.3.0-93a7a:i386
                            Depends: libghc-binary-conduit-dev-1.2.5-b3894:i386
                            Depends: libghc-byteable-dev-0.1.1-20e27:i386
                            Depends: libghc-bytestring-dev-0.10.8.1-a98c5:i386
                            Depends: libghc-bzlib-dev-0.5.0.5-ff8ae:i386
                            Depends: libghc-conduit-dev-1.2.12.1-969ff:i386
                            Depends: libghc-conduit-extra-dev-1.1.17-81117:i386
                            Depends: libghc-containers-dev-0.5.7.1-ed950:i386
                            Depends: libghc-crypto-cipher-types-dev-0.0.9-5c37c:i386
                            Depends: libghc-cryptonite-dev-0.23-ac8a2:i386
                            Depends: libghc-data-default-class-dev-0.1.2.0-007b2:i386
                            Depends: libghc-errors-dev-2.2.2-1880d:i386
                            Depends: libghc-hashable-dev-1.2.6.1-86b66:i386
                            Depends: libghc-incremental-parser-dev-0.2.5.2-52a42:i386
                            Depends: libghc-ixset-typed-dev-0.3.1.1-988ca:i386
                            Depends: libghc-lens-dev-4.15.4-92f75:i386
                            Depends: libghc-memory-dev-0.14.11-2319e:i386
                            Depends: libghc-monad-loops-dev-0.4.3-524ad:i386
                            Depends: libghc-nettle-dev-0.2.0-b2b01:i386
                            Depends: libghc-network-dev-2.6.3.2-67243:i386
                            Depends: libghc-network-uri-dev-2.6.1.0-5f962:i386
                            Depends: libghc-newtype-dev-0.2-14080:i386
                            Depends: libghc-openpgp-asciiarmor-dev-0.1-db006:i386
                            Depends: libghc-resourcet-dev-1.1.9-a9bf0:i386
                            Depends: libghc-securemem-dev-0.1.9-59183:i386
                            Depends: libghc-semigroups-dev-0.18.3-06c76:i386
                            Depends: libghc-split-dev-0.2.3.2-4c935:i386
                            Depends: libghc-text-dev-1.2.2.2-4f564:i386
                            Depends: libghc-time-dev-1.6.0.1-fbdf1:i386
                            Depends: libghc-time-locale-compat-dev-0.1.1.3-22eee:i386
                            Depends: libghc-transformers-dev-0.5.2.0-e204f:i386
                            Depends: libghc-unordered-containers-dev-0.2.8.0-8dcba:i386
                            Depends: libghc-wl-pprint-extras-dev-3.5.0.5-c5d76:i386
                            Depends: libghc-zlib-dev-0.6.1.2-f6ce5:i386
                            Conflicts: libghc-hopenpgp-dev but 2.5.5-3build12 is to be installed
 libghc-hopenpgp-prof : Depends: libghc-aeson-prof-1.1.2.0-165b0
                        Depends: libghc-attoparsec-prof-0.13.1.0-822ef
                        Depends: libghc-base-prof-4.9.1.0-d28d6
                        Depends: libghc-base16-bytestring-prof-0.1.1.6-5233a
                        Depends: libghc-base64-bytestring-prof-1.0.0.1-d047c
                        Depends: libghc-bifunctors-prof-5.4.2-df769
                        Depends: libghc-binary-prof-0.8.3.0-b46b7
                        Depends: libghc-binary-conduit-prof-1.2.5-bf906
                        Depends: libghc-byteable-prof-0.1.1-b0cc6
                        Depends: libghc-bytestring-prof-0.10.8.1-45b2c
                        Depends: libghc-bzlib-prof-0.5.0.5-a6fc7
                        Depends: libghc-conduit-prof-1.2.12.1-3c1f0
                        Depends: libghc-conduit-extra-prof-1.1.17-f30bb
                        Depends: libghc-containers-prof-0.5.7.1-cd211
                        Depends: libghc-crypto-cipher-types-prof-0.0.9-897f5
                        Depends: libghc-cryptonite-prof-0.23-24093
                        Depends: libghc-data-default-class-prof-0.1.2.0-38d56
                        Depends: libghc-errors-prof-2.2.2-41851
                        Depends: libghc-hashable-prof-1.2.6.1-04604
                        Depends: libghc-incremental-parser-prof-0.2.5.2-72bab
                        Depends: libghc-ixset-typed-prof-0.3.1.1-f7804
                        Depends: libghc-lens-prof-4.15.4-f1553
                        Depends: libghc-memory-prof-0.14.11-1fadd
                        Depends: libghc-monad-loops-prof-0.4.3-cbc54
                        Depends: libghc-nettle-prof-0.2.0-e3485
                        Depends: libghc-network-prof-2.6.3.2-1688b
                        Depends: libghc-network-uri-prof-2.6.1.0-4a1ab
                        Depends: libghc-newtype-prof-0.2-fbcdd
                        Depends: libghc-openpgp-asciiarmor-prof-0.1-97aa6
                        Depends: libghc-resourcet-prof-1.1.9-53ff1
                        Depends: libghc-securemem-prof-0.1.9-5b6bc
                        Depends: libghc-semigroups-prof-0.18.3-16af2
                        Depends: libghc-split-prof-0.2.3.2-ffd3d
                        Depends: libghc-text-prof-1.2.2.2-5429b
                        Depends: libghc-time-prof-1.6.0.1-37aff
                        Depends: libghc-time-locale-compat-prof-0.1.1.3-22eee
                        Depends: libghc-transformers-prof-0.5.2.0-1d020
                        Depends: libghc-unordered-containers-prof-0.2.8.0-40548
                        Depends: libghc-wl-pprint-extras-prof-3.5.0.5-618ee
                        Depends: libghc-zlib-prof-0.6.1.2-a4a43
                        Conflicts: libghc-hopenpgp-prof:i386 but 2.5.5-3build12 is to be installed
 libghc-hopenpgp-prof:i386 : Depends: libghc-aeson-prof-1.1.2.0-83cd7:i386
                             Depends: libghc-attoparsec-prof-0.13.1.0-c05de:i386
                             Depends: libghc-base-prof-4.9.1.0-5a696:i386
                             Depends: libghc-base16-bytestring-prof-0.1.1.6-c8f62:i386
                             Depends: libghc-base64-bytestring-prof-1.0.0.1-caecc:i386
                             Depends: libghc-bifunctors-prof-5.4.2-a264c:i386
                             Depends: libghc-binary-prof-0.8.3.0-93a7a:i386
                             Depends: libghc-binary-conduit-prof-1.2.5-b3894:i386
                             Depends: libghc-byteable-prof-0.1.1-20e27:i386
                             Depends: libghc-bytestring-prof-0.10.8.1-a98c5:i386
                             Depends: libghc-bzlib-prof-0.5.0.5-ff8ae:i386
                             Depends: libghc-conduit-prof-1.2.12.1-969ff:i386
                             Depends: libghc-conduit-extra-prof-1.1.17-81117:i386
                             Depends: libghc-containers-prof-0.5.7.1-ed950:i386
                             Depends: libghc-crypto-cipher-types-prof-0.0.9-5c37c:i386
                             Depends: libghc-cryptonite-prof-0.23-ac8a2:i386
                             Depends: libghc-data-default-class-prof-0.1.2.0-007b2:i386
                             Depends: libghc-errors-prof-2.2.2-1880d:i386
                             Depends: libghc-hashable-prof-1.2.6.1-86b66:i386
                             Depends: libghc-incremental-parser-prof-0.2.5.2-52a42:i386
                             Depends: libghc-ixset-typed-prof-0.3.1.1-988ca:i386
                             Depends: libghc-lens-prof-4.15.4-92f75:i386
                             Depends: libghc-memory-prof-0.14.11-2319e:i386
                             Depends: libghc-monad-loops-prof-0.4.3-524ad:i386
                             Depends: libghc-nettle-prof-0.2.0-b2b01:i386
                             Depends: libghc-network-prof-2.6.3.2-67243:i386
                             Depends: libghc-network-uri-prof-2.6.1.0-5f962:i386
                             Depends: libghc-newtype-prof-0.2-14080:i386
                             Depends: libghc-openpgp-asciiarmor-prof-0.1-db006:i386
                             Depends: libghc-resourcet-prof-1.1.9-a9bf0:i386
                             Depends: libghc-securemem-prof-0.1.9-59183:i386
                             Depends: libghc-semigroups-prof-0.18.3-06c76:i386
                             Depends: libghc-split-prof-0.2.3.2-4c935:i386
                             Depends: libghc-text-prof-1.2.2.2-4f564:i386
                             Depends: libghc-time-prof-1.6.0.1-fbdf1:i386
                             Depends: libghc-time-locale-compat-prof-0.1.1.3-22eee:i386
                             Depends: libghc-transformers-prof-0.5.2.0-e204f:i386
                             Depends: libghc-unordered-containers-prof-0.2.8.0-8dcba:i386
                             Depends: libghc-wl-pprint-extras-prof-3.5.0.5-c5d76:i386
                             Depends: libghc-zlib-prof-0.6.1.2-f6ce5:i386
                             Conflicts: libghc-hopenpgp-prof but 2.5.5-3build12 is to be installed
E: Unable to correct problems, you have held broken packages.
Hit:1 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease
Hit:3 https://download.docker.com/linux/ubuntu bionic InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease
Hit:5 http://ppa.launchpad.net/ansible/ansible-2.5/ubuntu bionic InRelease
Hit:6 http://security.ubuntu.com/ubuntu bionic-security InRelease
Reading package lists... Done
 
Last edited:

Stupifier

Experienced+
Staff
Donor
Mar 18, 2018
134
56
You need to downgrade Ansible to version 2.5.5. That latest version messed things up.

Code:
sudo apt-get remove ansible
sudo apt-add-repository --remove ppa:ansible/ansible && yes | sudo add-apt-repository ppa:ansible/ansible-2.5 && sudo apt install ansible -y
sudo ansible --version
Verify version is NOT 2.6
sudo apt-mark hold ansible
That will lock Ansible on 2.5.5 version
Then try updating our re-running the preinstaller (it is in the troubleshooting section of PG Menu). should work now. Follow that with whatever it is you wanted to do.
 
  • Like
Reactions: 1 users

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,114
You probably have the ansible error issue for init. I posted the issue on ansible a github and others had the same problem. Type ansible —version you need 2.5. I’ll update the code with hold for 6.009
 
  • Like
Reactions: 1 user

Stupifier

Experienced+
Staff
Donor
Mar 18, 2018
134
56
You probably have the ansible error issue for init. I posted the issue on ansible a github and others had the same problem. Type ansible —version you need 2.5. I’ll update the code with hold for 6.009
I've copy/paste those downgrade commands to at least 3-4 people in the past couple days. Seems to be a common issue amongst new people rolling in
 
  • Like
Reactions: 1 user

bobbarker

Citizen
Original poster
Apr 24, 2018
10
1
I've copy/paste those downgrade commands to at least 3-4 people in the past couple days. Seems to be a common issue amongst new people rolling in
I started on version 5 so I somehow upgraded to the newest ansible version, although I was running apt-get dist-upgrade outside the pg prompts.
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,114
I've copy/paste those downgrade commands to at least 3-4 people in the past couple days. Seems to be a common issue amongst new people rolling in
It’s version 5 users.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending