Discussion Problems setting custom Rclone VFS mount settings

hooper

Legendary Member
Original poster
Staff
Donor
Local time
5:28 PM
Aug 1, 2018
310
116
PG Version
8.6.3
Mount Type
Blitz Encrypted
Server Type
Remote - Dedicated Server
I noticed that the options in the mount settings have been updated since the last time I deployed my mounts. I tried to edit using option C, but each time I set a new value the screen refreshes and fills with the defaults again.

Is anyone else seeing this behavior?

these are the settings that I cannot change

Code:
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
VFS RClone Mount Settings ~ vfs.pgblitz.com
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

RClone Variable Name           Default ~ Current Settings

[1] Buffer-Size                16M        [16M]
[2] Drive-Chunk-Size           128M       [128M]
[3] Dir-Cache-Time             2m         [2m]
[4] VFS-Read-Chunk-Size        128M       [128M]
[5] VFS-Read-Chunk-Size-Limit  off        [off]
[6] VFS-Cache-Mode             writes     [writes]
[7] VFS-Cache-Max-Age          1h         [1h]
[8] VFS-Cache-Max-Size         off        [off]
[Z] Exit

Please read the wiki on how changing these settings impact stability and performance!
After you change these settings, you must redeploy the mounts for them to take effect.
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
 
  • Like
Reactions: timekills

Cacho

Junior Member
Local time
2:28 AM
Feb 1, 2019
10
1
I noticed that the options in the mount settings have been updated since the last time I deployed my mounts. I tried to edit using option C, but each time I set a new value the screen refreshes and fills with the defaults again.

Is anyone else seeing this behavior?

these are the settings that I cannot change

Code:
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
VFS RClone Mount Settings ~ vfs.pgblitz.com
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━

RClone Variable Name           Default ~ Current Settings

[1] Buffer-Size                16M        [16M]
[2] Drive-Chunk-Size           128M       [128M]
[3] Dir-Cache-Time             2m         [2m]
[4] VFS-Read-Chunk-Size        128M       [128M]
[5] VFS-Read-Chunk-Size-Limit  off        [off]
[6] VFS-Cache-Mode             writes     [writes]
[7] VFS-Cache-Max-Age          1h         [1h]
[8] VFS-Cache-Max-Size         off        [off]
[Z] Exit

Please read the wiki on how changing these settings impact stability and performance!
After you change these settings, you must redeploy the mounts for them to take effect.
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
I have the same problem, any solution?
 

Armin

Senior Member
Staff
Local time
8:28 PM
Mar 28, 2018
193
54
same here and after changed to this default I have lots buffering on my plex and emby
 

Admin9705

Administrator
Project Manager
Local time
8:28 PM
Jan 17, 2018
4,795
1,841
i'll work it this evening. should be a simple fix. i had several life things that required attention over the last few days (lawn care and house stuff)
 
  • Like
Reactions: Cacho and Armin
Assists Greatly with Development Costs
T

TheShadow

Guest
Try deploying with the new defaults, then go back and change them.
 
T

TheShadow

Guest
You can edit the file manually yourself until this is fixed.

sudo ntdrive / sudo ntcrypt
 

timekills

Legendary Member
Staff
Donor
Local time
4:28 AM
Sep 12, 2018
357
171
You can edit the file manually yourself until this is fixed.

sudo ntdrive / sudo ntcrypt
It seems to reset back to defaults after you set them manually if you redeploy or check the settings in PGB.
If you go back to check the ntdrive, it looks like its updated, until you redeploy, then if you go back to ntdrive they've been written over.
 

doludizgin

Junior Member
Local time
2:28 AM
Feb 1, 2018
16
0
where can i find values that work better, never had any buffering issues with the old pgmove.
 

Cacho

Junior Member
Local time
2:28 AM
Feb 1, 2019
10
1
i'll work it this evening. should be a simple fix. i had several life things that required attention over the last few days (lawn care and house stuff)
When you fix it, can you comment here? thx
 

Admin9705

Administrator
Project Manager
Local time
8:28 PM
Jan 17, 2018
4,795
1,841
fixed it. it's recommended you goto the settings at least. another team member added fixes and tried to migrate values, but the if statements did not properly change because it could not detect the set values correctly.
 

Admin9705

Administrator
Project Manager
Local time
8:28 PM
Jan 17, 2018
4,795
1,841
ok reverted all the new stuff that caused buffering. If you have the newer updates in your information, please make sure it looks like such

3371

The newer one would have like for 1 as [16MB], make sure it just 16 now.
 

captngimpy

Senior Member
Staff
Local time
7:28 PM
Mar 14, 2018
112
31
As someone that has been holding back my Plex server from upgrading. Thank you all for testing. Also in the same process I have found some things out from converting my whole tdrive from mkv to mp4 and working through the nzbget-mp4 issues. One thing I never thought that would cause buffering causes buffering. I started using the audio codec that was not compatible with a lot of my devices as the primary audio and having a second track stay original. Took a week or so before I figured it out. Luckily one of my users is my mom on her smart TV and I was able to pin point 1 episode that didn't work within the time frame switched it to the original audio and it worked changed the settings and redownloaded the same release and it worked. Never thought incompatible audio codecs would cause a buffering issue.
 

hooper

Legendary Member
Original poster
Staff
Donor
Local time
5:28 PM
Aug 1, 2018
310
116
I think there needs to be a little more care with commits like this. Not sure why this update was part of the stable 8.6.3 release - shouldn't it have gone in something that was 'beta' ?

EDIT:
I am still having issues now with this fix. /mnt/gcrypt, /mnt/gdrive, /mnt/tdrive, /mnt/tcrypt not properly mounted after applying update.
 
Last edited:
  • Like
Reactions: Robo and cruex

hooper

Legendary Member
Original poster
Staff
Donor
Local time
5:28 PM
Aug 1, 2018
310
116
Same Here.

OK, i got this fixed.

you need to pay close attention to the values in the customization menu. make sure you only have numbers between the brackets. Not a value like [64M] for example.

This is an example of a broken config:

Code:
RClone Variable Name           Default ~ Current Settings

[1] Buffer-Size                16M        [64] MB
[2] Drive-Chunk-Size           64M        [128] MB
[3] Dir-Cache-Time             2M         [1441] Minutes
[4] VFS-Read-Chunk-Size        64M        [128] MB
[5] VFS-Read-Chunk-Size-Limit  2G         [5] GB
[6] VFS-Cache-Mode             off        [writes]
[7] VFS-Cache-Max-Age          168H       [168] Hours
[8] VFS-Cache-Max-Size         100G       [100G] GB
[Z] Exit
You would need to edit the values so that there are just numbers and not characters also. so [100G] should be changed to be just [100].

This is what @Admin9705 pointed out in his reply above - i just didn't understand what was being said.
 
  • Like
Reactions: jeffcameron

Create an account or login to comment

You must be a member in order to leave a comment

Create account

Create an account on our community. It's easy!

Log in

Already have an account? Log in here.

Similar threads


Maintenance Donations

Recommend NewsGroups

      Up To a 58% Discount!