Discussion - PSA: SLOW HETZNER SERVER FIX | PlexGuide.com

Discussion PSA: SLOW HETZNER SERVER FIX

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

meteo

Experienced
Original poster
Staff
Nov 6, 2018
66
34
Gday folks. Recently setup servers in Finland with Hetzner and needed to share some info. Long story short there are issues with the Ubuntu install scripts which will likely cap your server @ 500mbit upload. Still not entirely sure what's going on and I've been working with staff to narrow it down. Recommend installing plexguide with Debian instead, which will fix this problem!
 
  • Like
Reactions: 2 users

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,117
good to know!
 

bubbadk

Governer
Staff
Mar 18, 2018
319
78
will it work if i back all up on ubuntu with plexguide backup, and then restore with plexguide restore on Debian :unsure:
 

meteo

Experienced
Original poster
Staff
Nov 6, 2018
66
34
Don't see why not. Backups are just configs and metadata. Ubuntu is based off Debian. :)
Best test if your server is having problems first. If using blitz, check if the upload seems to caps around 50mb/s via blitzui. Run speedtest-cli --server 864 (one of the fastest public local servers) a few times. Issue is confirmed is on dedicated boxes based in Finland, Ubuntu 18.04, all variants and rescue system installs. Not sure about the Germany servers. Speed problem is with entire OS not just a plexguide install, probably worth doing generally speaking if running dedicated housed in Finland.
 

bubbadk

Governer
Staff
Mar 18, 2018
319
78
I never run over 35-40 mb/sec anyway. And it's a German server I have. Is there any way of testing if my German server is capped :)
 

meteo

Experienced
Original poster
Staff
Nov 6, 2018
66
34
30ish is about normal for a single file push, can creep into 40-50 range when blitz raid mode pushes. hetnzer servers if using blitz and multi-file should easily hit 80-110mb/s. Mine now sits around 100mb/s on Debian when it was only hitting 50/mbs max on Ubuntu. Can check with speedtest-cli to germany as well, I'm just not sure which is the fastest server. Spam speedtest-cli in terminal a few times until you figure out which is fastest server (some can't do 1gbit~), then find number and use --server # after speedtest-cli. It should be obvious but if not pushing past 500mbit there are problems. Another option would be using iperf servers to run tests on (google), hetzner might even run their own you could use, I know online.net have some.
 
  • Like
Reactions: 1 user

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,117
haha ya basic speed test, there is a speed test module in the settings, but you know; some advertise one thing and you get one total other thing.
 

meteo

Experienced
Original poster
Staff
Nov 6, 2018
66
34
@bubbadk
Hmmm, yes and no. Enter following in terminal
ethtool -K enp0s31f6 tso off gso off
change enp# to your ethernet name if that didn't work.
multi-file upload again and see if it jumps toward 100! :D
 
  • Like
Reactions: 1 user

Maslygan

Experienced
Donor
Dec 1, 2018
87
18
Just got from 500mbit/s to 770+mbit/sec in upload by that commandline, thanks! ex-42 in finland with i7-7700 and intel i219 nic
 

meteo

Experienced
Original poster
Staff
Nov 6, 2018
66
34
@Qlogic
that is the fancy blitzui app/container that gets auto-deployed if you are using pgblitz. :)
no need or use for it if just using move since it's easy to see what single transfers are doing.
 

pviljaka

Citizen
Nov 10, 2018
11
3
I run Ubuntu server on VPS Hetzner Finland and usually see around 300-400Mbits/s transfer to Google (single file). I dont need more speed. This works just fine, no complaints. Good performance for the monthly pay :)
 

hawk2g

Active
May 2, 2018
38
21
I run Ubuntu server on VPS Hetzner Finland and usually see around 300-400Mbits/s transfer to Google (single file).
I too have never seen it upload a single file above 44MB/s. If it uploads 2 at the same time, they are both 44MB/s. Any more they just share the maximum 1Gbps uplink. One thing that does bother me is, what is after the yellow truck icon if it were to upload faster?
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,117

SirTranceALoT

Governer
Staff
Jun 14, 2018
319
147
Thnx for this, I'll have a go at it. I use servers in germany and have the slow upload speed too. Download is alright though. It doesn't only reflect the upload to google but running more servers seem to effect transfers between them too. This is a very big help. thnx!
 

pviljaka

Citizen
Nov 10, 2018
11
3
I too have never seen it upload a single file above 44MB/s. If it uploads 2 at the same time, they are both 44MB/s. Any more they just share the maximum 1Gbps uplink. One thing that does bother me is, what is after the yellow truck icon if it were to upload faster?
Are you talking about Mbits or Mbytes? I was talking Megabits, aka 300-400MBits is around 40Mbytes which is quite normal. Here is a attached screenshots while I was uploading single .mkv file to Gsuite.

edit: oh i saw you said "i too" so were both were talking about the same speeds :)
 

Attachments

Last edited:

mtan93

Citizen
Jul 29, 2018
9
5
I have the same issue with a Hetzner Auction Server, getting Max 502Mbps Upload on speedtest-cli.

I would be interested as to what is causing the problem and any potential fix as it's not practical for me to change OS as I use the server for other things as well as PG...
 

3days

Experienced
Jan 24, 2018
55
6
@bubbadk
Hmmm, yes and no. Enter following in terminal
ethtool -K enp0s31f6 tso off gso off
change enp# to your ethernet name if that didn't work.
multi-file upload again and see if it jumps toward 100! :D

Just getting this:


[email protected] ~ # ethtool -K eth0 tso off gso off
Cannot get device udp-fragmentation-offload settings: Operation not supported
Cannot get device udp-fragmentation-offload settings: Operation not supported

Can't find any other name for ethernet? eth0 is listed under ifconfig atleast..
 
Last edited:

Recommend NewsGroups

      Up To a 58% Discount!

Trending