Radarr - Radarr - Folder is not writable by user abc: (again) | PlexGuide.com

Radarr Radarr - Folder is not writable by user abc: (again)

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

genoxide

Citizen
Original poster
Aug 29, 2018
11
1
I've been researching this issue for awhile now, I took down a older server and reinstalled PG on the same box with a fresh install of ubuntu 18.04, for some reason radarr will not let me import as it states the folder is not writable. I'm not overly advanced in docker so i'm sure i'm missing something and i'm pulling my hair out ( what little i have left ) trying to get this to work. I have reinstalled pg 3 times with the same result. Is the folder ( located on a team drive ) carrying over permissions from the old install or what. I guess I need clarification on what exactly I am doing wrong. I should note Sonarr does not have this issue importing to from the TV folder on the same team drive.
 

nachobel

Experienced+
Staff
Donor
Feb 2, 2019
146
39
Just to clarify - you're using PG Blitz and using Sonarr and Radarr with ____ to download items, and then move them from the downloaded folder into your /mnt/unionfs/tv/movies/etc folders? Where is the error you're seeing? Do files get moved into /mnt/unionfs and then don't upload? Or are they not even showing up in /mnt/move? Can Radarr see the files in the download folder? Please do an ls -lah /mnt and see if all the folders are owned/in the group of your 1000 user.

You shouldn't be seeing an issue with your TD if you set it up IAW the Wiki and set your uploaders to "Contributors".
 

genoxide

Citizen
Original poster
Aug 29, 2018
11
1
the problem is in the import process on radarr the existing movies folder in my team drive is what im referingg to so /mnt/unionfs/movies/ <- is not writable. I haven't even gotten to the indexer part. I'm just trying to import what i have already.
 

genoxide

Citizen
Original poster
Aug 29, 2018
11
1
###Update###
Fixed the issue, thnx.

attached..

what i find puzzling in i have installed pg many of times on different computers no problem. im sure its something small i'm missing somewhere.

2996
 
Last edited:

nachobel

Experienced+
Staff
Donor
Feb 2, 2019
146
39
What was the issue? Looks like permissions...if it's solved please update the thread accordingly. Thanks!
 

genoxide

Citizen
Original poster
Aug 29, 2018
11
1
logged in portainer and opened a command terminal to the docker. I ran ls -ld /mnt/unionfs/movies and checked r&w permissions.

then I tried to create a junk file in the directory which was a success, but also made no sense, un tell i thought about i'd seen a radarr_write_test file i the unionfs/movies/ folder. Opened my team drive in a browser window and looked at the activity for that file and saw it had a changed timestamp. i then deleted the file and tried to add the folder again in radarr.. it was a succcess.
 

doludizgin

Citizen+
Feb 1, 2018
17
0
In some other post about this issue i've read about removing the test_radarr_writable flie. Did this rebooted and problem gone.
 

genoxide

Citizen
Original poster
Aug 29, 2018
11
1
:cautious: lol yea that was mine... good you got it all sorted. It was kicking my butt for sure.
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,112
usually it's a reboot. if you deployed radarr first then deployed the mounts; this would require a reboot also because raddar started with like, hey no mounts. it doesn't know that the exist if you deployed after.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending