Discussion Radarr/Sonarr file paths PG8.1

Marinerdevil

PG Sergeant
PG Donor
Jan 6, 2019
38
21
8
Reactions
21 0 0
#1
PG Version
8.1.0
Server Type
Remote - VPS
Upgraded my server over at Hetzner and did a total redo of PG. Aside from portainer being wonkie(replied to another thread about it) everything went great. One question, what up wit da file paths in Sonarr/Radarr. In 8.0.12 it was /mnt/unionfs/movies,tv.....Not no more!
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,682
1,987
113
Reactions
1,987 0 0
#3
Assists Greatly with Development Costs

armin0012002

PG 2nd Lieutenant
Tech Lead
Mar 28, 2018
111
42
28
Reactions
42 0 0
#4
but not /mnt/unionfs/MOVIES ?
cause i did /mnt/unionfs/Tv for sonarr and it work
 

armin0012002

PG 2nd Lieutenant
Tech Lead
Mar 28, 2018
111
42
28
Reactions
42 0 0
#6
thats is my problem I did changed all of that
but still getting that error
 

Attachments

armin0012002

PG 2nd Lieutenant
Tech Lead
Mar 28, 2018
111
42
28
Reactions
42 0 0
#8
believe me from yesterday I did any trick I know on this
ill go play with it more to see what is the issue
I read somewhere even if you have one movie with wrong path u get this
so i think have check 17000 movie path haha
 

Admin9705

Administrator
Project Manager
Jan 17, 2018
4,682
1,987
113
Reactions
1,987 0 0
#9
believe me from yesterday I did any trick I know on this
ill go play with it more to see what is the issue
I read somewhere even if you have one movie with wrong path u get this
so i think have check 17000 movie path haha
yes one movie can cause it
 

timekills

PG 1st Lieutenant
Mod | Tech Lead
Coder
PG Donor
Sep 12, 2018
256
172
43
Reactions
172 0 0
#10
@armin0012002 @Marinerdevil
If all your movies and TV shows are found, that error only affects a*al retentiveness.
HOWEVER

For Radarr to remove the old path (AFTER you've mass changed the movies to the new one!)
1. Go to "Add Movies:
2. Start typing in a new movie (you're not actually going to add it, just choose one you don't have like Ishtar or Gigli)
3. In the "Path" Section, press the drop-down arrow to choose another path. The new one you've mass changed everything to AND the old one should show up as options.
4. Press the red "x" at the right of the old one.
5. Stop/restart the Radarr docker container.
6. Et voila

For Sonarr it's the same unless you're using the V3/beta that is the default in 8.x then it's much easier:
1. Go to Series/Import
2. Click the black "x" at the end of the home path you want to remove (Again - AFTER you've mass moved everything!)
 
Assists Greatly with Development Costs

timekills

PG 1st Lieutenant
Mod | Tech Lead
Coder
PG Donor
Sep 12, 2018
256
172
43
Reactions
172 0 0
#13
You are correct about just one movie retaining the old path will cause the error. When you're mass changing 1700+ movies it *should* work, but we all know Radarr. I wouldn't be surprised if it errored/timed out. Although given your efforts, I assume when you mass changed them it gave you the pop-up saying all good/1700+ movies changed.
 

armin0012002

PG 2nd Lieutenant
Tech Lead
Mar 28, 2018
111
42
28
Reactions
42 0 0
#14
yeah because of that might missing one movie I did mass change 3 times :)
 

CyborgPirate

PG Master Sergeant
Aug 22, 2018
50
10
8
Reactions
10 0 0
#16
If you have radarr set up to import from RSS feeds then you need to change the import folder four each RSS feed otherwise new movies from the feed come in to the old path still.
 

armin0012002

PG 2nd Lieutenant
Tech Lead
Mar 28, 2018
111
42
28
Reactions
42 0 0
#17
If you have radarr set up to import from RSS feeds then you need to change the import folder four each RSS feed otherwise new movies from the feed come in to the old path still.
movies importing with no issue just annoying error for missing root cant get rid of
 

CyborgPirate

PG Master Sergeant
Aug 22, 2018
50
10
8
Reactions
10 0 0
#18
movies importing with no issue just annoying error for missing root cant get rid of
There might be a few movies that have the old root still. I found that some wouldn't change in the mass editor due some error. I ended up going through the ones with the old root individually(think there were only 7 out of my library of 8000 so didn't take long) to change the root path on each one manually. Some of them errored saying that a movie with that path already existed. In those cases I just deleted the movie completely and redownload it. If you have a load that aren't changing then you may need another option.