Discussion - Rclone maxing out CPU | PlexGuide.com

Discussion Rclone maxing out CPU

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

murkr

Experienced
Original poster
Donor
Nov 5, 2018
99
32
Hey All

Not sure if anyone else is facing the same issue, however I'm having real problems with rclone maxing out my CPU (i7 4770k). Whenever files get moved to gdrive in rclone, the CPU goes mental. I can run 5+ transcodes at once and CPU is more than happy to do so, but as soon as the files are being moved to gdrive the server becomes unresponsive!

Any suggestions? Can I limit this? As I can't even have 1 direct stream running when it does that, and with the rate I am downloading, that's pretty often!
 

Porkie

Experienced+
Staff
Aug 9, 2018
142
68
I see that plexguide installs cloudplow, Im not sure if or how it uses it but in cloudplow you can restrict speeds while plex streams are happening.

Code:
  "plex": {
      "enabled": false,
      "url": "https://plex.domain.com",
      "token": "",
      "poll_interval": 60,
      "max_streams_before_throttle": 1,
      "rclone": {
          "throttle_speeds": {
              "0": "1000M",
              "1": "50M",
              "2": "40M",
              "3": "30M",
              "4": "20M",
              "5": "10M"
          },
          "url": "http://localhost:7949"
      }
  }
You would need to ask Admin I guess if this would actually work as its unclear if cloudplow is even used.
 

murkr

Experienced
Original poster
Donor
Nov 5, 2018
99
32
I see that plexguide installs cloudplow, Im not sure if or how it uses it but in cloudplow you can restrict speeds while plex streams are happening.

Code:
  "plex": {
      "enabled": false,
      "url": "https://plex.domain.com",
      "token": "",
      "poll_interval": 60,
      "max_streams_before_throttle": 1,
      "rclone": {
          "throttle_speeds": {
              "0": "1000M",
              "1": "50M",
              "2": "40M",
              "3": "30M",
              "4": "20M",
              "5": "10M"
          },
          "url": "http://localhost:7949"
      }
  }
You would need to ask Admin I guess if this would actually work as its unclear if cloudplow is even used.
Hey, I did try that a couple of days ago and put the speeds right down but it didn't make a difference :(

EDIT: I'm thinking part of the reason is that it uses up all of the bandwith available, I've changed max streams before throttle to 0 and 0 speed to 20M and then the ones below to similar but slightly less.
My guess is as well as that, that it does a number of uploads at once (in my case I can see it doing 8, so when they're done it has to delete up to 8 files from the server at close intervals, also not sure if reading 8 files at once increases HDD read speeds).

I will monitor this at lower speeds and files
 
Last edited:

murkr

Experienced
Original poster
Donor
Nov 5, 2018
99
32
Just wanted to update on this, to hopefully help anyone else with the same issue.

I've been running the new settings for a few days and so far no problems, I've set the speeds to 9MB (as I will probably be uploading more than 750GB on some days so I believe this gets around the API ban) and set rclone to work with only 2 files at once. This has decrease load on CPU by over 70%.

I guess perhaps it didn't like 8 files being read at once at high speed, torrents and nbz's (and sometimes transcodes) running all at once. Now I've got the exact same setup, but as I have 6GB of storage locally, it doesn't bother me if the upload takes longer.
 

fr0sty

Veteran
Staff
Donor
Jul 8, 2018
184
54
Hey can you please direct me to the file location to edit this please? Since ive cranked up the DL im experiencing the same.


EDIT- sudo nano /opt/appdata/plexguide/move.sh
I'm testing --transfers=2

I think i need to restart service too - sudo systemctl restart move.service
 
Last edited:

murkr

Experienced
Original poster
Donor
Nov 5, 2018
99
32
Hey can you please direct me to the file location to edit this please? Since ive cranked up the DL im experiencing the same.


EDIT- sudo nano /opt/appdata/plexguide/move.sh
I'm testing --transfers=2

I think i need to restart service too - sudo systemctl restart move.service
Sorry just seen this, did you sort it?
 

DeadPool

Elite
Staff
May 2, 2018
213
74
guys,
dont think this is located there anymore...
Im interested as also getting hi cpu and system loads and would like to tweak transfers too(if it is still doable).
dP


PS apologies for resurrecting old af thread but...
AT LEAST I'M NOT ASKING YOU ABOUT INDEXER INVITES! haha-sigh
 

kiityman

Active
Donor
Feb 1, 2020
31
4
If Plexguide uses cloudplow, you can just limit bandwidth per Plex stream. Not sure if it does though since admin is very secretive.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending