Server Error: Spontaneous Kernel Crash | PlexGuide.com

Server Error: Spontaneous Kernel Crash

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

mtan93

Citizen
Original poster
Jul 29, 2018
9
5
Hi all,

has anyone seen this error before or could anyone be of assistance decoding it?
I understand it's a PCIe error and after some Googling, I can see that its unrecoverable hence the crashing and not responding.

Code:
dpc 0000:00:1b.0:pcie010: DPC error containment capabilities: Int Msg #0, RPExt+ PoisonedTLP+ SwTrigger+ RP PIO Log 4, DL_ActiveErr+
Docker swapiness is enabled.
Processor Policy changed to Max
Hetzner EX62-NVMe

I'm going to keep digging however I thought it wouldn't hurt to post here to see if anyone has seen it before.
 

doob

Administrator
Project Manager
Jun 7, 2020
851
448
the nvme is defect

made a system check and backups
 
  • Like
Reactions: 1 user

mtan93

Citizen
Original poster
Jul 29, 2018
9
5

mtan93

Citizen
Original poster
Jul 29, 2018
9
5
I can confirm that this appears (a whole day without a lock-up/crash, as opposed to every 3-5 hours) to have solved our issue on our EX62-NVMe:

Edit the file /etc/default/grub and modify GRUB_CMDLINE_LINUX_DEFAULT, I also use consoleblank=0 so I can ask Hetzner to connect a KVM in case of a crash and still be able to see the console should the system be unresponsive.

GRUB_CMDLINE_LINUX_DEFAULT="consoleblank=0 intel_idle.max_cstate=1"
If the line exists in some form but is commented out then delete the existing line and paste this line in its place ENSURE THERE IS NO HASH # OTHERWISE THE CODE WILL NOT WORK. Others in the Proxmox forum can't comprehend what commenting out means.

Next apply the grub configuration:

# update-grub

Output:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.3.18-1-pve
Found initrd image: /boot/initrd.img-5.3.18-1-pve
Found linux image: /boot/vmlinuz-5.3.13-3-pve
Found initrd image: /boot/initrd.img-5.3.13-3-pve
done

And then

reboot

Source: https://forum.proxmox.com/threads/r...e-6-1-auf-ex62-nvme-hetzner.63597/post-294285

Thank you for your input @Edrock200 & @doob , all help has been appreciated. If the problem re-appears I will try the kernel update suggested.
 
  • Like
Reactions: 1 user

Edrock200

MVP
Staff
Nov 17, 2019
544
195
I can confirm that this appears (a whole day without a lock-up/crash, as opposed to every 3-5 hours) to have solved our issue on our EX62-NVMe:

Edit the file /etc/default/grub and modify GRUB_CMDLINE_LINUX_DEFAULT, I also use consoleblank=0 so I can ask Hetzner to connect a KVM in case of a crash and still be able to see the console should the system be unresponsive.

GRUB_CMDLINE_LINUX_DEFAULT="consoleblank=0 intel_idle.max_cstate=1"
If the line exists in some form but is commented out then delete the existing line and paste this line in its place ENSURE THERE IS NO HASH # OTHERWISE THE CODE WILL NOT WORK. Others in the Proxmox forum can't comprehend what commenting out means.

Next apply the grub configuration:

# update-grub

Output:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.3.18-1-pve
Found initrd image: /boot/initrd.img-5.3.18-1-pve
Found linux image: /boot/vmlinuz-5.3.13-3-pve
Found initrd image: /boot/initrd.img-5.3.13-3-pve
done

And then

reboot

Source: https://forum.proxmox.com/threads/r...e-6-1-auf-ex62-nvme-hetzner.63597/post-294285

Thank you for your input @Edrock200 & @doob , all help has been appreciated. If the problem re-appears I will try the kernel update suggested.
Awesome info! Thanks for circling back!
 
  • Like
Reactions: 1 user

ItherNiT

Citizen
Oct 22, 2019
12
2
I can confirm that this appears (a whole day without a lock-up/crash, as opposed to every 3-5 hours) to have solved our issue on our EX62-NVMe:

Edit the file /etc/default/grub and modify GRUB_CMDLINE_LINUX_DEFAULT, I also use consoleblank=0 so I can ask Hetzner to connect a KVM in case of a crash and still be able to see the console should the system be unresponsive.

GRUB_CMDLINE_LINUX_DEFAULT="consoleblank=0 intel_idle.max_cstate=1"
If the line exists in some form but is commented out then delete the existing line and paste this line in its place ENSURE THERE IS NO HASH # OTHERWISE THE CODE WILL NOT WORK. Others in the Proxmox forum can't comprehend what commenting out means.

Next apply the grub configuration:

# update-grub

Output:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.3.18-1-pve
Found initrd image: /boot/initrd.img-5.3.18-1-pve
Found linux image: /boot/vmlinuz-5.3.13-3-pve
Found initrd image: /boot/initrd.img-5.3.13-3-pve
done

And then

reboot

Source: https://forum.proxmox.com/threads/r...e-6-1-auf-ex62-nvme-hetzner.63597/post-294285

Thank you for your input @Edrock200 & @doob , all help has been appreciated. If the problem re-appears I will try the kernel update suggested.

Thnx! I had a similar issue and this fixed it!
 
  • Like
Reactions: 1 user

Edrock200

MVP
Staff
Nov 17, 2019
544
195
What was your similar issue if you don't mind me asking? Would be helpful to compile a list of issues that this fixes as many use ex62 servers (myself included.)
 

Edrock200

MVP
Staff
Nov 17, 2019
544
195
I can confirm that this appears (a whole day without a lock-up/crash, as opposed to every 3-5 hours) to have solved our issue on our EX62-NVMe:

Edit the file /etc/default/grub and modify GRUB_CMDLINE_LINUX_DEFAULT, I also use consoleblank=0 so I can ask Hetzner to connect a KVM in case of a crash and still be able to see the console should the system be unresponsive.

GRUB_CMDLINE_LINUX_DEFAULT="consoleblank=0 intel_idle.max_cstate=1"
If the line exists in some form but is commented out then delete the existing line and paste this line in its place ENSURE THERE IS NO HASH # OTHERWISE THE CODE WILL NOT WORK. Others in the Proxmox forum can't comprehend what commenting out means.

Next apply the grub configuration:

# update-grub

Output:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.3.18-1-pve
Found initrd image: /boot/initrd.img-5.3.18-1-pve
Found linux image: /boot/vmlinuz-5.3.13-3-pve
Found initrd image: /boot/initrd.img-5.3.13-3-pve
done

And then

reboot

Source: https://forum.proxmox.com/threads/r...e-6-1-auf-ex62-nvme-hetzner.63597/post-294285

Thank you for your input @Edrock200 & @doob , all help has been appreciated. If the problem re-appears I will try the kernel update suggested.
I tried applying this to a test 9900 box. Just fyi, with console blank=0 included, my igpu wouldn't initialize. I removed that and it worked.
 

mtan93

Citizen
Original poster
Jul 29, 2018
9
5
Awesome info! Thanks for circling back!
No worries, I find most of my fixes in forums, I looked here first before going to Google, hopefully this will help a few more users and stop them having to scour the web.

I tried applying this to a test 9900 box. Just fyi, with console blank=0 included, my igpu wouldn't initialize. I removed that and it worked.
I shall test HW transcoding later and if it doesn't work I'll remove the console output, cheers bud!
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending