Discussion - Single Folder not loading from UnionFS after months of working | PlexGuide.com

Discussion Single Folder not loading from UnionFS after months of working

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

newguy5000

Citizen
Original poster
Apr 11, 2020
6
0
Version 8.7.5 .
After a reboot, my movies folder is no longer reachable. Everything else is still reachable. Folder structure below. I've not changed anything.
1. Checked the other server that's mounted to the same share, and all file are available and functional through Plex.
2. I've tried to remount with PG Clone Mount Transport. Still not functional.
3. Currently trying ( https://plexguide.com/threads/too-many-folders-in-movies.7083/ ) suggestion of: ls -alR /mnt/unionfs/movies

unionfs
> Fitness
> TV
> TV Japanese
> Movies
Post automatically merged:

I'm still importing movies to the GDrive. Really not understanding what's the issue.
 
Last edited:

Edrock200

MVP
Staff
Nov 17, 2019
726
260
Can u see /mnt/unionfs/Movies on the host? Have you restarted your Plex container since this started? How many folders are in movies roughly?
 
  • Like
Reactions: 1 user

newguy5000

Citizen
Original poster
Apr 11, 2020
6
0
1. It's only 14000 movies.
2. The other server was able to load the same folder structure without issues, both from putty and through plex. And I preformed a reboot on it as well.
3. Would a restart make it have to load all the folders?
4. How do i prevent this from happening again?
5. how do I mark this close as of 5 minutes ago, all movies load? It still didn't work an hour ago.

Thank you for all your help.
 

Edrock200

MVP
Staff
Nov 17, 2019
726
260
1. It's only 14000 movies.
2. The other server was able to load the same folder structure without issues, both from putty and through plex. And I preformed a reboot on it as well.
3. Would a restart make it have to load all the folders?
4. How do i prevent this from happening again?
5. how do I mark this close as of 5 minutes ago, all movies load? It still didn't work an hour ago.

Thank you for all your help.
Check your rclone settings. Make sure dir cache time is set to the max allows, 7000+ mins or something along those lines.
 
  • Like
Reactions: 1 user

Edrock200

MVP
Staff
Nov 17, 2019
726
260
Check your rclone settings. Make sure dir cache time is set to the max allows, 7000+ mins or something along those lines.
Rclone doesn't have cache persist through a reboot. So I have 2 crontab line items, @reboot and @daily that runs LS -alR /mnt/unionfs to keep the dir cache fresh. But you will still need to up your dir cache time in pgclone rclone options.

Also 14k folders in one root folder isn't a great practice. You should prob break it up into a few folders with no more than ~3000 per.
 
  • Like
Reactions: 1 user

Recommend NewsGroups

      Up To a 58% Discount!

Trending