Discussion - [Solved] Move.Service failed to start | PlexGuide.com

Discussion [Solved] Move.Service failed to start

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

jcrmit

Citizen+
Original poster
Mar 19, 2018
25
5
Have migrated to latest PG version, including all apps, backups, etc.
I edited the move.sh file (in cloudcmd) and now the move.service is failing to start. Notice permission changed so set back to 755. Also undid my edit - rebooted, restart, stop service, etc. - but this is the error I am getting. Can Anyone assist? Thanks

● move.service - Move Service Daemon
Loaded: loaded (/etc/systemd/system/move.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Thu 2019-01-17 12:11:12 AEDT; 3s ago
Process: 8189 ExecStart=/bin/bash /opt/appdata/plexguide/move.sh (code=exited, status=2)
Main PID: 8189 (code=exited, status=2)

Jan 17 12:11:12 [servername] systemd[1]: move.service: Service hold-off time over, scheduling restart.
Jan 17 12:11:12 [servername] systemd[1]: move.service: Scheduled restart job, restart counter is at 5.
Jan 17 12:11:12 [servername] systemd[1]: Stopped Move Service Daemon.
Jan 17 12:11:12 [servername] systemd[1]: move.service: Start request repeated too quickly.
Jan 17 12:11:12 [servername] systemd[1]: move.service: Failed with result 'exit-code'.
Jan 17 12:11:12 [servername] systemd[1]: Failed to start Move Service Daemon.
 
Last edited:
M

MrDoob

Guest
why you edit the files ??
and do you have the permission chnaged ??

the best options for anything to change is -

cp <name-of-the-file> <name-of-the-file-backup> && nano <name-of-the-file>

then edit

after edit /// via putty or NotePad ++ // give then chmod 755 <name-of-the-file> && service <name-of-the-service> restart


ist this failed you can edit this again .

but you have always the original as backup
 

jcrmit

Citizen+
Original poster
Mar 19, 2018
25
5
Edited the file - which I've done in the previous version to move other downloads that were not managed by sonarr, radarr, etc. It worked well, but I should have following the advice and backed up the file before tinkering.

Can you suggest;
  1. If I should leave the move.sh alone - what is the best way to do this - for example I set rclone to move files to the /mnt/move folder. This way - I can start a download or have the rss pick up the file, download and transfer to gdrive and appear in a custom library in plex (mainly for sports). Should I do this with a cron job instead? UPDATE: reedited the move.sh file as per MrDoob's advice and working again. I think it's best to avoid cloudcmd and use terminal.
  2. How can I get the move.service up and running again? Edit: solved by restoring a version from a test build! ;) Move.Service is running again.
Thanks
 
Last edited:
  • Like
Reactions: 1 user

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,114
awesome work mr.doob
 
  • Like
Reactions: 1 user

Recommend NewsGroups

      Up To a 58% Discount!

Trending