Radarr - Sonarr/Radarr Connections and Portainer networks | PlexGuide.com

Radarr Sonarr/Radarr Connections and Portainer networks

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

drpepper28

Citizen+
Original poster
Sep 5, 2018
16
3
So I've been trying to add my Plex server as a connection for the past two hours...
3042
I'll spare all the details of all the things i tried that didn't work but i could never connect. I ended up looking at my Networks through portainer. I had bridge (left) and plexguide (right) 3043
but noticed that bridge did not have the plex docker.

So i added the plex docker to the 'bridge' network and boom my plex connection with radarr and sonarr tested successfully.

NOW, my question is, will adding my plex docker to the bridge network cause any issues? So far it seems to be running smoothly and it seems like it should have been added to that network by default but idk.

Thanks!
 

bodgeup

Experienced
Staff
FreeLancer
Donor
Aug 12, 2018
99
33
If you installed the apps using the PGBlitz installer menus you shouldn't have needed to touch your networks. What was the problem to start with?? Radarr and Sonarr can see /mnt/unionfs/ and so can Plex see /mnt/unionfs/ with regards to the network traffic between the apps you need to use the url you get at the end of the app install script the Internal App to App url. I.E. http://sonarr:8989 and http://radarr:7878. Plex should also be accessible by the other apps on https://plex:32400. My instances haven't needed me to change the containers networks at all yet??
 

drpepper28

Citizen+
Original poster
Sep 5, 2018
16
3
Actually messing with the network stuff did cause issues and yes usually everything works out of the box. The issue was as hooper suggested below: use plex as the hostname. I was using the ip of Plex (for my case: 192.168.1.218:32400) . Thanks for the help
 

hooper

Governer
Staff
Donor
Aug 1, 2018
310
119
@drpepper28 to connect to plex you would use 'plex' as the hostname and '32400' forr the port. then add your plex username and pass and that should be it. This uses the plexguide docker network for the connection.
 

drpepper28

Citizen+
Original poster
Sep 5, 2018
16
3
THANKS.
I was using the IP of Plex for the hostname instead "plex". It's weird because I've been using ip's to connect all the different services together, this is the first time I had to use "plex"
 

hooper

Governer
Staff
Donor
Aug 1, 2018
310
119
You should change all the IP addresses you use to names like this. plex, sonarr, radarr, qbittorrent, etc. IP addresses can change on reboot, these names don't ever change.
 

drpepper28

Citizen+
Original poster
Sep 5, 2018
16
3
I have the IP statically set through the OS as well as the router as of now. How do I set it to names like you said?
 

coolhaus

Citizen+
Dec 27, 2018
18
2
On my remote server I have Traefik, Port Guard, Port Shield and Google OAuth working correctly but I can't seem to make radarr (haven't tried with sonarr etc but imagine it would be the same) talk to qbittorrent.

Can't seem to get the apps to talk internally with the docker containers. I've tried:
  1. Using the internal network ip visible in portainer and port number
  2. Referencing the app name 'qbittorrent' and port
Previously on testing with a basic install (apps accessible through ip + portnumber) I've just used the remote server ip and port number and this worked just fine. Any ideas appreciated.
 

indochild

Active
Mar 13, 2018
46
20
On my remote server I have Traefik, Port Guard, Port Shield and Google OAuth working correctly but I can't seem to make radarr (haven't tried with sonarr etc but imagine it would be the same) talk to qbittorrent.

Can't seem to get the apps to talk internally with the docker containers. I've tried:
  1. Using the internal network ip visible in portainer and port number
  2. Referencing the app name 'qbittorrent' and port
Previously on testing with a basic install (apps accessible through ip + portnumber) I've just used the remote server ip and port number and this worked just fine. Any ideas appreciated.
You have to exempt qbittorent from oauth. it can't communicate through the oauth. thats what happened to me.
 

bloodray

Active
May 2, 2019
41
12
You have to exempt qbittorent from oauth. it can't communicate through the oauth. thats what happened to me.
Do you know how to exempt qbittorrent from OAuth? If you know please post the details or a link to the resource. Thanks
 

indochild

Active
Mar 13, 2018
46
20
Do you know how to exempt qbittorrent from OAuth? If you know please post the details or a link to the resource. Thanks
It’s in the oauth settings in pgblitz. You have to go to exempt apps then choose which ones you want to exempt then redeploy oauth
 
  • Like
Reactions: 1 user

Recommend NewsGroups

      Up To a 58% Discount!

Trending