Sonarr - Sonarr - Unable to connect to indexer | PlexGuide.com

Sonarr Sonarr - Unable to connect to indexer

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
Hi All,

Really confused about something, Jackett is running fine and I've connected t successfully to my IPTorrents account and I can browse manually for torrent and it pulls in results. The issue I'm having is Sonarr is unable to connect, I've done everything properly (copy torznab feed into Sonarr URL, copy API key from Jackett into Sonarr API key) but no matter what I try it will not connect?

Steps I've tried
  • change torznab url from reverse proxy (Jackett.domain_name/api/v2.0/indexers/iptorrents/results/torznab/) to "Jackett.portainer IP/api/xxx..." and local IP
  • try with HTTP and HTTPS
  • update plexguide
  • re-install Jackett/Sonarr

Notes
To initially connect to IPT through Jackett I have to first enable the VPN otherwise the connection is refused, once the settings window appears for the tracker I change the URL to one in the list that bypasses the block as IPT provides a good number of alternative URL's to bypass. From there I can disable VPN and connect through Jackett absolutely fine with the new IPT URL.

Sonarr Logs (from Portainer)



[v3.0.0.348] System.Xml.XmlException: Data at the root level is invalid. Line 1, position 570.


at System.Xml.XmlTextReaderImpl.Throw (System.Exception e) [0x00027] in <7b3b892e8f8b41f9919da262956da569>:0


at System.Xml.XmlTextReaderImpl.Throw (System.String res, System.String arg) [0x00029] in <7b3b892e8f8b41f9919da262956da569>:0


at System.Xml.XmlTextReaderImpl.Throw (System.String res) [0x00000] in <7b3b892e8f8b41f9919da262956da569>:0


at System.Xml.XmlTextReaderImpl.ParseRootLevelWhitespace () [0x0012c] in <7b3b892e8f8b41f9919da262956da569>:0


at System.Xml.XmlTextReaderImpl.ParseDocumentContent () [0x002d4] in <7b3b892e8f8b41f9919da262956da569>:0


at System.Xml.XmlTextReaderImpl.Read () [0x0008c] in <7b3b892e8f8b41f9919da262956da569>:0


at System.Xml.Linq.XContainer.ReadContentFrom (System.Xml.XmlReader r) [0x00025] in <1cf8e2246b7d4f3bb72fb0123b1da80a>:0


at System.Xml.Linq.XContainer.ReadContentFrom (System.Xml.XmlReader r, System.Xml.Linq.LoadOptions o) [0x00005] in <1cf8e2246b7d4f3bb72fb0123b1da80a>:0


at System.Xml.Linq.XDocument.Load (System.Xml.XmlReader reader, System.Xml.Linq.LoadOptions options) [0x00024] in <1cf8e2246b7d4f3bb72fb0123b1da80a>:0


at System.Xml.Linq.XDocument.Parse (System.String text, System.Xml.Linq.LoadOptions options) [0x00016] in <1cf8e2246b7d4f3bb72fb0123b1da80a>:0


at System.Xml.Linq.XDocument.Parse (System.String text) [0x00000] in <1cf8e2246b7d4f3bb72fb0123b1da80a>:0


at NzbDrone.Core.Indexers.Newznab.NewznabCapabilitiesProvider.ParseCapabilities (NzbDrone.Common.Http.HttpResponse response) [0x00006] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Indexers\Newznab\NewznabCapabilitiesProvider.cs:88




Drone.Core.Indexers.Newznab.NewznabCapabilitiesProvider.FetchCapabilities (NzbDrone.Core.Indexers.Newznab.NewznabSettings indexerSettings) [0x000d8] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Indexers\Newznab\NewznabCapabilitiesProvider.cs:74


at NzbDrone.Core.Indexers.Newznab.NewznabCapabilitiesProvider+<>c__DisplayClass4_0.<GetCapabilities>b__0 () [0x00000] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Indexers\Newznab\NewznabCapabilitiesProvider.cs:35


at NzbDrone.Common.Cache.Cached`1[T].Get (System.String key, System.Func`1[TResult] function, System.Nullable`1[T] lifeTime) [0x00069] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Common\Cache\Cached.cs:81


at NzbDrone.Core.Indexers.Newznab.NewznabCapabilitiesProvider.GetCapabilities (NzbDrone.Core.Indexers.Newznab.NewznabSettings indexerSettings) [0x00020] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Indexers\Newznab\NewznabCapabilitiesProvider.cs:35


at NzbDrone.Core.Indexers.Torznab.Torznab.get_PageSize () [0x00000] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Indexers\Torznab\Torznab.cs:22


at NzbDrone.Core.Indexers.Torznab.Torznab.GetRequestGenerator () [0x00000] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Indexers\Torznab\Torznab.cs:26


at NzbDrone.Core.Indexers.HttpIndexerBase`1[TSettings].TestConnection () [0x00007] in M:\BuildAgent\work\63739567f01dbcc2\src\NzbDrone.Core\Indexers\HttpIndexerBase.cs:334




[Warn] SonarrErrorPipeline: Invalid request Validation failed:


-- Unable to connect to indexer, check the log for more details
 
S

subse7en

Guest
Jackett.portainer ??

First off, if you're using Hydra, you add each tracker you added to jackett to Hydra. You don't connect jackett to sonarr.

Please read the relevant wikis on GitHub (link at top menu).
 
S

subse7en

Guest
Also your url should be jackett:9117 not jacket.portainer and whatever else you tried.
 

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
jackett:9117

Sorry, Im not sure why I wrote Jackett.portainer I simply used the same default Torznab URL from Jackett and within that URL (https://jackett.domain/api/v2.0/indexers/iptorrents/results/torznab/) I changed Jackett.domain to the Jackett IP listed in portainer and also changed jackett.domain to my local IP just to see if it would work. In theory, for IPT it really should be a case of copy-pasting the torznab link and api key from Jackett and Sonarr should work perfectly especially given the fact Jackett communicates fine with IPT.. I don't understand why mine doesn't :/
 

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
Jackett.portainer ??

First off, if you're using Hydra, you add each tracker you added to jackett to Hydra. You don't connect jackett to sonarr.

Please read the relevant wikis on GitHub (link at top menu).
It's strange as PlexGuide wiki doesn't appear to have NZBHydra listed and I also don't remember hearing many people mention NZBHydra on the reddit posts I used to read prior to trying Plexguide. Either way, NZBhydra is facing the same issue, NZBHydra add custom torznab > copy paste torznab from Jackett, copy paste API key and again "Unable to parse indexer output"

portainer log
<meta charset="utf-8">

<meta content="width=300, initial-scale=1" name="viewport">

<meta name="google-site-verification" content="LrdTUW9psUAMbh4Ia074-BPEVmcpBxF6Gwf0MD78sDR">

2019-02-04 23:55:25.920 WARN --- [0.0-5076-exec-1] o.n.indexers.capscheck.NewznabChecker : [IP: 192.168.0.45] Connection check with indexer ipt failed with message: Unable to parse indexer output

2019-02-04 23:55:39.338 ERROR --- [ool-11-thread-1] org.nzbhydra.indexers.IndexerWebAccess : Unable to parse indexer output at line 2 and column 10 with error message: DOCTYPE is disallowed when the feature "http://apache.org/xml/features/disallow-doctype-decl" set to true.. Excerpt:
 
Last edited:

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
Okay, so I researched an error I got when trying to use Torznab in nzbhydra from Jackett and came across one result https://support.microfocus.com/kb/doc.php?id=7020985

This guy talks about reverse proxy which I believe is handled by Traefik? so I opened ports in PG Guard so I could actually use Jackett:9177 instead of Jackett.domain and it worked. So something in Traefic mustn't be configured correctly as the link above shows a solution of "add option XML_PARSE_ALLOW_DTD true to AG Cluster -> Edit -> Reverse Proxy/Authentication -> ESP Global Options" So in the mean-time I'm going to dig a bit deeper but help would be appreciated as I can't imagine I'm the only one with this issue.
 
S

subse7en

Guest
jackett:9117 is the internal traefik url. As long as apps are on the same server, you should use it. Don't use your domain or ips. Port guard has nothing to do with jackett:9117 working, portguard is for external access, not internal to internal.
I have several trackers setup in jackett, added to Hydra, Hydra added to arr.

Here's my url
http://jackett:9117/api/v2.0/indexers/iptorrents/results/torznab/

You don't want to use docker IPs, they change. You don't want to use your domain because you're increasing the latency which is very important for arr / hydra not to have timeouts.

I don't have ports open either. It's a configuration issue on your end.
 
  • Like
Reactions: 1 user

klimbo123

Citizen
Feb 5, 2019
4
0
jackett:9117 is the internal traefik url. As long as apps are on the same server, you should use it. Don't use your domain or ips. Port guard has nothing to do with jackett:9117 working, portguard is for external access, not internal to internal.
I have several trackers setup in jackett, added to Hydra, Hydra added to arr.

Here's my url
http://jackett:9117/api/v2.0/indexers/iptorrents/results/torznab/

You don't want to use docker IPs, they change. You don't want to use your domain because you're increasing the latency which is very important for arr / hydra not to have timeouts. Pnr Status TextNow VPN

I don't have ports open either. It's a configuration issue on your end.
exactly i think it's a configuration issue on his end
 
Last edited:

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
jackett:9117 is the internal traefik url. As long as apps are on the same server, you should use it. Don't use your domain or ips. Port guard has nothing to do with jackett:9117 working, portguard is for external access, not internal to internal.
I have several trackers setup in jackett, added to Hydra, Hydra added to arr.

Here's my url
http://jackett:9117/api/v2.0/indexers/iptorrents/results/torznab/

You don't want to use docker IPs, they change. You don't want to use your domain because you're increasing the latency which is very important for arr / hydra not to have timeouts.

I don't have ports open either. It's a configuration issue on your end.

Right, so the reverse proxy (Traefik) is useful for accessing the installed applications without needing to remember ip's and ports and as you've mentioned, access the programs externally. communication between the apps running on the same server is much quicker using the port address as they're directly communicating with each other as opposed to going through the domain (GoDaddy) in my case just to eventually communicate back to Jackett that's already running on the same server.. it's quite obvious now how stupid it was to use a domain when my applications run on the same server but I think because I follow the guide it sort of take a out the questioning of things and it was an oversight for sure haha.

sorry to be noobish but I think like many others who don't have any other experience other than installing a Plex media server on a windows environment this whole setup and undersranding the flow of information is pretty substantial so im just trying to wrap my head around everything haha.

As for accessing the applications through their port such as Jackett/xxxx I honestly don't know how I could have messed anything up, I had a fresh install of Ubuntu 18.04 and installed PlexGuide as shown in the videos..


Also, a little off topic but Traefik runs as far as I'm aware as the reverse proxy and ssl has always worked but iv'e never once been able to access the GUI.. whether or not that has anything to do with the issues I'm not sure
 
Last edited:

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
exactly i think it's a configuration issue on his end
Any idea where to start with an issue like that? As I previously replied I quite literally installed Ubuntu 18.04 and then PlexGuide straight after and followed everything as shown in the videos/wiki so "in theory" everything should have worked. whether or not this will be another one of those cases where simply disabling and re-enabling the port blocks will fix itself I'm not sure but I'll 're enable the port blocks later and see if Sonarr to communicate with the torznab URL being pointed at Jacket:xxxx (forgot the port number hence the xxxx)
 

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
I don't use hydra. I have my sonnar/ radarr connected to the indexer Https://jackett.domain.com/the rest

That works for me. Jackett connects to torrent sites and feeds the results to sonarr.
Really strange! see I think the issue with using the domain for sonarr to access jackett through the torznab url has something to do with Traefic as the logs from both sonarr and hydra both state something about parsing/XML but how mines gone wrong is beyond me..
 

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
My jackett in sonarr looks like this , check and ensure yours is correct as well. https://jackett.domain.com/api/v2.0/indexers/hdme/results/torznab/
Hi mate,

Thanks for the link, my torznab link from Jackett is

"http://jackett.domain/api/v2.0/indexers/iptorrents/results/torznab/"

which appears to be fine, however replacing domain with Jackett:9117 with ports open works fine. I'm just closing my ports again now and waiting for the containers to re-deploy and see if Sonarr can still connect to Jackett through the port number as it didn't make sense why it can't with the ports closed. Assuming that goes well I'll replace Jackett:9177 with Jackett.mydomain and see if it works but I do believe it has something to do with the reverse proxy as it seems to be unable to read the request Also, as the other chap had pointed out it doesn't actually make sense for me to have the Torznab URL use the domain because all of my services (Jackett, Sonarr, Radarr) run on the same server so using my domain just creates an added step when it's not necessary and slows things down compared to directly accessing with the port. Either way though, it would be good to understand why it doesn't work for future reference.

Okay, after writing all of that above the portainers are all back up and running but again the connection fails. Hydra, however, displays it couldn't connect to:

"jackett/172.19.0.4:9177" which is the IP address for Traefik in portainer, the odd thing is though despite Traefik appearing to work due to seeing SSL certs and being able to access appname.domain I can never actually get Traefik itself to load in the browser... I really think the issue is Traefik
 

timetrex

Elite
Staff
Oct 22, 2018
231
59
Traefik wont load in the browser unless you do it from vnc on the server itself or ssh.
The dashboard for traefik doesnt appear to be in the container ports 8080.
If you can get to sites like radarr etc then traefik is working
 

MrSweet1991

Experienced+
Original poster
Jan 30, 2019
118
4
Traefik wont load in the browser unless you do it from vnc on the server itself or ssh.
The dashboard for traefik doesnt appear to be in the container ports 8080.
If you can get to sites like radarr etc then traefik is working
Brilliant,

I noticed on the Plexguide youtube video that he doesn't access Traefik either, out of curiosity if you open Portainer > traefik > Logs do you get this?

"httputil: ReverseProxy read error during body copy: unexpected EOF" ?
 

timetrex

Elite
Staff
Oct 22, 2018
231
59
just a couple of

time="2019-02-01T16:54:50+01:00" level=error msg="vulcand/oxy/forward/websocket: Error when copying from client to backend

Dont have that error that you have. Would assume then something is wrong with your deployment of traefik.
 

coolhaus

Citizen+
Dec 27, 2018
18
2
jackett:9117 is the internal traefik url. As long as apps are on the same server, you should use it. Don't use your domain or ips. Port guard has nothing to do with jackett:9117 working, portguard is for external access, not internal to internal. I have several trackers setup in jackett, added to Hydra, Hydra added to arr.
subse7en
Just wanted to say thanks literally saved my afternoon! The missing piece in this particular puzzle. To potentially help others:

I've previously setup my own domain, with subdomains for apps and got Traefik working with PG Shield. The problem I had was coming back to sonarr and radarr to find that my previously setup indexes were throwing up errors (they were working fine before Traefik). I proceeded to setup the indexers afresh with the direct URL and API taken straight from Jackett (which incidentally had remained working).

However the above URL didn't work. I tried different combinations of URL's, sometimes appending the port, sometimes not but the exact format eluded me. I'm pretty new to using Docker but I knew that referencing the IP address of a container is a bad idea but what worked for me was exactly as subse7en suggests:

The format of the URL should http://jackett:9117/...
Where 'jackett' is the container label in portainer
Note the use of http:// (accessed from within the internal network so https:// doesn't work)

Hope this might help others. Loving the community of this forum keep up the good work!
 

mackattack57

Experienced
Apr 14, 2019
64
14
Hi mate,

Thanks for the link, my torznab link from Jackett is

"http://jackett.domain/api/v2.0/indexers/iptorrents/results/torznab/"

which appears to be fine, however replacing domain with Jackett:9117 with ports open works fine. I'm just closing my ports again now and waiting for the containers to re-deploy and see if Sonarr can still connect to Jackett through the port number as it didn't make sense why it can't with the ports closed. Assuming that goes well I'll replace Jackett:9177 with Jackett.mydomain and see if it works but I do believe it has something to do with the reverse proxy as it seems to be unable to read the request Also, as the other chap had pointed out it doesn't actually make sense for me to have the Torznab URL use the domain because all of my services (Jackett, Sonarr, Radarr) run on the same server so using my domain just creates an added step when it's not necessary and slows things down compared to directly accessing with the port. Either way though, it would be good to understand why it doesn't work for future reference.

Okay, after writing all of that above the portainers are all back up and running but again the connection fails. Hydra, however, displays it couldn't connect to:

"jackett/172.19.0.4:9177" which is the IP address for Traefik in portainer, the odd thing is though despite Traefik appearing to work due to seeing SSL certs and being able to access appname.domain I can never actually get Traefik itself to load in the browser... I really think the issue is Traefik



DUDDDDDEEEEEEEEEEEEEEE

I figured out the issue.

So, the solution requires you to use the VNC-XFCE container. I used it to login to ipTorrents from my server's Firefox browser. I had to login to jackett internally there too at jackett:9117.

I figured out the problem when I installed Jackett on my local desktop and ipTorrents worked fine locally. So, I used firefox to grab a local cookie for my Hetzner server. I then was able to connect using jackett:9117 and keep it working.

The only thing I have not done yet is to reboot my server and see if the connection survives the reboot.

However, I can try that another time. Let me know if you don't pick up this completely because I am exhausted and have no idea if this makes sense on a re-read.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending