Plex - Takes a long time to skip backwards | PlexGuide.com

Plex Takes a long time to skip backwards

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

matt314159

Experienced+
Original poster
Donor
Nov 29, 2018
136
28
This is a small thing, but I wonder if there's a server buffer setting or something that I can tweak.

Running PG 8.7.5 on Hetzner EX42-NVME in Helsinki, Finland. I use Cloudflare, but this happened before I set up CF, too. My STB is a 2019 Nvidia Shield Pro

So here's the deal: I can start up a stream, and it begins playing fairly quickly, and then it builds a forward-facing buffer so before too long if I skip ahead 30s, it's an instant jump. However, if I try to skip BACKWARDS, it has to re-buffer the stream all over again, and I swear it feels like it takes longer to skip back than it does to begin playing the initial stream.

It's totally functional, I just get tired of waiting if I go "what did they say?" and try to jump back 10 seconds, then wait while it takes 10s to buffer before it begins playing again. Since Plex builds a buffer AHEAD on the Shield, is there a parameter by which it can be made to hold onto a minute or two of TRAILING buffer as well?
 
  • Like
Reactions: 1 user

matt314159

Experienced+
Original poster
Donor
Nov 29, 2018
136
28
Anybody? is this normal behavior or is there room for improvement with my setup via some config parameters changes or something like that?
 

doob

Administrator
Project Manager
Jun 7, 2020
851
448
Its normal skip backwards is not the best idea
 

Edrock200

MVP
Staff
Nov 17, 2019
545
195
You can try lowering your VFS chunk and VFS max chunk settings. Unfortunately I don't think the VFS cache setting is configurable via the menu. If you want to try to edit your mount service file you can add a line like:
vfs-cache-max-size=10G
But you would need to set that after any of clone deoyment as it will revert.

Otherwise I have found.that these settings offer better zap time
sudo pg
PG clone
Rclone settings
VFS chunk size = 32M
VFS max chunk size = 512M

The max chunk is less important. The way rclone works is it starts out by requesting the VFS chunk size. If the subsequent requests are sequential to the same file, it doubles the chunk size request until it hits max chunk, until you stop, seek or switch to another file, then it starts over.

So with the above settings, if playing the same file continuously the requested chunk sizes would be in this order 32, 64, 128, 256, 512, 512, 512, etc. You can play with different chunk sizes to see which works best for you, e.g. 8, 16, or 64M, but note I don't believe a quick deployment applies the settings to the mount. Having a smaller initial chunk size usually equates to faster load (zap) times. In general people keep this higher to limit API hits, but as you can see due to how rclone does sequential requests, it doesn't add significant API hits. After you change the settings you need to restart your mount and your containers to be safe:
sudo docker stop plex emby jellyfin sonarr radarr lidarr
sudo systemctl restart gdrive
sudo systemctl restart gcrypt
sudo systemctl restart tdrive
sudo systemctl restart tcrypt
sudo systemctl restart pgunion
sudo docker start plex emby jellyfin sonarr radarr lidarr

If you don't have some of those mount types or containers you will get an error for those. That's ok.
 
  • Like
Reactions: 1 users

Recommend NewsGroups

      Up To a 58% Discount!

Trending