Tautulli - Tautulli showing docker network IP addresses instead of actual client IP address | PlexGuide.com

Tautulli Tautulli showing docker network IP addresses instead of actual client IP address

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

hooper

Governer
Original poster
Staff
Donor
Aug 1, 2018
310
119
I have PG setup in the standard way but am using the cloudflare CDN. something I have noticed since making this change a few months back is that now Tautulli shows 172.18.0.18 for the IP address of all playback entries on the history page. the IP corresponds to the Treafik proxy.

Is anyone else seeing something similar? I occasionally get an actual IP address in the report, but the vast majority are always this same 172.18.0.8 IP address.

Any idea how to fix this so I can see the actual IP addresses of clients playing content on my system?
 
  • Like
Reactions: 1 user

hooper

Governer
Original poster
Staff
Donor
Aug 1, 2018
310
119
Here is a screengrab of what I am talking about

1544211436132.png
 

hooper

Governer
Original poster
Staff
Donor
Aug 1, 2018
310
119
Update: It seems like this is an issue with how Plex handles X-Forwarded-For and X-Real-IP headers for clients that are ipv6.

Interesting thread here https://forums.plex.tv/t/plex-api-s...ded-for-x-real-ip-with-ipv6-clients/175705/29

As a temporary workaround I disabled ipv6 in cloudflare per the thread above. A CURL command like the following will do this if you have ipv6 enabled. remember to substitute your email and API information where needed.

Code:
curl -X PATCH "https://api.cloudflare.com/client/v4/zones/023e105f4ecef8ad9ca31a8372d0c353/settings/ipv6" \
     -H "X-Auth-Email: [email protected]" \
     -H "X-Auth-Key: c2547eb745079dac9320b638f5e225cf483cc5cfdda41" \
     -H "Content-Type: application/json" \
     --data '{"value":"off"}'
I will run with ipv6 turned off at cloudflare for a while to see if this workaround really does resolve this issue.
 
  • Like
Reactions: 1 users

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,114
sounds good. when i get to the traeifk rewrite in 7.6; it will be better setup.
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending