Discussion - Traefik breaks after reboot | PlexGuide.com

Discussion Traefik breaks after reboot

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

kamos69

Experienced+
Original poster
Donor
Apr 22, 2018
131
71
This started today. I use Traefik with Cloudflare. Whenever I reboot, I cannot access portainer or any other site on the server and I see this error when do "sudo pgblitz":

Code:
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
⛔  Emergency & Warning Log Generator | Visit - http://emlog.pgblitz.com
━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━
NOTE: This can be turned [On] or Off in Settings!

1. Warning: Apps Cannot Be Accessed! Ports are Closed & Traefik is not enabled! Either deploy traefik or open your ports (which is worst for security)

Acknowledge Info | Press [ENTER]
I've just deployed on a new server and the same thing is happening on that one. I have to redeploy Traefik to get it working again.

Is there any way I can check why this is happening? It'
 

kamos69

Experienced+
Original poster
Donor
Apr 22, 2018
131
71
What is in the Traefik log in Portainer?
This is all I'm seeing:

Code:
time="2019-05-15T10:42:01+02:00" level=error msg="vulcand/oxy/forward/websocket: Error when copying from client to backend: websocket: close 1006 (abnormal closure): unexpected EOF"
 

kamos69

Experienced+
Original poster
Donor
Apr 22, 2018
131
71
Just some context, in case it helps. I am on a temp ban from Google. Getting Error 429: Rate Limit Exceeded, rateLimitExceeded for all requests. And for some reason Watchtower is broken as well, getting the following error when I try to re-install:

Code:
TASK [Pull Stored Data] ********************************************************
Wednesday 15 May 2019  10:07:34 +0200 (0:00:00.052)       0:00:00.052 *********
fatal: [127.0.0.1]: FAILED! => {"changed": true, "cmd": "cat /tmp/watchtower.set", "delta": "0:00:00.001357", "end": "2019-05-15 10:07:34.131981", "msg": "non-zero return code", "rc": 1, "start": "2019-05-15 10:07:34.130624", "stderr": "cat: /tmp/watchtower.set: No such file or directory", "stderr_lines": ["cat: /tmp/watchtower.set: No such file or directory"], "stdout": "", "stdout_lines": []}
        to retry, use: --limit @/opt/coreapps/apps/watchtower.retry

PLAY RECAP *********************************************************************
127.0.0.1                  : ok=0    changed=0    unreachable=0    failed=1
I'm hoping all of this is related to the google issue.
 

Sejrup

Experienced
Jan 11, 2019
91
32
Yeah might be. I haven't seen above entries in the log before, so no help from here :-(
 

Admin9705

Administrator
Project Manager
Donor
Jan 17, 2018
5,156
2,112
Those are not. Nothing has changed for treafik or watchtower. You should have a second test domain and a test box. Hetzner cloud is a good way to go to test on the cheap.
 

kamos69

Experienced+
Original poster
Donor
Apr 22, 2018
131
71
OK. Traefik is working again but watchtower is now broken. I'll log a separate thread for that. Please close this one.
 

timmeh

Experienced+
Feb 14, 2019
130
31
I’ve started having this problem as well. What solved it for you guys? How can I see whether I’ve had an API van?
 

Recommend NewsGroups

      Up To a 58% Discount!

Trending