Discussion - Traefik, having a mare! | PlexGuide.com

Discussion Traefik, having a mare!

  • Stop using Chrome! Download the Brave Browser via >>> [Brave.com]
    It's a forked version of Chrome with native ad-blockers and Google's spyware stripped out! Download for Mac, Windows, Android, and Linux!
Welcome to the PlexGuide.com
Serving the Community since 2016!
Register Now

Proxim0

Citizen
Original poster
Dec 3, 2019
3
0
Hi all,

So tonight I have managed to run out of API calls on Lets Encrypt like a clown, there must be something that I am missing, at one point I had it working but I could not change my Top Domain, then I tried again and ran out of API calls.

I am using GoDaddy and I have both my A and * pointed to the ipaddress of the remote server. I have created the API and inserted the API key and secret into PG. DNS delay check is set to 60 but I have tried 120 also.

Questions:

  1. When running through Traefik should Port Gaurd be on or off, I'm assuming off until I have the SSL certificate for my domain?
  2. Does port guard being on stop the Traefik setup from working?
  3. Do I have to re-run Traefik if I want to change my Top Level Domain, I had portainer set but then I wanted to use a Wordpress site, I changed it in PGPress but it just stayed as portainer, I also tried to change it to Monitorr to see if that would work but it also did not.
Thanks for any info you can provide :)
 

artiume

Active
Mar 19, 2018
44
18
The let's encrypt rate limit should clear after an hour. Power down traefik to clear the ban.

Port guard won't affect traefik. It's the one service that isn't touched.

Yes, you have to respin traefik to change your main domain
 

Proxim0

Citizen
Original poster
Dec 3, 2019
3
0
I thought that you had to leave port guard open when setting up Traefik, once I opened portguard it went straight through. Previous to that it was failing, I thought maybe it wasn’t allowing it to talk externally to Traefik. Not sure why it worked then.

after further reading I think it’s mentions that until you have Traefik setup you should close ports as it will stop the ipv4 addresses from working.

I have had no problems changing my top level domain since my certificate worked in Traefik, the only one that doesn’t work is Wordpress, in the PGPress menu it goes through some motions but no where near as many as when I change the Traefik TLD. Are you saying you have to redeploy it to use another? Using an Api call? Don’t know if I dare mess with that again.
 
Last edited:

Recommend NewsGroups

      Up To a 58% Discount!

Trending